LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-20-2004, 02:00 PM   #1
coldy
Member
 
Registered: Nov 2002
Distribution: Debian GNU/Linux, Gentoo
Posts: 75

Rep: Reputation: 15
When I run /sbin/lilo on Debian it says /proc/partitions does not exist


Hello friends, I am using Debian GNU/Linux 3.0r2
I was precompiled my kernel before month maybe, and today I have this error, well before 2 days I preinstalled Windows, than rebooted the system using the first CD of Debian and try to install lilo in MBR.
Can someone help me how to solve this error when I run /sbin/lilo please:
Quote:
Warning: '/proc/partitions does not exist disk scan bypassed
Added Debian *
Skipping /vmlinuz.old
Added Windows
My kernel is 2.4.24
thanks in advance
 
Old 03-21-2004, 08:28 AM   #2
GregLee
Member
 
Registered: Feb 2004
Location: Waimanalo, HI
Distribution: Slackware 10, Fedora 6
Posts: 308

Rep: Reputation: 30
Verify that lilo is right -- from the command line: "ls /proc", "cat /proc/partitions". Perhaps there is no /proc filesystem at all. If not, create one. (1) Check that you requested a proc filesystem in configuring your kernel with "grep PROC /usr/src/linux/.config", which should return "CONFIG_PROC_FS=y". If not, reconfigure your kernel, asking for a proc filesystem, and recompile. (2) Make sure the directory /proc exists, and if not "mkdir /proc". (3) Mount the proc filesystem with "mount proc /proc". Then you should see /proc/partitions. If not, I dunno.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/proc/partitions does not exist Impaler Linux - Software 5 12-10-2008 10:54 PM
run /sbin/lilo after update IF you use LILO (don't know) jdblick Suse/Novell 3 12-28-2004 03:06 PM
Upgraded kernel, lilo.conf, didn't run /sbin/lilo dtashima Linux - Newbie 4 10-18-2004 11:21 AM
Forgot to run /sbin/lilo justin_p Slackware 3 08-26-2004 06:53 AM
zip drive accessed when I run /sbin/lilo major.tom Slackware 1 06-16-2004 07:40 PM


All times are GMT -5. The time now is 10:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration