LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-17-2007, 11:31 AM   #1
jmhalloy
LQ Newbie
 
Registered: Nov 2007
Location: Wezembeek-Oppem Belgium
Distribution: OpenSuSE 10.3
Posts: 8

Rep: Reputation: 0
what is the replacement of the samba "smbmount" command


I used to use the samba "smbmount" command in order to access a network drive with an imbedded samba server so it looks like a windows server.

In order to mount the samba share to a local empty directory on my linux desktop, the command was:

smbmount //the_server_ip_address/my_userid_on_the_server ./the_local_dir -o username=my_userid_on_the_server,password=my_password_on_the_server,workgroup=WORKGROUP

Unfortunately, after upgrading from suse 10.0 to 10.3, the "smbmount" command does not exist anymore as well as the smbfs which is replaced with cifs

The question is:
What is the replacement of the "smbmount" command and how to use it ?

Regards

Jean-Michel Halloy
 
Old 11-17-2007, 11:53 AM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Samba was not compiled with smbfs support commands and features. Use the mount command with -t cifs option.

Brian
 
Old 11-17-2007, 11:58 AM   #3
Baloo_PNW
LQ Newbie
 
Registered: Jun 2006
Posts: 12

Rep: Reputation: 0
Samba has given me nothing but headaches since the switch to cifs.

I'm afraid I can't help you with smbmount, but smb4k http://smb4k.berlios.de/ is a KDE GUI for mounting samba shares.
After some initial issues (http://www.linuxforums.org/forum/sus...ba-woes-2.html), I've got it working in openSuse 10.3.
 
Old 11-18-2007, 06:49 AM   #4
jmhalloy
LQ Newbie
 
Registered: Nov 2007
Location: Wezembeek-Oppem Belgium
Distribution: OpenSuSE 10.3
Posts: 8

Original Poster
Rep: Reputation: 0
Hi,

I already try the mount -t cifs command with the following syntax before posting for this:

mount -t cifs //xxx.xxx.xxx.xxx/my_userid ./backup -o userid=my_userid,password=my_password

but I receive the following error

mount error 20 = Not a directory
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

I read the man page but did not find the possible syntax error

I'm able to see the server directorys from konqueror with smb://xxx.xxx.xxx.xxx

any idee ?
 
Old 11-18-2007, 11:07 AM   #5
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Is /backup a hidden directory since placing a . infront of it?
If so mount it to just a directory called /backup.

Brian
 
Old 11-19-2007, 02:38 AM   #6
jmhalloy
LQ Newbie
 
Registered: Nov 2007
Location: Wezembeek-Oppem Belgium
Distribution: OpenSuSE 10.3
Posts: 8

Original Poster
Rep: Reputation: 0
Hi Brian and everybody,

I added the dot to be ./backup to retry after having the same result with /backup

Regards

Jean-Michel
 
Old 11-19-2007, 04:06 PM   #7
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Got no idea. Used the exact command and directory name and mounted to problem. If nothing in that directory I would delete and recreate.

Brian
 
Old 11-20-2007, 06:03 AM   #8
jmhalloy
LQ Newbie
 
Registered: Nov 2007
Location: Wezembeek-Oppem Belgium
Distribution: OpenSuSE 10.3
Posts: 8

Original Poster
Rep: Reputation: 0
Hi everybody,

Trying yesterday with smbclient and was able to connect to my remote drive, but this "ftp like" environment does not allow me to perform my easy backup scripts at night.
:-( why did they suppress the smbmount command &@#...!!!
Plan to try putting all the stuff into /etc/fstab with user,noauto... maybe this evening

Regards

Jean-Michel
 
Old 12-04-2007, 06:18 AM   #9
jmhalloy
LQ Newbie
 
Registered: Nov 2007
Location: Wezembeek-Oppem Belgium
Distribution: OpenSuSE 10.3
Posts: 8

Original Poster
Rep: Reputation: 0
Hi,

Still not able to mount the share, even in the fstab since the mount.cifs or mount -t cifs do not work.
I'd like to know how konqueror is able to perform the stuff.
It seems my Packard-Bell NetStore 3500 device does not support CIFS at all.
I plan to try a new firmware on it.
@+

Jean-Michel
 
Old 02-19-2008, 04:11 PM   #10
tke1384
LQ Newbie
 
Registered: Feb 2008
Posts: 8

Rep: Reputation: 1
What works for me

I know this is a little late but I'm looking for a solution to a similar problem but have found a work around for what you are asking about. I would get the same error when I knew there was a folder by that name. I'm working on a Fedora box connecting to an XP machine on a 2003 domain. I found that if I used the command mount -t cifs /remote_machine/shared_folder /local_folder -o username=name@domain.com it would map just fine or you could use mount.cifs /remote_machine/shared_folder /local_folder -o username=name@domain.com hope this works for you. Happy Bash.
 
Old 02-21-2008, 09:36 AM   #11
paklan
LQ Newbie
 
Registered: Jun 2006
Distribution: OpenSuSe
Posts: 5

Rep: Reputation: 0
That looks correct to me.
The package cifs-mount replaces the use of smbmount and (I think) is installed as a default when installing samba and samba client.
Create the mount directory as normal and use
mount -t cifs //machine/service /mountpoint -o "user=winuser,password=hfhf,domain=workgroup"


Notice the double slash on the front of the machine name.

You should now also be able to set this up in fstab and allow non root users to mount and unmount the service.

See the man page for mount(8) and mount.cifs(8).
"man mount"
OR
"man mount.cifs"

Patrick.
 
Old 06-03-2008, 11:59 AM   #12
jmhalloy
LQ Newbie
 
Registered: Nov 2007
Location: Wezembeek-Oppem Belgium
Distribution: OpenSuSE 10.3
Posts: 8

Original Poster
Rep: Reputation: 0
Hi,

The mount -t cifs did not work even after installing a new firmware.
Since I do not receive any answer from the NAS vendor, I'll never by any packard bell anything
anymore.
 
Old 12-17-2008, 01:05 PM   #13
JohnnySnowman
LQ Newbie
 
Registered: Dec 2008
Posts: 1

Rep: Reputation: 0
this worked for me

Sorry for the late post... just joined this forum.

in the man entry for mount.cifs, note the information about setting security mode.

adding sec=ntlmv2 worked fine for me connecting to w2k3 service pack 2 box.

Hope this helps somebody out.

-JS
 
  


Reply

Tags
command, how, replacement, smbmount


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 10:18 PM
Shell Variable available within Samba "print command" thibert Linux - Networking 0 12-12-2005 01:02 PM
Samba 3.0.0 installed on RH WS3, but "net join" command not found chloevu Linux - Networking 0 07-13-2004 03:20 PM
samba - smbmount freezing my terminals -> "Device is busy" Yntarius Linux - Networking 4 05-21-2004 07:19 AM
"net ads join" command not found with samba 3.0.2a tisource Linux - Networking 2 04-15-2004 03:38 PM


All times are GMT -5. The time now is 02:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration