LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-19-2004, 02:08 AM   #1
soundbarrier
LQ Newbie
 
Registered: Nov 2004
Posts: 8

Rep: Reputation: 0
what's the smartd ?


hi everyone!!!
yesterday I installed FC3 on my computer .... and it doesn't see big problem...
but FC3 have some small problem on my computer.
what is the smartd ? smartd failed in the booting everytime.
My FC3 is very well boot operating except for this error.
I appreicate if you teach me that solution!!!
thank you...
 
Old 11-19-2004, 02:40 AM   #2
linuXBOX
Member
 
Registered: Jul 2003
Location: Stuart,FL
Distribution: Fedora Core 3 and Slackware 10.0
Posts: 179

Rep: Reputation: 30
Chances are, as it was with me, the smartd config file is incorrect. It is located at /etc/smartd.conf . When I went from FC1 to FC2, they changed the cdrom to /dev/hda. However they forgot to change the smartd.conf accordingly. Edit it with your own information. Example, if you have one hard drive installed and it is located at /dev/hdb, comment out every line in smartd.conf, and add your one line to the end with the -a option.

#afhjhgfashfldf
#lkdsfhalsdfhlakfh
#lkfhlasihflhadf
/dev/hdb -a

The lines you want smartd to inspect must be uncommented.

After you are done, save the .conf file and run 'smartd -d'.
It will report to you the hard drives it inspected and their smart capabilities. When you are satisfied, use 'ctrl+\' to exit smartd debug.

To confirm if you had the same problem, you should be able to check dmesg to see what the smartd error message is
'dmesg | grep smartd', but it sounds like the situation I had.

Last edited by linuXBOX; 11-19-2004 at 02:42 AM.
 
Old 11-19-2004, 04:12 AM   #3
soundbarrier
LQ Newbie
 
Registered: Nov 2004
Posts: 8

Original Poster
Rep: Reputation: 0
thank you for your advice!!!!!

I'll try it.

thank you very much!!!
 
Old 11-19-2004, 06:15 AM   #4
soundbarrier
LQ Newbie
 
Registered: Nov 2004
Posts: 8

Original Poster
Rep: Reputation: 0
well...............
I try to set smartd.conf file

/dev/hdb -a root@localhost.localdomain

but error message is the same situation....

I have one HDD...
HDD; 250G (divide 3 partition)
- first partition is Windows XP
- second partition is Data Drive
- third partition is FC3

please teache me...how to set the smartd.conf

thank you...!
 
Old 11-19-2004, 07:37 AM   #5
anzez
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
On my FC3 there is a script '/usr/sbin/smartd-conf.py' that automatically generates the configuration.
 
Old 11-19-2004, 10:57 PM   #6
linuXBOX
Member
 
Registered: Jul 2003
Location: Stuart,FL
Distribution: Fedora Core 3 and Slackware 10.0
Posts: 179

Rep: Reputation: 30
run 'smartd -d' what type of message do you get?
 
Old 11-20-2004, 02:51 AM   #7
soundbarrier
LQ Newbie
 
Registered: Nov 2004
Posts: 8

Original Poster
Rep: Reputation: 0
well...

[soundbarrier@localhost ~]$ smartd -d
bash: smartd: command not found
[soundbarrier@localhost ~]$

so what shall i do?

please teach me....!!!
 
Old 11-20-2004, 03:08 AM   #8
linuXBOX
Member
 
Registered: Jul 2003
Location: Stuart,FL
Distribution: Fedora Core 3 and Slackware 10.0
Posts: 179

Rep: Reputation: 30
Smartd is located in /sbin, and this may not be in your $PATH. Try -

[user@localhost ]$ /sbin/smartd -d

If that fails you will probably need to be root in order to run it. That is executed as follows

[user@localhost ]$ su -
password:
[root@localhost ]$ smartd -d

And as with user, root's path may not include '/sbin'. If that is the case then

[root@localhost ]$ /sbin/smartd -d

Remember, once smartd is running you cannot ctrl - c to break out, you must use ctrl - \ to exit debug.

Try these possibilites in the order presented. If you are successful with the first suggestion there is no need to proceed to the next. Let me know how it goes.
 
Old 11-20-2004, 03:13 AM   #9
linuXBOX
Member
 
Registered: Jul 2003
Location: Stuart,FL
Distribution: Fedora Core 3 and Slackware 10.0
Posts: 179

Rep: Reputation: 30
And once you get that straight I want to ask you to do something else. Run this command.

[user@localhost ~]$ df -h

And post the output.
This will let us know what to put in your /etc/smartd.conf file.
 
Old 11-20-2004, 07:06 AM   #10
anzez
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
After I upgraded FC2 to FC3 I had the same problem. It proved out that it was because my /etc/smartd.conf was empty:
Code:
[root@thor ~]# /usr/sbin/smartd -d
smartd version 5.33 [i386-redhat-linux-gnu] Copyright (C) 2002-4 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

Opened configuration file /etc/smartd.conf
Configuration file /etc/smartd.conf parsed but has no entries (like /dev/hda)
Unable to monitor any SMART enabled devices. Try debug (-d) option. Exiting...
[root@thor ~]#
I also found the '/usr/sbin/smartd-conf.py' script which generates the configuration that can be used for smartd.conf.
Here's what I had to do (as root):
Code:
[root@thor ~]# /usr/sbin/smartd-conf.py > /etc/smartd.conf
To see if smartd starts up now:
Code:
[root@thor ~]# /etc/init.d/smartd start
Starting smartd:                                           [  OK  ]
[root@thor ~]#
BTW: on FC3 smartd is located in /usr/sbin/ not /sbin/!
 
Old 11-20-2004, 11:20 AM   #11
linuXBOX
Member
 
Registered: Jul 2003
Location: Stuart,FL
Distribution: Fedora Core 3 and Slackware 10.0
Posts: 179

Rep: Reputation: 30
As Mr. Burns would say "Excellent." I'm upgrading to FC3 today. I thought it was still in testing or I would've switched earlier. Sorry I didn't know smartd was moved! But it sounds like you fixed your problem!
 
Old 12-16-2004, 03:36 PM   #12
rjcrews
Member
 
Registered: Apr 2004
Distribution: Debian
Posts: 193

Rep: Reputation: 30
im having the same problem here, was hoping to get some help with this.

when i do df -h i get something like

/dev/mapper/Volgroup00-logvol00
149G 3.4G 138G 3% /
/dev/sda1 99M 8.9M 85M 10 /boot
none 506m 0 506m 0% /dev/shm

my /etc/smartd.conf has:
/dev/sda -H -m root@localost.localdomain

i followed the instructions above but it failed, i suspect i need to change the .conf file but am not sure to what. any ideas?

thx
 
Old 12-30-2004, 08:28 PM   #13
prcarp
LQ Newbie
 
Registered: Feb 2004
Location: Lynchburg, VA
Distribution: Slackware 9.1/Fedora Core 2
Posts: 17

Rep: Reputation: 0
I am stuck as well:

This is what is currently in my .conf (the python script echoes the same thing)
Code:
[root@localhost etc]# cat smartd.conf
/dev/sda -H -m root@localhost.localdomain
Here is the smartd output:
Code:
[root@localhost prc]# smartd -d
smartd version 5.33 [i386-redhat-linux-gnu] Copyright (C) 2002-4 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

Opened configuration file /etc/smartd.conf
Configuration file /etc/smartd.conf parsed.
Device: /dev/sda, opened
Device /dev/sda, SATA disks accessed via libata are not currently supported by
smartmontools. When libata is given an ATA pass-thru ioctl() then an
additional '-d libata' device type will be added to smartmontools.
Unable to register SCSI device /dev/sda at line 1 of file /etc/smartd.conf
Unable to register device /dev/sda (no Directive -d removable). Exiting.
And the df output...
Code:
[root@localhost prc]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                       40G  3.9G   34G  11% /
/dev/sda6              99M   19M   76M  20% /boot
none                  252M     0  252M   0% /dev/shm
What did I miss?
Thanks,
 
Old 01-06-2005, 06:04 AM   #14
wiseNoob
LQ Newbie
 
Registered: Nov 2004
Location: 40 46' N, 73 54' W
Distribution: Fedora Core 3, OSX 10.3.7
Posts: 15

Rep: Reputation: 0
Not sure if it helps, but I found this on RH bugzilla:
https://bugzilla.redhat.com/bugzilla....cgi?id=134337

Apparently smartd does not support SATA drives - not sure if you are using one but from the prcarp entry above it seems you would be
"Device /dev/sda, SATA disks accessed via libata are not currently supported by
smartmontools."

If you are using only SATA, then theoretically you may be able to disable smartd altogether and not harm the system since it is not running anyway.

I also have this same problem and am wondering if I were to disable smartd it would screw with my PATA drive (that I believe is SMART capable) that has the os installed on it - any ideas?

my smartd.conf file has both drives listed - not sure if I want to try it, but I could comment out the sda line and see what happens...?
 
Old 01-06-2005, 06:31 AM   #15
rjcrews
Member
 
Registered: Apr 2004
Distribution: Debian
Posts: 193

Rep: Reputation: 30
yea i did find out that sata didnt need smartd , so i turned it off.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
smartd??? yenonn Linux - General 1 10-14-2005 10:30 PM
smartd darkangel29 Linux - Newbie 1 07-03-2005 09:16 AM
smartd ciberrust Fedora 2 11-14-2004 03:41 AM
Smartd Fails pbrian17 Fedora 0 10-09-2004 10:23 PM
Smartd ? gibbylinks Fedora 1 11-18-2003 12:33 PM


All times are GMT -5. The time now is 01:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration