LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Website won't load on Linux (http://www.linuxquestions.org/questions/linux-general-1/website-wont-load-on-linux-704467/)

gpowell 02-13-2009 01:17 PM

Website won't load on Linux
 
I have one website http://www.siloamsprings.com that will not load on either my OpenSuse or Kubuntu systems, using either Konqueror or Firefox. This website loads ok on windows systems with either IE or Firefox. I don't seem to have any problems loading any other websites.

Both Linux systems are running KDE4 and are the latest releases. I don't have a KDE3 system to test with.

Can anyone direct me to how to make this work.

arizonagroovejet 02-13-2009 02:34 PM

Doesn't load for on Linux either. I also tried Lynx and Opera. I don't know what the problem is but I can tell you that: The site loads fine with Firefox, Safari and Lynx running on Mac OS X.

I've got the Live HTTP Headers extension installed in Firefox and that shows nothing at all. Not even a GET request. Which seems odd.

If I run
Code:

mike@continuity:~$ /sbin/tracepath www.siloamsprings.com
then it reaches the site.

If I run

Code:

mike@continuity:~$ lynx -head http://www.siloamsprings.com
I get back:


HTTP/1.1 200 OK
Date: Fri, 13 Feb 2009 19:34:39 GMT
Server: Apache/2.2.3 (Linux/SUSE)
X-Powered-By: PHP/5.1.2
Connection: close
Content-Type: text/html


So apparently the web server is running Linux and yet the site fails to load in any Linux web browsers.


Weird.

AuroraCA 02-13-2009 02:54 PM

Have you looked at your server log files to see what problems are reported? I would start with your /var/log/apache2/access.log and /var/log/apache2/error.log.
If you don't see any problem there look in your /var/log/apache2/error.log.siloamsprings and /var/log/apache2/access.log.siloamsprings files.

gpowell 02-15-2009 01:51 AM

I don't own this website, the city of Siloam Springs does and when I called about the problem the IT guy denied they had a problem. Seems to think it is somethink wrong with Linux. I just want to use my linux systems to get to this site.

yancek 02-15-2009 11:03 AM

Interesting! I clicked on the link for Siloam Springs and it loaded right up. Using Firefox 1.5 on Suse Linux 9.2, worked with lynx from a terminal??

hobbsc 02-17-2009 10:26 AM

Greetings, folks.

My name is Christopher M. Hobbs, I'm the Network Administrator for the City of Siloam Springs a member of the openSUSE Community and a member of the openSUSE-GNOME team.

The issue posted here is a known issue and has nothing to do with our webserver. The problem we're having is with our firewall and it has been on the table for some months now. The firewall will soon be replaced, so in order to fix things on your end (at least until we have a new firewall), you will need to adjust your TCP Window Scaling options.

In order to do this temporarily, you can issue the following command (as root):

sysctl -w net.ipv4.tcp_window_scaling=0

Should that command fail, give this one a shot:

echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

To permanently disable TCP Window Scaling, issue the following command as root and reboot:

echo '"net.ipv4.tcp_window_scaling=0" >> sysctl.conf'

I'll personally write the original author of this post from my City account should he not return to this thread.

Thank you for your diligent efforts.
cmh

hobbsc 02-17-2009 10:34 AM

1 Attachment(s)
And furthermore, as an example of the settings, attached is a screenshot of the site in my browser on openSUSE 11.1 with my uname, window scaling, and date output.

You can also view it directly here as it looks like the forum mangled the image a bit:

http://flickr.com/photos/hooobs/3288112890/sizes/o/

Thanks!

arizonagroovejet 02-17-2009 10:55 AM

Being at work right now and having just got the thread update notification it occurred to me to try visiting the site from my work machine which runs SUSE Linux Enterprise Desktop 10. The site loads fine even though tcp_window_scaling is not 0

Code:

me@mymachine:~> cat /proc/sys/net/ipv4/tcp_window_scaling
1

On an openSUSE 11.1 machine I also have at work for tinkering with the website fails to load just as it does on my openSUSE 11.1 machine at home. Interestingly, the tcp_window_scaling setting is the same as on my SLED 10 machine:

Code:

host-foo:~ # cat /proc/sys/net/ipv4/tcp_window_scaling
1

If I change the tcp_windows_scaling to 0 then the website loads. Which is curious.


Anyway, best get back to work. :)

repo 02-17-2009 11:01 AM

Quote:

To permanently disable TCP Window Scaling, issue the following command as root and reboot:

echo '"net.ipv4.tcp_window_scaling=0" >> sysctl.conf'

should be

Code:

echo '"net.ipv4.tcp_window_scaling=0" >> /etc/sysctl.conf'

hobbsc 02-17-2009 11:02 AM

Quote:

Originally Posted by arizonagroovejet (Post 3447013)
Being at work right now and having just got the thread update notification it occurred to me to try visiting the site from my work machine which runs SUSE Linux Enterprise Desktop 10. The site loads fine even though tcp_window_scaling is not 0

Code:

me@mymachine:~> cat /proc/sys/net/ipv4/tcp_window_scaling
1

On an openSUSE 11.1 machine I also have at work for tinkering with the website fails to load just as it does on my openSUSE 11.1 machine at home. Interestingly, the tcp_window_scaling setting is the same as on my SLED 10 machine:

Code:

host-foo:~ # cat /proc/sys/net/ipv4/tcp_window_scaling
1

If I change the tcp_windows_scaling to 0 then the website loads. Which is curious.


Anyway, best get back to work. :)



For what it's worth, I've had the same problem with almost all modern Linux distros. I'm probably the first to have noticed it being that the site belongs to my employer and I couldn't access our intranet.

Older distros (such as SLED 10, which I do use at the office) work without modification. I don't know the intimate details of it, I just know that our firewall is awful picky about window scaling.

hobbsc 02-17-2009 11:03 AM

Quote:

Originally Posted by repo (Post 3447020)
should be

Code:

echo '"net.ipv4.tcp_window_scaling=0" >> /etc/sysctl.conf'

Thanks, I was assuming they were in /etc already.

gpowell 02-17-2009 11:21 AM

Thanks for fix. Works for me.

mrclisdue 02-17-2009 11:30 AM

I, for one, think it's wonderful that Mr. Hobbs took the time to respond in the thread.

cheers,

hobbsc 02-17-2009 12:03 PM

Quote:

Originally Posted by mrclisdue (Post 3447065)
I, for one, think it's wonderful that Mr. Hobbs took the time to respond in the thread.

cheers,

No worries, the OP wrote us with a link to the thread so I wanted to make sure I covered all bases. I've experienced this issue on several distros across several sites. I'm just glad I could help.

tredegar 02-18-2009 01:33 PM

hobbsc,

Thanks for your post at #6.

I learnt something new, and consequently was able to help someone else: http://www.linuxquestions.org/questi...s-file-705646/

With (currently) 5 posts & 3 "Thanks" (= 60% "Thanked"!!!) you should probably qualify for "LQ Saint" status rather than "LQ Newbie". [ I am taking the pi?? - I hate this Thumbs-Up button, but it was only recently introduced ]

Anyhow, welcome to LQ, and I hope you'll stick around.


All times are GMT -5. The time now is 12:22 AM.