LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-13-2009, 12:17 PM   #1
gpowell
LQ Newbie
 
Registered: Nov 2004
Posts: 5

Rep: Reputation: 0
Website won't load on Linux


I have one website http://www.siloamsprings.com that will not load on either my OpenSuse or Kubuntu systems, using either Konqueror or Firefox. This website loads ok on windows systems with either IE or Firefox. I don't seem to have any problems loading any other websites.

Both Linux systems are running KDE4 and are the latest releases. I don't have a KDE3 system to test with.

Can anyone direct me to how to make this work.
 
Old 02-13-2009, 01:34 PM   #2
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: SLED, openSUSE
Posts: 1,009

Rep: Reputation: 171Reputation: 171
Doesn't load for on Linux either. I also tried Lynx and Opera. I don't know what the problem is but I can tell you that: The site loads fine with Firefox, Safari and Lynx running on Mac OS X.

I've got the Live HTTP Headers extension installed in Firefox and that shows nothing at all. Not even a GET request. Which seems odd.

If I run
Code:
mike@continuity:~$ /sbin/tracepath www.siloamsprings.com
then it reaches the site.

If I run

Code:
mike@continuity:~$ lynx -head http://www.siloamsprings.com
I get back:


HTTP/1.1 200 OK
Date: Fri, 13 Feb 2009 19:34:39 GMT
Server: Apache/2.2.3 (Linux/SUSE)
X-Powered-By: PHP/5.1.2
Connection: close
Content-Type: text/html


So apparently the web server is running Linux and yet the site fails to load in any Linux web browsers.


Weird.
 
Old 02-13-2009, 01:54 PM   #3
AuroraCA
Member
 
Registered: Jul 2008
Location: Northern CA USA
Distribution: Ubuntu, Slackware, Gentoo, Fedora, Red Hat, Puppy Linux
Posts: 370

Rep: Reputation: 35
Have you looked at your server log files to see what problems are reported? I would start with your /var/log/apache2/access.log and /var/log/apache2/error.log.
If you don't see any problem there look in your /var/log/apache2/error.log.siloamsprings and /var/log/apache2/access.log.siloamsprings files.
 
Old 02-15-2009, 12:51 AM   #4
gpowell
LQ Newbie
 
Registered: Nov 2004
Posts: 5

Original Poster
Rep: Reputation: 0
I don't own this website, the city of Siloam Springs does and when I called about the problem the IT guy denied they had a problem. Seems to think it is somethink wrong with Linux. I just want to use my linux systems to get to this site.
 
Old 02-15-2009, 10:03 AM   #5
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,473

Rep: Reputation: 692Reputation: 692Reputation: 692Reputation: 692Reputation: 692Reputation: 692
Interesting! I clicked on the link for Siloam Springs and it loaded right up. Using Firefox 1.5 on Suse Linux 9.2, worked with lynx from a terminal??
 
Old 02-17-2009, 09:26 AM   #6
hobbsc
LQ Newbie
 
Registered: Feb 2009
Location: Arkansas
Distribution: openSUSE, SLED, SLES
Posts: 8

Rep: Reputation: 1
Greetings, folks.

My name is Christopher M. Hobbs, I'm the Network Administrator for the City of Siloam Springs a member of the openSUSE Community and a member of the openSUSE-GNOME team.

The issue posted here is a known issue and has nothing to do with our webserver. The problem we're having is with our firewall and it has been on the table for some months now. The firewall will soon be replaced, so in order to fix things on your end (at least until we have a new firewall), you will need to adjust your TCP Window Scaling options.

In order to do this temporarily, you can issue the following command (as root):

sysctl -w net.ipv4.tcp_window_scaling=0

Should that command fail, give this one a shot:

echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

To permanently disable TCP Window Scaling, issue the following command as root and reboot:

echo '"net.ipv4.tcp_window_scaling=0" >> sysctl.conf'

I'll personally write the original author of this post from my City account should he not return to this thread.

Thank you for your diligent efforts.
cmh

Last edited by hobbsc; 02-17-2009 at 10:34 AM.
 
Old 02-17-2009, 09:34 AM   #7
hobbsc
LQ Newbie
 
Registered: Feb 2009
Location: Arkansas
Distribution: openSUSE, SLED, SLES
Posts: 8

Rep: Reputation: 1
And furthermore, as an example of the settings, attached is a screenshot of the site in my browser on openSUSE 11.1 with my uname, window scaling, and date output.

You can also view it directly here as it looks like the forum mangled the image a bit:

http://flickr.com/photos/hooobs/3288112890/sizes/o/

Thanks!
Attached Images
File Type: jpg window_scaling.jpg (161.7 KB, 21 views)

Last edited by hobbsc; 02-17-2009 at 09:46 AM.
 
Old 02-17-2009, 09:55 AM   #8
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: SLED, openSUSE
Posts: 1,009

Rep: Reputation: 171Reputation: 171
Being at work right now and having just got the thread update notification it occurred to me to try visiting the site from my work machine which runs SUSE Linux Enterprise Desktop 10. The site loads fine even though tcp_window_scaling is not 0

Code:
me@mymachine:~> cat /proc/sys/net/ipv4/tcp_window_scaling
1
On an openSUSE 11.1 machine I also have at work for tinkering with the website fails to load just as it does on my openSUSE 11.1 machine at home. Interestingly, the tcp_window_scaling setting is the same as on my SLED 10 machine:

Code:
host-foo:~ # cat /proc/sys/net/ipv4/tcp_window_scaling
1
If I change the tcp_windows_scaling to 0 then the website loads. Which is curious.


Anyway, best get back to work.
 
Old 02-17-2009, 10:01 AM   #9
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,484

Rep: Reputation: 882Reputation: 882Reputation: 882Reputation: 882Reputation: 882Reputation: 882Reputation: 882
Quote:
To permanently disable TCP Window Scaling, issue the following command as root and reboot:

echo '"net.ipv4.tcp_window_scaling=0" >> sysctl.conf'

should be

Code:
echo '"net.ipv4.tcp_window_scaling=0" >> /etc/sysctl.conf'
 
Old 02-17-2009, 10:02 AM   #10
hobbsc
LQ Newbie
 
Registered: Feb 2009
Location: Arkansas
Distribution: openSUSE, SLED, SLES
Posts: 8

Rep: Reputation: 1
Quote:
Originally Posted by arizonagroovejet View Post
Being at work right now and having just got the thread update notification it occurred to me to try visiting the site from my work machine which runs SUSE Linux Enterprise Desktop 10. The site loads fine even though tcp_window_scaling is not 0

Code:
me@mymachine:~> cat /proc/sys/net/ipv4/tcp_window_scaling
1
On an openSUSE 11.1 machine I also have at work for tinkering with the website fails to load just as it does on my openSUSE 11.1 machine at home. Interestingly, the tcp_window_scaling setting is the same as on my SLED 10 machine:

Code:
host-foo:~ # cat /proc/sys/net/ipv4/tcp_window_scaling
1
If I change the tcp_windows_scaling to 0 then the website loads. Which is curious.


Anyway, best get back to work.


For what it's worth, I've had the same problem with almost all modern Linux distros. I'm probably the first to have noticed it being that the site belongs to my employer and I couldn't access our intranet.

Older distros (such as SLED 10, which I do use at the office) work without modification. I don't know the intimate details of it, I just know that our firewall is awful picky about window scaling.
 
Old 02-17-2009, 10:03 AM   #11
hobbsc
LQ Newbie
 
Registered: Feb 2009
Location: Arkansas
Distribution: openSUSE, SLED, SLES
Posts: 8

Rep: Reputation: 1
Quote:
Originally Posted by repo View Post
should be

Code:
echo '"net.ipv4.tcp_window_scaling=0" >> /etc/sysctl.conf'
Thanks, I was assuming they were in /etc already.
 
Old 02-17-2009, 10:21 AM   #12
gpowell
LQ Newbie
 
Registered: Nov 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for fix. Works for me.
 
Old 02-17-2009, 10:30 AM   #13
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,030

Rep: Reputation: 160Reputation: 160
I, for one, think it's wonderful that Mr. Hobbs took the time to respond in the thread.

cheers,
 
Old 02-17-2009, 11:03 AM   #14
hobbsc
LQ Newbie
 
Registered: Feb 2009
Location: Arkansas
Distribution: openSUSE, SLED, SLES
Posts: 8

Rep: Reputation: 1
Quote:
Originally Posted by mrclisdue View Post
I, for one, think it's wonderful that Mr. Hobbs took the time to respond in the thread.

cheers,
No worries, the OP wrote us with a link to the thread so I wanted to make sure I covered all bases. I've experienced this issue on several distros across several sites. I'm just glad I could help.
 
Old 02-18-2009, 12:33 PM   #15
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
hobbsc,

Thanks for your post at #6.

I learnt something new, and consequently was able to help someone else: http://www.linuxquestions.org/questi...s-file-705646/

With (currently) 5 posts & 3 "Thanks" (= 60% "Thanked"!!!) you should probably qualify for "LQ Saint" status rather than "LQ Newbie". [ I am taking the pi?? - I hate this Thumbs-Up button, but it was only recently introduced ]

Anyhow, welcome to LQ, and I hope you'll stick around.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
login page won't load for a website.(KDE 3.5 Xubuntu) tombo465 Linux - Newbie 6 12-04-2008 03:21 AM
Running a website which load sharing on many server!!! celeron Linux - Server 4 10-25-2007 08:18 PM
Website will not load marlaina1 General 1 04-05-2007 12:44 PM
Can't load one specific website using any browser Ilisdur Fedora 4 09-14-2004 04:59 PM
Apache - Website wont load biggiefatts Linux - Networking 11 02-23-2003 03:03 PM


All times are GMT -5. The time now is 05:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration