LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 04-07-2007, 12:29 PM   #1
tornado_11
Member
 
Registered: Aug 2005
Posts: 30

Rep: Reputation: 15
Volume group "VolGroup00" not found


Hello colleagues!

My current kernel is 2.6.18.1 and it works fine!

I'm trying to compile and install the new 2.6.20.4 kernel. My steps:

1.I created /usr/src/linux-2.6.20.4 folder and extracted kernel source here
2. make clean
3. make mrproper
4. make gconfig with setting my CPU type (AMD)
4. make bzImage
5. make modules
6. make modules_install
7. make install

But! When I'm trying to boot with the new kernel I get the error:

Volume group "VolGroup00" not found
Unable to access resume device (/dev/VolGroup00/LogVol00 ...

this is my grub.conf

title Fedora Core (2.6.18-1.2798.fc6)
root (hd0,2)
kernel /vmlinuz-2.6.18-1.2798.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.18-1.2798.fc6.img
title test 2.6.20.4
root (hd0,2)
kernel /vmlinuz-2.6.20.4 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.20.4.img

I have no idea what is this
 
Old 04-07-2007, 12:46 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,059

Rep: Reputation: 295Reputation: 295Reputation: 295
Did you compile logical volume support into the kernel or make sure that a module capable of supporting LVM is on the initrd? It sounds like your kernel can't read logical volumes.
 
Old 04-07-2007, 01:10 PM   #3
tornado_11
Member
 
Registered: Aug 2005
Posts: 30

Original Poster
Rep: Reputation: 15
Could you please say me what it is the parameter name in the config file to support LVM?
 
Old 04-07-2007, 01:20 PM   #4
tornado_11
Member
 
Registered: Aug 2005
Posts: 30

Original Poster
Rep: Reputation: 15
Under Multi-device support RAID and LVM I have the following
Options Name Value

Multiple devices driver support (RAID and LVM) (NEW) MD Y
Device mapper support (NEW) BLK_DEV_MD M

Should the "Device mapper support" be as Y (in kernel)?

Thank you!!
 
Old 04-07-2007, 02:11 PM   #5
tornado_11
Member
 
Registered: Aug 2005
Posts: 30

Original Poster
Rep: Reputation: 15
Ok, I added "Device mapper support" into kernel. But I get the same error
 
Old 04-07-2007, 02:55 PM   #6
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,238

Rep: Reputation: 121Reputation: 121
Did you add it by editing .config or using make menuconfig? And just to be clear, you rebuilt (starting with make clean) and reinstalled the kernel after changing the config?
 
Old 04-07-2007, 03:03 PM   #7
tornado_11
Member
 
Registered: Aug 2005
Posts: 30

Original Poster
Rep: Reputation: 15
yes, my steps:
1. make clean
2. make mrproper
3. here I change my .config using make gconfig
4. make bzImage and etc

by the way how can I verify that some parameters are set correctky after the kernel compilation? For example now I'm running the 2.6.18 kernel and I want to see if BLK_DEV_MD is set. Is it possible?

P.S. Now I'm trying to compare the config file of my current kernel (under /boot) to config file that I created.
 
Old 04-07-2007, 03:07 PM   #8
tornado_11
Member
 
Registered: Aug 2005
Posts: 30

Original Poster
Rep: Reputation: 15
by the way output of df -hT
Filesystem Type Size Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
ext3 115G 6.5G 102G 6% /
/dev/sda3 ext3 99M 17M 78M 18% /boot
tmpfs tmpfs 1004M 0 1004M 0% /dev/shm

I see that my current FS is ext3 but in the config file the ext2 is built-in into kernel and ext3 is as module EXT3_FS (M). Is it relevant?

thanks!
 
Old 04-07-2007, 03:13 PM   #9
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,238

Rep: Reputation: 121Reputation: 121
copy your current config to .config and modify that if necessary, rather than trying to create a proper .config from scratch. Since your working config *works* just run make oldconfig after you copy it over to .config and make sure there aren't any new modules that you need to enable/disable, and then build your kernel from that.

I believe that make mrproper deletes the .config file. It's not normally necessary to do that unless things are really borked badly. make clean is usually enough.
 
Old 04-08-2007, 02:17 AM   #10
tornado_11
Member
 
Registered: Aug 2005
Posts: 30

Original Poster
Rep: Reputation: 15
Ok I did what you said. But I get the same error. Somehow the kernel cannot work with logical partition. When I was installing my distribution I used automatic partition and my root file system is mounted on the logical volume. I ran "make install" it should create ramdisk to handle the LVM issue.
 
Old 04-08-2007, 05:52 AM   #11
tornado_11
Member
 
Registered: Aug 2005
Posts: 30

Original Poster
Rep: Reputation: 15
It sounds like the ramdisk with root file system does not load. How can I check this?
 
Old 04-08-2007, 01:25 PM   #12
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,238

Rep: Reputation: 121Reputation: 121
Did you check the grub entries to make sure they are the same as for the old working kernel? Did you see update-initramfs run? Please verify that you copied the working config to .config and that you DID NOT make any manual changes to the file, and made ALL of your changes using make gconfig.
 
Old 04-08-2007, 03:28 PM   #13
tornado_11
Member
 
Registered: Aug 2005
Posts: 30

Original Poster
Rep: Reputation: 15
yes I copied the working .config and did changes only using gconfig. In addition I found this nice article
http://www-128.ibm.com/developerwork.../l-initrd.html
about ramdisk. It still does not work. Then I decided to leave the LVM and use the custom partitioning. I have two hard disk. On the first I have the Win and on the second I wanted to install FC6. So I started the installation, selected the custom partitioning and did it without LVM. After the restart .. nothing. I have only Windows. Where is the grub? Is it possible to install Win and Linux on different hard disks?
 
Old 04-08-2007, 03:33 PM   #14
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,238

Rep: Reputation: 121Reputation: 121
You will need to have grub on the disk that the BIOS boots.
 
Old 04-08-2007, 03:40 PM   #15
tornado_11
Member
 
Registered: Aug 2005
Posts: 30

Original Poster
Rep: Reputation: 15
How can I ensure this? I didn't select where to install grub, by default it is installed on the correct disk (where the Win resides)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gnome-volume-control "Sorry, no mixer elements and/or devices found" [KIA]aze Linux - Newbie 1 06-24-2010 03:14 PM
"No volume control GStreamer plugins and/or devices found" Frank Soranno Linux - Hardware 2 01-20-2009 11:21 AM
Gnome, Shortcut for "headphones" instead of "volume" Bollie Linux - General 2 06-07-2007 09:19 PM
How to undo an fdisk? "No volume groups found" stickyc Linux - Newbie 2 12-03-2006 01:02 PM
"Successful install" results in "Boot device not found" slackr007 Linux - Newbie 2 05-31-2005 08:02 PM


All times are GMT -5. The time now is 02:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration