LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-02-2003, 12:32 PM   #1
Gerardoj
Member
 
Registered: May 2003
Location: Somewhere over the Rainbow
Distribution: Slackware 9.x, Knoppix, Damn Small Linux, RedHat.
Posts: 465

Rep: Reputation: 30
Vmware Slack 9.0 as Guest ?


Hi I would like to know if I can Install Slackwre 9.0 as Guest?, Now I have Redhat 8.0 as Host but when I type setup appear me that " No linux partitions Detected" and "No swap space detected" how can I install? and what I need to do ?

Thanks

Last edited by Gerardoj; 06-02-2003 at 12:34 PM.
 
Old 06-07-2003, 03:46 PM   #2
StonedZealot
Member
 
Registered: May 2003
Location: St. Louis
Distribution: Slack 9
Posts: 42

Rep: Reputation: 15
Sorta answer...

Well, you need to format the virtual disk as Linux. After you get to the terminal in the slack 9 install (where you typed "setup") you have to use cfdisk (or fdisk if you're adventurous) to format the drive as Linux. It's really easy to use, just create a partition and set the type to 82. If you want a swap partition, make two and set the type of one (the larger one) to 82 and the other to 83. These numbers are all listed when you choose type so don't worry about that...

The problem that I had however, was that in cfdisk, it didn't recognize the virtual disk as 4GB, it recognized it as 670 and some odd MB. I've been trying to get around this with no success...
 
Old 06-07-2003, 07:27 PM   #3
Gerardoj
Member
 
Registered: May 2003
Location: Somewhere over the Rainbow
Distribution: Slackware 9.x, Knoppix, Damn Small Linux, RedHat.
Posts: 465

Original Poster
Rep: Reputation: 30
Hi, you have reason it didn't recognize the virtual disk as 4GB, it recognized it as 670 and also I tried to configutre my partition but, gave me errors like:

Partition the hard disk fdisk <CR> =enter key
p<CR> (to prints my current partition table DOS partition will shown)
n<CR> (to create my new partition)
p<CR> (primary partition type)
2<CR> (partition number 2)
xxx<CR> (where xxx is the first available cylinder number offered)
+xxxM<CR> (where xxx equals two times the system memory)
n<CR> (create new partition)
p<CR> (primary partition type)
3<CR> (partition number 3) = ERROR =partition is alredy defined delete before re-adding and if
I try with other number to primary partition appear me No free sectors available then I jump to

w<CR> (write the partition table and exit fdisk) ERROR unable to write /dev/hda

I tried with cfdisk but appear me in the beginning "opened disk read only you have nop permissions to write then apear me
no partitions table or unknow signature on partition table, do you wish to start with zero table (y) (n) ? Y

then
Disk Drive /dev/hda
Par Type---------FS Type----------Size MB---
Pry/Log Free Space 690.93MB

What can I do? please help me!!

Thanks a lot

Last edited by Gerardoj; 06-08-2003 at 11:15 AM.
 
Old 06-21-2003, 10:41 AM   #4
Coldfirex
LQ Newbie
 
Registered: Jan 2003
Location: College Station, TX
Distribution: Slackware 8.1
Posts: 28

Rep: Reputation: 15
same thing here too
 
Old 06-22-2003, 06:41 PM   #5
apsn
LQ Newbie
 
Registered: May 2003
Posts: 11

Rep: Reputation: 0
Try using a kernel that contains SCSI drivers. The virtual disk is configured as scsi so you won't be able to install to it without the right kernel.
 
Old 06-23-2003, 10:41 AM   #6
Coldfirex
LQ Newbie
 
Registered: Jan 2003
Location: College Station, TX
Distribution: Slackware 8.1
Posts: 28

Rep: Reputation: 15
Thanks. I loaded scsi.s instead of the bare kernel and it loaded just fine. I then got an infinite loop problem after setting up my partitions, but I figured out I had to install LILO to the MBR.
Thanks!
 
Old 06-23-2003, 11:25 AM   #7
Gerardoj
Member
 
Registered: May 2003
Location: Somewhere over the Rainbow
Distribution: Slackware 9.x, Knoppix, Damn Small Linux, RedHat.
Posts: 465

Original Poster
Rep: Reputation: 30
Hi Coldfirex,

how did you loaded scsi.s instead of the bare kernel ? or what else did you do?, do you fixed?, what kernel did you used? Thanks
 
Old 06-29-2003, 07:55 PM   #8
apsn
LQ Newbie
 
Registered: May 2003
Posts: 11

Rep: Reputation: 0
Set your bios to boot your cdrom, put in the slack cd and start your virtual machine. At the boot prompt, boot scsi.s instead of bare.i.

By the way, if anybody is using a windows guest installed on a raw disk partition with vmware 4.0., can you tell me if there's any way to mark the linux bootable partition read only to the vm.
All instructions I've seen indicate that the install wizard should provide a screen with the ro, rw and none options, but for some reason I'm not getting it with the slackware install. I have exactly the same installation on a SUSE box and I get the screen. Don't know why not in slack......
I'm hoping there's some other way to set the attribute... edit a file maybe?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
salckware 10.0 guest on VMware 4.52 cameleonul1 Slackware 2 02-13-2005 11:47 PM
Vmware guest awilisch Linux - Software 1 01-24-2005 07:35 PM
WinXP guest on VMWARE supermatt Linux - Software 1 03-13-2004 11:41 AM
vmware in xp with redhat 8.0 guest dmarkow Linux - Software 2 04-05-2003 07:40 PM
VMWare, RH7.1 guest OS sancho5 Linux - General 1 08-16-2001 09:56 PM


All times are GMT -5. The time now is 04:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration