LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-01-2007, 09:04 AM   #1
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
vim won't paste on middle click anymore


suddenly vim won't paste anymore when i click the scroll wheel. it works in other apps like text editors, firefox, email, etc. is there a vim command for that i can reset?
 
Old 07-01-2007, 09:54 AM   #2
atom
Member
 
Registered: Feb 2004
Location: Slovenia
Distribution: archlinux
Posts: 271

Rep: Reputation: 31
Quote:
Originally Posted by slackhack
suddenly vim won't paste anymore when i click the scroll wheel. it works in other apps like text editors, firefox, email, etc. is there a vim command for that i can reset?
Just fishing here, but have you tried pressing "i" before pasting (to get into insert mode)?

Another thing that might help is :set paste and :set nopaste when you're done.

If that doesn't work, have you tried any other console text editors like emacs and nano if they work?

If the question is related to gvim only (the GUI version), have you tried running vim in console (xterm, konsole...) and pasting? Does that work?

I'd have to have answers to all these questions before I can say anything.

cheers!

G
 
Old 07-01-2007, 10:08 AM   #3
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Original Poster
Rep: Reputation: 46
yes, i was in insert mode. it seems to have been a .vimrc file i copied from someone on LQ to mess around with colorschemes. i removed the file and did :colorscheme default and now it's back to normal. thanks.
 
Old 07-01-2007, 10:24 PM   #4
mcmillan
Member
 
Registered: Jul 2005
Distribution: Arch
Posts: 489

Rep: Reputation: 30
I'm guessing this is with Arch and not Debian (the two listed in your profile). It seems there was a change in the vimrc after the most recent update. The fix is pretty simple, just change "set mouse=a" to "set mouse=v"

Two relevant threads on the Arch forums:
http://bbs.archlinux.org/viewtopic.php?id=34641
http://bbs.archlinux.org/viewtopic.php?id=34694
 
Old 07-01-2007, 11:09 PM   #5
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 292Reputation: 292Reputation: 292
set mouse=r works for me.

mouse=v goes into visual mode automatically when selecting text, which can cause problems when pasting.

Last edited by dive; 07-01-2007 at 11:11 PM.
 
  


Reply

Tags
paste, vim


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to bind Middle click (paste selected text) to keyboard shortcut yozhhh Linux - General 4 10-05-2010 04:25 PM
alter middle click paste Four Programming 3 04-30-2007 03:43 PM
middle click paste only works sometime and how to config other buttons? zeltak Linux - Software 3 02-16-2006 09:53 AM
help: cannot use middle mutton to paste parv Linux - Hardware 1 07-07-2005 09:18 PM
Disabling middle click paste. Pyroknight Linux - Software 6 04-20-2004 07:32 PM


All times are GMT -5. The time now is 09:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration