-   Linux - General (
-   -   Video overlay on Intel Corp. 82845G/GL? (

Muzzy 04-18-2004 07:19 AM

Video overlay on Intel Corp. 82845G/GL?
Hi everyone,

I hope someone can help me with DVD playback. I have been following the instructions at:

I have got to the point where I can play DVDs and I get both video and sound :) but I am having a problem with the quality of the video. It is very jerky, especially when running in full screen mode, and causes the processor to go to 100% usage. I know that this is not how it should be on a 2.6GHz processor and 512Mb RAM with no other programs running - my old computer (1.6GHz, 256MB RAM) running Windows can play DVDs fine.

According the website, I need to activate video overlay.

$ xvinfo
X-Video Extension version 2.2
screen #0
no adaptors present

Here is the output of lspci:

$ /sbin/lspci
00:00.0 Host bridge: Intel Corp. 82845G/GL [Brookdale-G] Chipset Host Bridge (rev 03)
00:02.0 VGA compatible controller: Intel Corp. 82845G/GL [Brookdale-G] Chipset Integrated Graphics Device (rev 03)
00:1d.0 USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801DB USB (Hub #3) (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801DB USB EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corp. 82801DB ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801DB ICH4 IDE (rev 02)
00:1f.3 SMBus: Intel Corp. 82801DB SMBus (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio (rev 02)
00:1f.6 Modem: Intel Corp. 82801DB AC'97 Modem (rev 02)
01:0c.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller

It's not nVidia or ATI which are the only makes covered in the tutorial. Does anyone know what I can do to get video overlay working? Do I have to download some drivers?


Muzzy 04-21-2004 03:26 PM


All I had to do was go into XF86Config and change the driver for the video card to "i810". This also fixed a number of other problems I was having :)

(Solution found by browsing the gentoo forums)

Thank you to everyone that took the time to read my post.

All times are GMT -5. The time now is 10:16 PM.