LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 04-25-2002, 02:43 AM   #1
chuck77
Member
 
Registered: Nov 2001
Location: singapore
Posts: 120

Rep: Reputation: 15
User Quota


/dev/ida/c0d0p9 / ext2 defaults 1 1
/dev/ida/c0d0p1 /boot ext2 defaults 1 2
/dev/ida/c0d0p6 /home ext2 defaults,usrquota
1 2
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
/dev/ida/c0d0p7 /tmp ext2 defaults 1 2
/dev/ida/c0d0p5 /usr ext2 defaults 1 2
/dev/ida/c0d0p10 /var ext2 defaults 1 2
none /proc proc defaults 0 0
none /dev/pts devpts gid=5,mode=620 0 0
/dev/ida/c0d0p8 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0
0


Above is my /etc/fstab.

After setting the file aquota.user in /home and reboot. When i type the command

#./edquota -u test
#Can't read quotafile header: No data available


How do i solve this ?

PS: i am using Redhat 7.1 on Compaq Alpha.
 
Old 04-26-2002, 01:27 PM   #2
kylo8787
Member
 
Registered: Jan 2002
Location: longview idaho
Distribution: slackware 8.1
Posts: 48

Rep: Reputation: 15
you have to add a quota file to the partion with the the quota limit i forgot how to do its been a while but here is a how to.
http://www.tldp.org/HOWTO/mini/Quota.html#toc6
 
Old 05-27-2002, 03:15 AM   #3
auge
LQ Newbie
 
Registered: May 2002
Location: Germany
Distribution: CentOS, Fedora
Posts: 1

Rep: Reputation: Disabled
Well, I just had the same problem. But it works now for me ...
try to move (!) the aquota.user file to quota.user in every fs-root-dir with quota
the reason for that is, if your system automatically uses quota1 (older quota in kernel for example) but the quotatools create/check for quota2 files with the "a" at the begining
 
Old 11-16-2002, 10:21 AM   #4
newb13
LQ Newbie
 
Registered: Nov 2002
Posts: 3

Rep: Reputation: 0
Ok, how do you fix this ?

I have both aquota.* and quota.* in the /home directory
fstab is setup properly. I have double checked and I have had 3 others look into this. The system is redhat. I took and recompiled the kernel to 2.4.19-grsec. Yes quota support is enabled in the kernel.

repquota: Quotafile format detected differs from the specified one (or the one kernel uses on the file).
repquota: Not all specified mountpoints are using quota.

quota
Disk quotas for user tech (uid 541): none

it looks like the kernel wants one quota format and the quota system wants another ! How do you corrent this problem ?
I didnt have this problem on my other servers.

Here is more info if you need it to help me solve this problem:
[root@snapper home]# quotacheck -avugm
quotacheck: Scanning /dev/hda2 [/home] done
quotacheck: Checked 2251 directories and 25153 files
quotacheck: Scanning /dev/hda9 [/home2] done
quotacheck: Checked 3 directories and 8 files
[root@snapper home]# repquota -u /home
repquota: Can't open quotafile /home/quota.user: No such file or directory
repquota: Not all specified mountpoints are using quota.

yet when running quotacheck it generated aquota.user and aquota.group.

Last edited by newb13; 11-16-2002 at 11:09 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
User quota limit ust Linux - General 1 12-16-2004 07:55 AM
user quota ust Linux - Software 1 08-25-2004 10:53 AM
Quota for an user Anibal Slackware 4 06-02-2004 12:14 AM
About user quota... raymond Linux - General 4 08-27-2003 01:01 AM
about user quota... raymond Linux - General 2 11-09-2002 11:52 PM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration