LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 06-16-2005, 04:10 PM   #1
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Use Greek AND English at the same time


I figured out how to get the Greek ("el" for ellenika, or Greek) keyboard layout, and figured out most of the accent marks, etc. But two problems remain. I'm going to be taking an online class in Ancient Greek, and will need to type "simultaneously" in Greek and English. Does anybody know where to find the proper layout for that?

And the second problem is how to put a breathing mark AND an accent mark over the same vowel. I suspect I'll need a dead-key setup for that; what I found and enabled is a composite-key (right ALT) setup, without true dead keys.

Any help greatly appreciated. The whole keyboard thing is one of the most complex areas of Unix, and I'm floundering whenever I even have to do something "simple."

Edit--I made a couple of little icons to switch back and forth between languages, and I can associate shortcuts with them using function keys (to avoid wrong keycodes) that ought to work just fine, so that part of the problem is solved at least crudely.

Now for the breathing-plus-accent issue! I also don't know how to make that little mark that appears under final vowels sometimes....


Last edited by jonr; 06-16-2005 at 04:25 PM.
 
Old 06-16-2005, 04:55 PM   #2
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
Hmm No Greek support in the forum, or maybe I don't have the fonts installed.

You could try a virtual keyboard like
"xvkbd - virtual keyboard for X window system"
http://homepage3.nifty.com/tsato/xvkbd/
 
Old 06-16-2005, 05:11 PM   #3
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 47
Quote:
Originally posted by craigevil
Hmm No Greek support in the forum, or maybe I don't have the fonts installed.

You could try a virtual keyboard like
"xvkbd - virtual keyboard for X window system"
http://homepage3.nifty.com/tsato/xvkbd/
Thanks, Craigevil. I was thinking the same thing--the site I'm going to be taking the course on may not accept the codes I send it! I think it's unicode and it ought to work, but only time will tell. If not...I'll just be outa luck as far as showing off my homework, I guess.

I will look into the xvkbd program. Meanwhile my little icons (for some reason "neutral" keyboard shortcuts only work part of the time; I suspect it's to do with the fabulously intricate innards of OpenOffice.org...) so I put little Greek and US flags on the icons for easy recognition. Better than nothing.
 
Old 07-24-2005, 01:24 PM   #4
simosx
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Rep: Reputation: 0
You can type English and Greek Polytonic (synonym to Ancient Greek) by using the instructions at
http://simos.info/blog/?p=131
The instructions are in (modern) Greek, though I believe the screenshots should be of good help. In the instructions we show how to use the standard support provided by GNOME. Similar support is available for KDE.

We (greek buffs) are currently trying to revamp Greek Polytonic support and there is some draft documentation you could use (in Greek):
http://planet.hellug.gr/misc/polytonic/

For further instructions and comments, you can subscribe to
http://lists.hellug.gr/mailman/listinfo/i18ngr

Let's type some Greek here, αυτό είναι ένα παράδειγμα,
αυτά είναι πολυτονικά, ἀᾶἰὰᾳὰ

You can get free (a la FSF) polytonic fonts at
http://www.ellak.gr/fonts/mgopen/
We are in the process of getting them appear by default in Debian, Ubuntu, Fedora and more.

It's very important to use Unicode and the UTF-8 encoding. This website does not specify encoding, therefore you may have to change from your browser to UTF-8.

Last edited by simosx; 07-28-2005 at 07:22 PM.
 
Old 11-30-2005, 08:23 AM   #5
Nightfrost
Member
 
Registered: Jun 2004
Location: Sweden
Distribution: ArchLinux
Posts: 201

Rep: Reputation: 30
Hi there,

I've been trying endlessly to figure out how to write ancient greek in openoffice. Thank you for the links (the fonts were especially nice). Unfortunately, I don't understand modern greek so the documentation was of little help.

Is it truly very complicated to get openoffice to work with unicode fonts? Would be possible to for you to post brief instructions here?

Thank you very much.
 
Old 12-01-2005, 07:54 AM   #6
Nightfrost
Member
 
Registered: Jun 2004
Location: Sweden
Distribution: ArchLinux
Posts: 201

Rep: Reputation: 30
OK; sorry to be an idiot. I had completely disregarded of setting the keymap with setxkbmap. I have done that now, and I'm using one the fonts linked to above. But I'm still having problems to make it work polytonically; I seem only to be able to get the acute accent. I have made sure I have a font which supports polytonic Greek, but it's still a no go. Any ideas? I'm really desperate to get this working. I have to hand in some stuff in the beginning of next week..

Thanks again.

EDIT: Basically, I'm using the following command

Code:
setxkbmap -model pc105 -layout gr -variant polytonic
to set the keymap...

Last edited by Nightfrost; 12-01-2005 at 08:03 AM.
 
Old 12-04-2005, 11:50 AM   #7
Nightfrost
Member
 
Registered: Jun 2004
Location: Sweden
Distribution: ArchLinux
Posts: 201

Rep: Reputation: 30
I normally don't reply to myself indefinitely like this. But I'm so friggin desperate to get this working, so I'm gonna ask all of you out there to help me once again. The problem is the same; I set the keymap to polytonic Greek, I use a unicode font in OpenOffice with support for polytonic Greek, but when I enter a vowel after I've pressed a dead key, nothing happens. Except for the acute accent dead key, which seems to work.

I tried this under a friend's Windows computer and it worked. I'm seriously considering to install windows on a partition so that I can hand in my translations for school. I've been working hard to keep the contents of my hard drive all open source, so it's gonna be rather painful to welcome satan into my home. Please please, help me out here...
 
Old 01-22-2006, 05:16 PM   #8
simosx
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Rep: Reputation: 0
Quote:
Originally Posted by Nightfrost
I normally don't reply to myself indefinitely like this. But I'm so friggin desperate to get this working, so I'm gonna ask all of you out there to help me once again. The problem is the same; I set the keymap to polytonic Greek, I use a unicode font in OpenOffice with support for polytonic Greek, but when I enter a vowel after I've pressed a dead key, nothing happens. Except for the acute accent dead key, which seems to work.

I tried this under a friend's Windows computer and it worked. I'm seriously considering to install windows on a partition so that I can hand in my translations for school. I've been working hard to keep the contents of my hard drive all open source, so it's gonna be rather painful to welcome satan into my home. Please please, help me out here...
Before running OpenOffice.org you need to execute

(if you use tcsh)
setenv GTK_IM_MODULE xim

(if you use sh/bash)
export GTK_IM_MODULE=xim

Then, from the same shell run OpenOffice.org.

Now, setxkbmap will work with Greek polytonic.
 
Old 10-27-2008, 09:42 AM   #9
simosx
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Rep: Reputation: 0
Quote:
Originally Posted by simosx View Post
Before running OpenOffice.org you need to execute

(if you use tcsh)
setenv GTK_IM_MODULE xim

(if you use sh/bash)
export GTK_IM_MODULE=xim

Then, from the same shell run OpenOffice.org.

Now, setxkbmap will work with Greek polytonic.
Just to note here that if you run Ubuntu 8.10 or Fedora 10 (or any newer distribution), then Greek Polytonic works out-of-the-box.

You do not need to make special arrangements, just specify the Greek Polytonic layout and you are set.

Actually, make sure that you remove any quickfixes (such as setting the GTK_IM_MODULE variable) you may have done to your system to get Greek Polytonic running.

In developer speak, the fix took place in gtk+ 2.14, which is included in GNOME 2.24.
 
Old 10-27-2008, 03:00 PM   #10
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,228

Rep: Reputation: 825Reputation: 825Reputation: 825Reputation: 825Reputation: 825Reputation: 825Reputation: 825
I'm using Fedora 8 and I have the same problem: only the acute accent works in the polytonic driver. This is nothing to do with Open Office, since it occurs in Gedit. The acceptable dead keys (like Compose key combinations) are built-in (Gnome, kernel?) and there seems to be no way to correct any errors and omissions. I've just tried that mysterious export command, but it doesn't help.
 
Old 10-27-2008, 05:01 PM   #11
simosx
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Rep: Reputation: 0
Quote:
Originally Posted by DavidMcCann View Post
I'm using Fedora 8 and I have the same problem: only the acute accent works in the polytonic driver. This is nothing to do with Open Office, since it occurs in Gedit. The acceptable dead keys (like Compose key combinations) are built-in (Gnome, kernel?) and there seems to be no way to correct any errors and omissions. I've just tried that mysterious export command, but it doesn't help.
It is actually a GTK+ issue, that has been resolved recently. GTK+ is an important library (software that is used by many programs), and is used in all GNOME applications, OpenOffice.org, Firefox and more.

One way to solve the problem is to upgrade to Fedora 10 (end of November), or Ubuntu 8.10 (end of this week).

If you must still use Fedora 8, you would need to read
http://simos.info/blog/archives/639
and figure out the changes you need to do to your system.
If you read all the comments in the post, I think it will help you.
 
Old 10-27-2008, 06:53 PM   #12
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,228

Rep: Reputation: 825Reputation: 825Reputation: 825Reputation: 825Reputation: 825Reputation: 825Reputation: 825
Thanks for the suggestions. It looks like it's a question of waiting until this is sorted out. Since I was planning to switch to Debian Stable when it comes out (and that has been frozen since summer) I might have a long wait.

Incidentally, I doubt if altering the Compose file, as they suggest, would help: for some strange reason only some of the compose combinations in the file work.

Stop press:
Putting GTK_IM_MODULE=xim into /etc/environment (otherwise unused) does work. Problem solved, at least for Fedora 8.

Last edited by DavidMcCann; 10-27-2008 at 07:57 PM. Reason: addition
 
Old 10-28-2008, 01:06 PM   #13
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,228

Rep: Reputation: 825Reputation: 825Reputation: 825Reputation: 825Reputation: 825Reputation: 825Reputation: 825
More on the polytonic keyboard. Mine seems to lack dead breathings. Anyone in the same situation can get them with the Compose key:

Compose ( alpha gives alpha with rough breathing
Compose ) epsilon gives epsilon with smooth breathing
dead_acute Compose ) omega gives omega with acute and smooth breathing

Note that the sequence of keystrokes cannot be varied, unlike compose sequences in English.
 
Old 11-20-2008, 06:38 PM   #14
simosx
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Rep: Reputation: 0
And here is my latest post on writing Greek Polytonic,
http://simos.info/blog/archives/763
 
  


Reply

Tags
gtk+, writing


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there English-to-English dictionary in linux? uishen Linux - General 27 06-03-2009 11:36 PM
Way to use a good free English to English Dictionary linbose Linux - Software 6 06-03-2009 11:25 PM
English Openoffice with greek support alepou192 Linux - Software 2 09-03-2004 07:23 AM
i am looking for a english to english dictionary for RedHat8.0 rddreamz Linux - Software 1 07-10-2004 11:58 AM
Can I have english menu with chinese/english/spanish input? codec Linux - General 9 10-04-2003 08:18 PM


All times are GMT -5. The time now is 07:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration