LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-20-2003, 12:41 AM   #1
fog_proxy
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Rep: Reputation: 0
USB mouse not work after kernel recompile


Dear All,

I Installed Redhat 9.0 at my notebook(dell inspiron 2650),and it worked fine with the default install.For some reason,I recompiled my kernel(same as the old one,2.4.20-8),then my usb mouse can not work,even my touchpad refused to work.
I am sure I have compiled all modules which usb need,here is my lsmod list:

Module Size Used by Tainted: P
agpgart 47776 0 (autoclean)
nvidia 1676832 0 (autoclean)
parport_pc 19076 1 (autoclean)
lp 8996 0 (autoclean)
parport 37056 1 (autoclean) [parport_pc lp]
autofs 13268 0 (autoclean) (unused)
3c59x 30704 1
nls_iso8859-1 3516 2 (autoclean)
nls_cp437 5116 2 (autoclean)
vfat 13004 2 (autoclean)
fat 38808 0 (autoclean) [vfat]
keybdev 2944 0 (unused)
mousedev 5492 0
input 5856 0 [keybdev mousedev]
hid 11768 0 (unused)
usb-uhci 26348 0 (unused)
usbcore 78784 1 [hid usb-uhci]
ext3 70784 1
jbd 51892 1 [ext3]

and I also checked dmesg info about usb:

usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 12:45:41 Aug 20 2003
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: USB UHCI at I/O 0x1800, IRQ 10
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
usb-uhci.c: USB UHCI at I/O 0x1820, IRQ 5
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usb.c: registered new driver hid
hid-core.c: USB HID support drivers

but can't find any problem.then I checked my /etc/module.conf,there is only one line relate to USB:

alias usb-controller usb-uhci

Can anyone help? I have troubled by the problem for a long time.
 
Old 08-20-2003, 12:45 AM   #2
exodist
Senior Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: Gentoo
Posts: 1,372

Rep: Reputation: 46
in the kernel configuration you need to enable the following in the usb section

enable all 3 of the ehci ehci, whatever, they are the root driver, then go down and enable hid support and full hid, that should do it. also try linking /dev/input/mice to /dev/mouse (-sf flags)
that might help
 
Old 08-20-2003, 01:11 AM   #3
fog_proxy
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for reply.I really have done it,but still can not work.It seems that my usb driver is not working.
 
Old 08-20-2003, 01:39 AM   #4
exodist
Senior Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: Gentoo
Posts: 1,372

Rep: Reputation: 46
mine also did not work for some reason after changing cases but not anything else (how the h*ll?) but if I unplug it after boot and then re-plug it it willw ork, try that, also I changed it to the usb2.0 ports rather than the 1.0 ones and it initilises on kernel boot.
 
Old 08-20-2003, 04:14 AM   #5
fog_proxy
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
I have no usb2.0 ports,and I tried unplug then re-plug the usb mouse after boot,it still not work.

I just test it in test mode(init 3),and my touchpad can work now(after I compiled kernel again with the redhat default config file,which I copy from kernel.src.rpm,use kernel-2.4.20.i686.config).

If my usb mouse work,I should see the cursor when I move the mouse,right?but never to see that.
 
Old 08-20-2003, 05:39 AM   #6
fog_proxy
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
When I tried unplug then replug the usb mouse,/var/log/messages said:

Aug 20 18:11:44 localhost kernel: usb.c: USB disconnect on device 00:1d.0-1 address 3
Aug 20 18:11:44 localhost devlabel: devlabel service started/restarted
Aug 20 18:11:53 localhost kernel: hub.c: new USB device 00:1d.0-1, assigned address 4
Aug 20 18:11:53 localhost kernel: : USB HID v1.00 Mouse [05e3:1205] on usb1:4.0
Aug 20 18:11:56 localhost /etc/hotplug/usb.agent: Setup hid for USB product 5e3/1205/242
Aug 20 18:11:56 localhost /etc/hotplug/usb.agent: Setup mousedev for USB product 5e3/1205/242
Aug 20 18:11:56 localhost devlabel: devlabel service started/restarted

It seems OK.But when I try to use /dev/usb/mice (which should point to my usb mouse), Xwindows said : can't open device /dev/usb/mice.

Any suggestions?
 
Old 08-20-2003, 11:34 AM   #7
exodist
Senior Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: Gentoo
Posts: 1,372

Rep: Reputation: 46
I have never heard of using /dev/usb/mice, try /dev/input/mice, see if that works
 
Old 08-21-2003, 11:28 AM   #8
fog_proxy
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Oh,I type a wrong path,in fact it is /dev/input/mice.
I have solved the problem now,but replace with a new kernel(2.4.21) and load the module uhci.But my 2.4.20 still can not work.
Thanks all for help.
 
Old 08-21-2003, 12:52 PM   #9
exodist
Senior Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: Gentoo
Posts: 1,372

Rep: Reputation: 46
uhm 2.4.20 would work to, butbe sure to load all 3 usb bus drivers, ehci, uhci, ohci? whatever, that way you know you have support rather than doing the one you think you have and being wrong.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My USB keyboard and mouse no work in kernel 2.6+ (Debian) 0x86 Linux - Software 5 08-01-2004 12:22 PM
USB Mouse/Sound no longer work after kernel compile, MDK 10, 2.6.3 Kramer Linux - Hardware 8 03-25-2004 11:49 PM
Mouse not working after kernel recompile. phekno Linux - Newbie 2 12-03-2003 07:50 PM
Usb mouse doesn't work after kernel upgrade fsu_slacker Linux - Hardware 9 08-29-2003 04:31 AM
Debian - Mouse problem in X, recompile Kernel? PerpetualBurn Linux - Distributions 7 06-07-2003 01:16 AM


All times are GMT -5. The time now is 01:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration