LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-03-2008, 07:22 PM   #1
sblantipodi
Member
 
Registered: May 2006
Distribution: Latest CentOS
Posts: 151

Rep: Reputation: 15
USB external hard disk and fstab


Hi,
I'm trying to mount an usb external hard disk with user account (no root).

I put this lines in /etc/fstab
/dev/sdb1 /mnt/TravelStar ntfs auto,rw,dev,umask=0 0 0

but it doesn't solve my problem.
Could you help me please? Thanks.
 
Old 01-03-2008, 07:56 PM   #2
stefan_nicolau
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32
add the 'user' option
Code:
auto,rw,user,dev,umask=0
 
Old 01-03-2008, 08:12 PM   #3
deepumnit
Member
 
Registered: Dec 2006
Location: NOIDA, India
Distribution: Debian, SUSE, Fedora
Posts: 334
Blog Entries: 1

Rep: Reputation: 31
This may help:
Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/mapper/deepu-root /               ext3    defaults,errors=remount-ro 0       1
/dev/sda1       /boot           ext3    defaults        0       2
/dev/mapper/deepu-swap_1 none            swap    sw              0       0
/dev/hda        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
You need user to be added in order to auto-mount and read.
 
Old 01-04-2008, 12:56 PM   #4
sblantipodi
Member
 
Registered: May 2006
Distribution: Latest CentOS
Posts: 151

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by stefan_nicolau View Post
add the 'user' option
Code:
auto,rw,user,dev,umask=0
unfortunantly this doesn not solve my problem
the strange thing is that if I doesn't add any line to fstab I can mount all USB-pen but If I try with usb disk I've got this error:

TODO: have to rethink extra options
 
Old 01-04-2008, 01:05 PM   #5
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by sblantipodi View Post
If I try with usb disk I've got this error:

TODO: have to rethink extra options
Is that literally the error message?! . You might want to give distro and possibly kernel information.
 
Old 01-04-2008, 01:11 PM   #6
sblantipodi
Member
 
Registered: May 2006
Distribution: Latest CentOS
Posts: 151

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Nylex View Post
Is that literally the error message?! . You might want to give distro and possibly kernel information.
yes, I cut and paste it.
I'm using Fedora 8 with a vanilla kernel 2.6.23.
 
Old 01-04-2008, 06:51 PM   #7
stefan_nicolau
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32
I found this:

http://bbs.archlinux.org/viewtopic.php?pid=311624 (involves recompiling HAL...)
http://www.fedoraforum.org/forum/sho...d.php?t=177287 (config file change)

The last one especially seems to deal with your exact problem...
This looks like a fedora bug.
 
Old 01-04-2008, 06:58 PM   #8
sblantipodi
Member
 
Registered: May 2006
Distribution: Latest CentOS
Posts: 151

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by stefan_nicolau View Post
I found this:

http://bbs.archlinux.org/viewtopic.php?pid=311624 (involves recompiling HAL...)
http://www.fedoraforum.org/forum/sho...d.php?t=177287 (config file change)

The last one especially seems to deal with your exact problem...
This looks like a fedora bug.
yes, if you read the second link you posted this is a thread started by me.
I solved with that thread. Really thanks!
 
Old 01-06-2008, 01:14 PM   #9
xptools
Member
 
Registered: Sep 2005
Location: Canada
Distribution: Debian Testing
Posts: 40

Rep: Reputation: 15
Quote:
Originally Posted by sblantipodi View Post
I put this lines in /etc/fstab
/dev/sdb1 /mnt/TravelStar ntfs auto,rw,dev,umask=0 0 0
/dev/sdb1 is definitely not a good entry to put into fstab -- what if some other usb devices are plugged in?

You'd better use UDev. The most prominent advantages is that it allows you to have Persistent block device naming.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB External Hard Disk linux_2007_ Linux - General 8 12-31-2007 03:57 AM
60GB laptop hard disk & 200GB external USB hard disk linux compatibility powah Linux - Hardware 0 03-07-2006 10:55 AM
USB external hard disk draggin Linux - Hardware 1 12-28-2005 04:33 PM
usb controller dies mounting external usb hard disk komasoftware Linux - Hardware 4 11-30-2005 01:18 PM
External USB Hard Disk Nishy Linux - Hardware 2 09-28-2005 06:35 AM


All times are GMT -5. The time now is 05:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration