LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-04-2010, 12:09 PM   #1
corteplaneta
Member
 
Registered: Jul 2007
Distribution: archlinux, ubuntu, slackware
Posts: 58

Rep: Reputation: 15
USB devices stop responding when a new device is inserted


Hello,

I'm running archlinux & just recently started having a problem where ALL USB devices will stop responding for a second when a new USB device is plugged in. dmesg doesn't provide any hints.

For example, I've got my music on an external HD & it will stop playing for like ~30 seconds if plug in my camera or gamepad...

This issue only seemed to start after my home partition was erased & re-created, though I don't see how these two issues could be related.

I've been running a custom kernel (2.6.35-rc6) for the past few months, and that hadn't changed to spur this issue. Thinking it may have been something weird with the kernel, I even switched over 2.6.36-rc6-mainline, yet this did not remediate the issue.

Any suggestions would be greatly appreciated.

Thanks!
 
Old 10-05-2010, 09:47 PM   #2
mf93
Member
 
Registered: Jun 2009
Distribution: Debian Squeeze, centOS
Posts: 229

Rep: Reputation: 36
try looking in your logs to see what happens when a device is plugged in. try the dmesg command and look at the last couple of lines after you plug in your usb device post what it outputs
 
Old 10-06-2010, 05:27 PM   #3
jefro
Guru
 
Registered: Mar 2008
Posts: 11,965

Rep: Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483
Boot to a live cd and see if the problem follows. It could be a current issue on the port maybe.
 
  


Reply

Tags
archlinux, usb


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian automount inserted devices Mr. Alex Debian 7 06-06-2010 07:31 AM
Accessing USB devices without device-driver barunparichha Linux - Software 5 07-22-2008 10:59 AM
usb keyb and mouse randomly stop responding netsurf Linux - Hardware 1 10-18-2007 07:16 PM
usb devices stop working -while booting narendra.pant Linux - Hardware 2 07-05-2006 03:09 AM
USB Device stop working grendel-IT Linux - Hardware 1 04-06-2004 12:14 PM


All times are GMT -5. The time now is 12:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration