LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   upgrading Glibc 2.2.4 to 2.3+ (http://www.linuxquestions.org/questions/linux-general-1/upgrading-glibc-2-2-4-to-2-3-a-35452/)

zLinuxz 11-14-2002 10:54 AM

upgrading Glibc 2.2.4 to 2.3+
 
Hey guys...well check it out.
I've got glibc 2.2.4, but I need to upgrade it to 2.3+ for some programs to run.
I need to get the libasound.so.2 library, and the only way I Can do that is by upgrading to glibc 2.3 because then I can install the Alsa lib 0.9, and that'll install libasound.so.2, but it wont let me install that until I install glibc 2.3....however, I downloaded the rpm for the glibc 2.3.1 and when I try installing it, it says the following:

error: Failed dependencies:
glibc-common = 2.3.1-6 is needed by glibc-2.3.1-6
glibc > 2.2.4 conflicts with glibc-devel-2.2.4-13
glibc = 2.2.4 is needed by glibc-devel-2.2.4-13

which in a way seemes kind of contradictory, since I'm trying to install what it says there is needed...

So, I'm not sure how to go about this upgrade, I appreciate any help you guys can give me, :study: , thanks a lot!

zLinuxz

bulliver 11-14-2002 03:17 PM

If you add the flag --no-deps to the rpm command it will install it regardless, of course this may not solve your problem, and may in fact bugger it up more.

"error: Failed dependencies:
glibc-common = 2.3.1-6 is needed by glibc-2.3.1-6"

have you looked for and installed glibc-common = 2.3.1-6?
you can get it at rpmfind.net

zLinuxz 11-15-2002 12:10 AM

eckk, could a possibility be to uninstall the onld glibc 2.2.4 and then install the 2.3?, or is that not possible?

jdc2048 11-15-2002 12:46 AM

Looks like you need to download the same version of "glibc-common", "glibc-devel", and "glibc" and then run the "rpm -U glibc*.rpm"

Were you using the "-U" option?

zLinuxz 11-15-2002 12:21 PM

k, I'll download all of those...
I did, however, tried the -U option with the glibc2.3 rpm I downloaded, and I also got an error. but I'll try it again with all the files. thanks.

Johng 01-02-2003 10:01 PM

Hi zLinuxz

Did it work?

There are a lot of us our there who want/need to upgrade to glibc_2.3

On my Mandrake 9.0, if I do "strings /lib/libc.so.6 | grep GLIBC" I get:
GLIBC_2.0
GLIBC_2.1
GLIBC_2.1.1
GLIBC_2.1.2
GLIBC_2.1.3
GLIBC_2.2
GLIBC_2.2.1
GLIBC_2.2.2
GLIBC_2.2.3
GLIBC_2.2.4
GLIBC_2.2.5

adding GLIBC_2.3 seems to be full of fish hooks(?). I would prefer to use RPMs on MDK9.

Has anyone found the answer?


All times are GMT -5. The time now is 01:17 PM.