LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-05-2006, 04:29 PM   #1
drew boardman
LQ Newbie
 
Registered: Nov 2005
Location: Versailles, France
Distribution: Hardy Heron
Posts: 12

Rep: Reputation: 0
Updating KDE with apt


Hi

I have switched to Suse 10.1 and use apt to update install etc. I use KDE 3.5.1 I know 3.5.4 is out but I am not offered the chance to upgrade to anything else.

Here's the sources list.
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/10.1-i386 java xorg openoffice suser-agirardet suser-hthen suser-liviudm suser-jengelh suser-gbv usr-local-bin suser-scorot suser-scrute suser-jogley suser-ollakka suser-raoul funktronics suse-people suse-projects kde3-stable
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 update
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 rpmkeys
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 base
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 non-oss
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 extra
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 gnome
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 mozilla
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 suser-rbos
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 suser-crauch
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 jacklab
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 suser-oc2pus
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 suser-guru
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 suser-tcousin
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 suser-sbarnin
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 kolab
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 packman
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 packman-i686
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 kraxel
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 wine
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 security

Anybody know why?

Thanks
 
Old 09-06-2006, 04:47 AM   #2
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
The repos has changed for KDE upgrades:
you should use this address
 
Old 09-06-2006, 08:12 AM   #3
drew boardman
LQ Newbie
 
Registered: Nov 2005
Location: Versailles, France
Distribution: Hardy Heron
Posts: 12

Original Poster
Rep: Reputation: 0
Updating KDE with apt

Thanks for that link.

Do you know the format in which I can write to my sources list file?

All of them are ftp.

Thanks again

Drew
 
Old 09-06-2006, 11:29 AM   #4
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
See this link from another forum, especially :
Quote:
* and a important information for SuSE-10.x is missing in your HowTo:
you must use a new version of apt, it must understand repomd repositories.
you can get it here (versions may have changed)
wget http://ftp.gwdg.de/pub/opensuse/repo...-12.1.i586.rpm
wget http://ftp.gwdg.de/pub/opensuse/repo...-12.1.i586.rpm
wget http://ftp.gwdg.de/pub/opensuse/repo...-12.1.i586.rpm

and of course this synaptic version can also use repomd-entries in the sources.list:
wget http://ftp.gwdg.de/pub/opensuse/repo...-11.3.i586.rpm

with this version you can extend your sources.list to use entries like:
repomd http://software.opensuse.org/download/KDE: KDE3 SUSE_Linux_10.1
repomd http://software.opensuse.org/download/KDE: Backports SUSE_Linux_10.1

the repomd format has to be used, because some repos are changing to the build-server.
Have a good KDE upgrade.

Last edited by berbae; 09-06-2006 at 04:15 PM.
 
Old 09-16-2006, 05:19 PM   #5
drew boardman
LQ Newbie
 
Registered: Nov 2005
Location: Versailles, France
Distribution: Hardy Heron
Posts: 12

Original Poster
Rep: Reputation: 0
the new apt and repomd

Dear berbae

Thanks for the reply. I have added the new apt, libs and synaptic and they work but my sources list does not work.

Do I merely add repomd in front of every address that I used to have in a special way? (I have tried just typing that but didn't work either)

Do you know of a link that lists all the repo's similar to those I had previously? I know I'm close but its this last stage that has me confused!

Thanks

Drew
 
Old 09-17-2006, 11:19 AM   #6
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
Hi drew boardman
Can you post your source.list file?
I think you just have to add the new KDE repos with the
repomd key word, like that:
Quote:
repomd http://software.opensuse.org/download/KDE: KDE3 SUSE_Linux_10.1
repomd http://software.opensuse.org/download/KDE: Backports SUSE_Linux_10.1
and suppress old KDE repos in your source.list and let everything else untouched.
But if you can, I advise you to first update/upgrade your system without adding the KDE repos, and test if everything is ok, before adding the KDE repos and update KDE. So it would be easy to discover where a problem originates from.
And check that you are able to go back to the present running KDE version, if something doesn't work well. Verify that you have a backup of the KDE rpm files somewhere or the installation CD/DVDs available.
Try this and tell us if it works.
Have a good KDE upgrade.
 
Old 09-18-2006, 06:55 AM   #7
drew boardman
LQ Newbie
 
Registered: Nov 2005
Location: Versailles, France
Distribution: Hardy Heron
Posts: 12

Original Poster
Rep: Reputation: 0
Updating KDE with apt

Dear Berbae

Here is the sources list as requested

# Safe sources.list file generated by install-apt4suse at Tue May 30 21:20:43 CEST 2006

# You can manage the components that apprear in this file by editing
# UNWANTED_COMPONENTS in the file /etc/install-apt4rpm.conf.
# Don't edit this variable unless you know what you do !!!

# This file is based on the content of the full components list file:
# ftp://ftp4.gwdg.de/pub/linux/suse/ap...urces.list.FTP

# Don't remove the following line.
# DEFAULT_MIRROR = ftp://ftp4.gwdg.de/pub/linux/suse/apt


# Repository created by: aptate (version 0.69.3)
# At: Tue May 30 21:17:15 MEST 2006
# More info about aptate at: http://apt4rpm.sourceforge.net


rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 java xorg openoffice suser-agirardet suser-hthen suser-liviudm suser-jengelh suser-gbv usr-local-bin suser-scorot suser-scrute suser-jogley suser-ollakka suser-raoul funktronics suse-people suse-projects kde3-stable
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 update
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 rpmkeys
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 base
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 non-oss
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 extra
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 gnome
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 mozilla
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 suser-rbos
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 suser-crauch
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 jacklab
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 suser-oc2pus
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 suser-guru
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 suser-tcousin
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 suser-sbarnin
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 kolab
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 packman
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 packman-i686
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 kraxel
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 wine
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 security
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 update
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 security
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 rpmkeys
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 base
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 non-oss
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 extra
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 gnome
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 mozilla
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-rbos
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-crauch
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 jacklab
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-oc2pus
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-guru
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 suser-tcousin
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 kolab
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 packman
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 packman-i686
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 kraxel
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.0-i386 wine

Thanks for the help

Drew
 
Old 09-18-2006, 08:39 AM   #8
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
First, suppress this line from your present sources.list file:
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 java xorg openoffice suser-agirardet suser-hthen suser-liviudm suser-jengelh suser-gbv usr-local-bin suser-scorot suser-scrute suser-jogley suser-ollakka suser-raoul funktronics suse-people suse-projects kde3-stable
Put a '#' at the start of the line, because the repos mentionned in it don't exist at the given address, or are not safe.
Preferably take this updated one (without the unsafe repos) from apt repo:
#
# Repository created by: aptate (version 0.69.3)
# At: Mon Sep 18 13:25:30 MEST 2006
# More info about aptate at: http://apt4rpm.sourceforge.net
#
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/10.1-i386 packman rpmkeys base non-oss extra update gnome mozilla suser-rbos suser-crauch suser-jengelh jacklab suser-oc2pus suser-guru suser-tcousin suser-sbarnin kolab packman-i686 kraxel wine security
#rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt SuSE/10.1-i386 packman rpmkeys base non-oss extra update gnome mozilla suser-rbos suser-crauch suser-jengelh jacklab suser-oc2pus suser-guru suser-tcousin suser-sbarnin kolab packman-i686 kraxel wine security

Then do as explained in my preceding post.

Last edited by berbae; 09-18-2006 at 08:46 AM.
 
Old 09-20-2006, 10:23 AM   #9
drew boardman
LQ Newbie
 
Registered: Nov 2005
Location: Versailles, France
Distribution: Hardy Heron
Posts: 12

Original Poster
Rep: Reputation: 0
Updating KDE with apt

Dear Berbae

The sources list now looks like this:

# Repository created by: aptate (version 0.69.3)
# At: Mon Sep 18 13:25:30 MEST 2006
# More info about aptate at: http://apt4rpm.sourceforge.net

rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 packman rpmkeys base non-oss extra update gnome mozilla suser-rbos suser-crauch suser-jengelh jacklab suser-oc2pus suser-guru suser-tcousin suser-sbarnin kolab packman-i686 kraxel wine security
repomd http://software.opensuse.org/download/KDE:/ KDE3 SUSE_Linux_10.1
repomd http://software.opensuse.org/download/KDE:/ Backports SUSE_Linux_10.1
# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 packman rpmkeys base non-oss extra update gnome mozilla suser-rbos suser-crauch suser-jengelh jacklab suser-oc2pus suser-guru suser-tcousin suser-sbarnin kolab packman-i686 kraxel wine security


But I get this error msg;

"Could not download all repository indexes

The repository might be no longer available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and the correct writing of the repository address in the preferences."

http://software.opensuse.org/downloa...ta/repomd.xml: The http server sent an invalid reply header
http://software.opensuse.org/downloa...ta/repomd.xml: The http server sent an invalid reply header
http://software.opensuse.org/downloa...a/primary.xml: The http server sent an invalid reply header
http://software.opensuse.org/downloa...filelists.xml: The http server sent an invalid reply header
http://software.opensuse.org/downloa...a/primary.xml: The http server sent an invalid reply header
http://software.opensuse.org/downloa...filelists.xml: The http server sent an invalid reply header

W: Release files for some repositories could not be retrieved or authenticated. Such repositories are being ignored.
W: Release file did not contain checksum information for http://software.opensuse.org/downloa...ta/primary.xml
W: Release file did not contain checksum information for http://software.opensuse.org/downloa.../filelists.xml
W: Release file did not contain checksum information for http://software.opensuse.org/downloa...ta/primary.xml
W: Release file did not contain checksum information for http://software.opensuse.org/downloa.../filelists.xml


Thanks for your patience

Dreww
 
Old 09-20-2006, 04:18 PM   #10
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
The repodata directory is under
http://repos.opensuse.org/KDE:/KDE3/...10.1/repodata/
not
http://repos.opensuse.org/KDE:/KDE3/repodata/
as apparently supposed by Apt, which seems to ignore the release number directory.

Comparing with the former format with rpm keyword which is
rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 packman rpmkeys base ...
where the release '10.1-i386' is linked with the higher level directory 'SuSE'
I suggest that you try this format for repomd keyword:
repomd http://software.opensuse.org/download/KDE:/ KDE3/SUSE_Linux_10.1
repomd http://software.opensuse.org/download/KDE:/ Backports/SUSE_Linux_10.1
But before starting the KDE upgrade, did you run an update/upgrade of your system, first without the KDE repos ?
And would you be able to go back to the present running KDE version
if something turns out badly ?

Last edited by berbae; 09-20-2006 at 04:27 PM.
 
Old 09-21-2006, 03:15 AM   #11
drew boardman
LQ Newbie
 
Registered: Nov 2005
Location: Versailles, France
Distribution: Hardy Heron
Posts: 12

Original Poster
Rep: Reputation: 0
Updating with apt

Dear Berbae

I have'nt run run an upgrade recently as the differences between what I have installed and the upgrade seem to be minor.

As for undoing I usually re-install and start from scratch, there seems to no easy Linux equivalent to Ghost. All the important files are copied to an external HDD and then copied back again. I am using am old dual boot machine and after I get the scanner working, I'll drop windows.

This the error I am getting:

drew@linux1:~> su
Password:
linux1:/home/drew # apt-get update
E: Malformed line 7 in source list /etc/apt/sources.list (dist)
linux1:/home/drew #

Here is the sources list:
# Repository created by: aptate (version 0.69.3)
# At: Mon Sep 18 13:25:30 MEST 2006
# More info about aptate at: http://apt4rpm.sourceforge.net

rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 packman rpmkeys base non-oss extra update gnome mozilla suser-rbos suser-crauch suser-jengelh jacklab suser-oc2pus suser-guru suser-tcousin suser-sbarnin kolab packman-i686 kraxel wine security

repomd http://repos.opensuse.org/KDE:/KDE3/SUSE_Linux_10.1/
repomd http://repos.opensuse.org/KDE:/KDE3/...inux_10.1/i586
repomd http://repos.opensuse.org/KDE:/KDE3/...10.1/repodata/
repomd http://software.opensuse.org/downloa...SE_Linux_10.1/
repomd http://software.opensuse.org/downloa...inux_10.1/i586


# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 packman rpmkeys base non-oss extra update gnome mozilla suser-rbos suser-crauch suser-jengelh jacklab suser-oc2pus suser-guru suser-tcousin suser-sbarnin kolab packman-i686 kraxel wine security

Each of the red options have been tested individually but none of work although the others (packman etc) do.

Yours

Drew
 
Old 09-21-2006, 02:49 PM   #12
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
You missed a space in the format:
repomd http://software.opensuse.org/download/KDE:/ KDE3/SUSE_Linux_10.1
repomd http://software.opensuse.org/download/KDE:/ Backports/SUSE_Linux_10.1
not
repomd http://software.opensuse.org/downloa...SE_Linux_10.1/
repomd http://software.opensuse.org/downloa...inux_10.1/i586

download/KDE:/<space>KDE3/SUSE_Linux_10.1
not
download/KDE:/KDE3/SUSE_Linux_10.1/
And nothing after SUSE_Linux_10.1 : neither / nor /i586

Last edited by berbae; 09-21-2006 at 03:11 PM.
 
Old 09-25-2006, 06:27 AM   #13
drew boardman
LQ Newbie
 
Registered: Nov 2005
Location: Versailles, France
Distribution: Hardy Heron
Posts: 12

Original Poster
Rep: Reputation: 0
Updating with apt

Dear Berbae

Here is my latest attempt:

Password:
linux1:/home/drew # apt-get update
Err http://software.opensuse.org KDE3/SUSE_Linux_10.1 repomd.xml
The http server sent an invalid reply header
Err http://software.opensuse.org Backports/SUSE_Linux_10.1 repomd.xml
The http server sent an invalid reply header
Get:1 ftp://ftp4.gwdg.de SuSE/10.1-i386 release [10.1kB]
Fetched 10.1kB in 0s (13.3kB/s)
Err http://software.opensuse.org KDE3/SUSE_Linux_10.1/ primary.xml
The http server sent an invalid reply header
Err http://software.opensuse.org KDE3/SUSE_Linux_10.1/ filelists.xml
The http server sent an invalid reply header
Err http://software.opensuse.org Backports/SUSE_Linux_10.1/ primary.xml
The http server sent an invalid reply header
Err http://software.opensuse.org Backports/SUSE_Linux_10.1/ filelists.xml
The http server sent an invalid reply header
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/packman pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/packman release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/rpmkeys pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/rpmkeys release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/base pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/base release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/non-oss pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/non-oss release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/extra pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/extra release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/update pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/update release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/gnome pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/gnome release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/mozilla pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/mozilla release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-rbos pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-rbos release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-crauch pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-crauch release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-jengelh pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-jengelh release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/jacklab pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/jacklab release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-oc2pus pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-oc2pus release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-guru pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-guru release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-tcousin pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-tcousin release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-sbarnin pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/suser-sbarnin release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/kolab pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/kolab release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/packman-i686 pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/packman-i686 release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/kraxel pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/kraxel release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/wine pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/wine release
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/security pkglist
Hit ftp://ftp4.gwdg.de SuSE/10.1-i386/security release
Failed to fetch http://software.opensuse.org/downloa...ata/repomd.xml The http server sent an invalid reply header
Failed to fetch http://software.opensuse.org/downloa...ata/repomd.xml The http server sent an invalid reply header
Failed to fetch http://software.opensuse.org/downloa...ta/primary.xml The http server sent an invalid reply header
Failed to fetch http://software.opensuse.org/downloa.../filelists.xml The http server sent an invalid reply header
Failed to fetch http://software.opensuse.org/downloa...ta/primary.xml The http server sent an invalid reply header
Failed to fetch http://software.opensuse.org/downloa.../filelists.xml The http server sent an invalid reply header
Reading Package Lists... Done
Building Dependency Tree... Done
W: Release files for some repositories could not be retrieved or authenticated. Such repositories are being ignored.
W: Release file did not contain checksum information for http://software.opensuse.org/downloa...ta/primary.xml
W: Release file did not contain checksum information for http://software.opensuse.org/downloa.../filelists.xml
W: Release file did not contain checksum information for http://software.opensuse.org/downloa...ta/primary.xml
W: Release file did not contain checksum information for http://software.opensuse.org/downloa.../filelists.xml
W: You may want to run apt-get update to correct these problems
E: Some index files failed to download, they have been ignored, or old ones used instead.
linux1:/home/drew #

This was based upon, this sources list:

# Repository created by: aptate (version 0.69.3)
# At: Mon Sep 18 13:25:30 MEST 2006
# More info about aptate at: http://apt4rpm.sourceforge.net

rpm ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 packman rpmkeys base non-oss extra update gnome mozilla suser-rbos suser-crauch suser-jengelh jacklab suser-oc2pus suser-guru suser-tcousin suser-sbarnin kolab packman-i686 kraxel wine security

repomd http://software.opensuse.org/download/KDE:/ KDE3/SUSE_Linux_10.1
repomd http://software.opensuse.org/download/KDE:/ Backports/SUSE_Linux_10.1

# rpm-src ftp://ftp4.gwdg.de/pub/linux/suse/apt/ SuSE/10.1-i386 packman rpmkeys base non-oss extra update gnome mozilla suser-rbos suser-crauch suser-jengelh jacklab suser-oc2pus suser-guru suser-tcousin suser-sbarnin kolab packman-i686 kraxel wine security
Note: I have corrected my list to include the space as you suggested, (thanks for that), however the copy paste action here seems to have deleted it!!

Drew
 
Old 09-25-2006, 10:27 AM   #14
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
Sorry, I cannot help you more on this subject, because I have not installed the new Apt version on my machine, and so I cannot try it myself. At this time I prefer to compile rather than use rpm packages.
I can only suggest 3 options to you:
1) Try the Smart package manager which seems to work to update KDE
2) Download the KDE rpm package files and install them manually under root/run level 3
3) Try to get an answer in this thread which is already opened and waits for new infos about the right format to use.
Good luck and sorry for not going further with you on this issue.
 
Old 09-25-2006, 10:51 AM   #15
drew boardman
LQ Newbie
 
Registered: Nov 2005
Location: Versailles, France
Distribution: Hardy Heron
Posts: 12

Original Poster
Rep: Reputation: 0
Dear Berbae

Thanks for all your help. I'll follow the thread you suggested.

Thanks again

Drew
 
  


Reply

Tags
apt, kde35, suse, yast


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
updating in slack10.1: apt-get? nadroj Linux - Newbie 12 05-30-2005 09:20 PM
erro updating with apt-get toddncl Linux - Software 1 08-20-2004 07:22 AM
updating kernel without apt-get! restless Debian 5 02-11-2004 03:02 AM
Updating the kernel with apt-get yamaduc Linux - Software 0 12-19-2003 11:08 AM
Problem updating KDE on Redhat using apt-get meeshka Linux - Software 5 06-15-2003 09:21 PM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration