Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 10-27-2004, 02:05 PM   #1
LQ Newbie
Registered: Oct 2004
Posts: 1

Rep: Reputation: 0
Unresolved symbol: xtime_lock

Hi, I am trying to install a kernel module on a smp box with 2.4.20 kernel patched with ethe high-res-timer patch. The insmod failed with the following error:

# insmod ./hrt_test.o
./hrt_test.o: unresolved symbol xtime_lock

The xtime_lock is referenced since posix_get_now() is called in the module.

In a single cpu box, this same module can be installed without the problem.

How can fix it?

Any help is greatly appreciated.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
unresolved symbol haddon Linux - Hardware 3 03-11-2005 02:24 PM
Unresolved symbol? Elonch Programming 2 03-01-2005 11:48 PM
unresolved symbol unregister_sound_special Daeljan Slackware 3 11-19-2004 06:22 PM
modprobe unresolved symbol DJSpaceMouse Linux - Software 3 08-08-2003 02:55 PM
SB Audigy Unresolved Symbol Metal Linux - Hardware 2 10-16-2002 07:05 AM

All times are GMT -5. The time now is 03:52 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration