LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 08-20-2007, 12:36 PM   #1
Josephus Ross
LQ Newbie
 
Registered: Mar 2007
Posts: 22

Rep: Reputation: 15
unmet dependencies


Hi There,

I am running debian 2.6.17 and I am trying to run an apt-get install however I keep getting a huge error when I try to install anything as follows;

:~# apt-get install bluez-utils
Reading package lists... Done
Building dependency tree... Done
util-linux is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
bash: PreDepends: libncurses5 (>= 5.4-5) but it is not installable
bluez-utils: Depends: libdbus-1-3 but it is not installable
Depends: modutils but it is not installable or
module-init-tools but it is not installable
Depends: dbus but it is not installable
cron: Depends: adduser but it is not installable
debconf: Depends: debconf-i18n but it is not installable or
debconf-english but it is not installable
defoma: Depends: whiptail but it is not installable or
dialog but it is not installable
Depends: file but it is not installable
dnsmasq: Depends: netbase but it is not installable
Depends: libdbus-1-3 but it is not installable
Depends: adduser but it is not installable
elvis-tiny: PreDepends: libncurses5 (>= 5.4-1) but it is not installable
fontconfig: Depends: libfontconfig1 (>= 2.4.0) but it is not installable
Depends: zlib1g (>= 1:1.2.1) but it is not installable
g++: Depends: gcc-4.1 (>= 4.1.1-2) but it is not installable
g++-4.1: Depends: gcc-4.1 (= 4.1.1-21) but it is not installable
gcc: Depends: gcc-4.1 (>= 4.1.1-2) but it is not installable
gnupg: Depends: libldap2 (>= 2.1.17-1) but it is not installable
Depends: libreadline5 (>= 5.2) but it is not installable
Depends: zlib1g (>= 1:1.2.1) but it is not installable
Depends: gpgv but it is not installable
grub: Depends: libncurses5 (>= 5.4-5) but it is not installable
initramfs-tools: Depends: module-init-tools but it is not installable
less: Depends: libncurses5 (>= 5.4-5) but it is not installable
libblkid1: Depends: libsepol1 (>= 1.14) but it is not installable
libc6: Depends: tzdata but it is not installable
libdevmapper1.02: Depends: libsepol1 (>= 1.12) but it is not installable
libedit2: Depends: libncurses5 (>= 5.4-5) but it is not installable
libfreetype6: Depends: zlib1g (>= 1:1.2.1) but it is not installable
libgnutls13: Depends: zlib1g (>= 1:1.2.1) but it is not installable
libopencdk8: Depends: zlib1g (>= 1:1.2.1) but it is not installable
libpango1.0-0: Depends: libcairo2 (>= 1.2.4) but it is not installable
Depends: libfontconfig1 (>= 2.4.0) but it is not installable
Depends: zlib1g (>= 1:1.2.1) but it is not installable
libpng12-0: Depends: zlib1g (>= 1:1.2.1) but it is not installable
libselinux1: Depends: libsepol1 (>= 1.14) but it is not installable
libssl0.9.8: Depends: zlib1g (>= 1:1.2.1) but it is not installable
libtiff4: Depends: zlib1g (>= 1:1.2.1) but it is not installable
libxcursor1: Depends: libxrender1 but it is not installable
libxft2: Depends: libfontconfig1 (>= 2.3.0) but it is not installable
Depends: libxrender1 but it is not installable
Depends: zlib1g (>= 1:1.2.1) but it is not installable
libxi6: Depends: libxext6 but it is not installable
libxinerama1: Depends: libxext6 but it is not installable
libxml2: Depends: zlib1g (>= 1:1.2.1) but it is not installable
lilo: Depends: mbr but it is not installable
login: Depends: libpam-modules (>= 0.72-5) but it is not installable
madwifi-modules-2.6.17-486-voyage: Depends: madwifi-tools but it is not going to be installed
Depends: linux-image-2.6.17-486-voyage but it is not installable or
kernel-image-2.6.17-486-voyage but it is not installable
ncurses-base: Depends: libncurses5 (>= 5.4-5) but it is not installable
ncurses-bin: PreDepends: libncurses5 (>= 5.4-5) but it is not installable
ntpdate: Depends: netbase but it is not installable
openssh-client: Depends: libncurses5 (>= 5.4-5) but it is not installable
Depends: zlib1g (>= 1:1.2.1) but it is not installable
Depends: adduser (>= 3.10) but it is not installable
openssh-server: Depends: zlib1g (>= 1:1.2.1) but it is not installable
Depends: libpam-modules (>= 0.72-9) but it is not installable
Depends: adduser (>= 3.9) but it is not installable
passwd: Depends: libpam-modules (>= 0.72-5) but it is not installable
ppp: Depends: libpam-modules but it is not installable
Depends: netbase but it is not installable
pptpd: Depends: netbase but it is not installable
procps: Depends: libncurses5 (>= 5.4-5) but it is not installable
python-bluez: Depends: python (< 2.5) but it is not installable
Depends: python (>= 2.3) but it is not installable
python-cairo: Depends: libcairo2 (>= 1.2.0) but it is not installable
Depends: python (< 2.5) but it is not installable
Depends: python (>= 2.3) but it is not installable
python-central: Depends: python (>= 2.3.5-7) but it is not installable
python-dbus: Depends: libdbus-1-3 (>= 0.94) but it is not installable
Depends: libdbus-glib-1-2 (>= 0.71) but it is not installable
Depends: python (< 2.5) but it is not installable
Depends: python-support (>= 0.3.4) but it is not installable
Depends: python (>= 2.4) but it is not installable
python-gtk2: Depends: python (< 2.5) but it is not installable
Depends: python-support (>= 0.3.4) but it is not installable
Depends: python (>= 2.4) but it is not installable
Depends: libcairo2 (>= 1.2.4) but it is not installable
Depends: libfontconfig1 (>= 2.4.0) but it is not installable
Depends: libgtk2.0-0 (>= 2.8.0) but it is not installable
Depends: libxext6 but it is not installable
Depends: libxrandr2 but it is not installable
Depends: libxrender1 but it is not installable
python-libxml2: Depends: python (>= 2.3) but it is not installable
Depends: python (< 2.5) but it is not installable
Depends: python-support (>= 0.3.4) but it is not installable
python-numeric: Depends: python (< 2.5) but it is not installable
Depends: python (>= 2.3) but it is not installable
python-soappy: Depends: python-support (>= 0.2) but it is not installable
python-xml: Depends: python (< 2.5) but it is not installable
Depends: python (>= 2.4) but it is not installable
python2.4: Depends: libreadline5 (>= 5.2) but it is not installable
python2.4-minimal: Depends: zlib1g (>= 1:1.2.1) but it is not installable
sqlite3: Depends: libreadline5 (>= 5.2) but it is not installable
Depends: libsqlite3-0 (>= 3.3.8) but it is not installable
sysvinit: Depends: libsepol1 (>= 1.14) but it is not installable
sysvinit-utils: Depends: libsepol1 (>= 1.14) but it is not installable
util-linux: Depends: tzdata (>= 2006c-2) but it is not installable
PreDepends: libncurses5 (>= 5.4-5) but it is not installable
PreDepends: zlib1g (>= 1:1.2.1) but it is not installable
wpasupplicant: Depends: libdbus-1-3 but it is not installable
Depends: libncurses5 (>= 5.4-5) but it is not installable
Depends: libreadline5 (>= 5.1) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Any ideas? My sources.list looks like this

# official Debian archives
deb http://security.debian.org/ stable/updates main contrib non-free
deb http://http.us.debian.org/debian/ stable main contrib non-free
deb http://http.us.debian.org/debian/ testing main contrib non-free
deb http://http.us.debian.org/debian/ unstable main contrib non-free
#deb-src http://http.us.debian.org/debian/ unstable main contrib non-free

# Experimental
deb http://http.us.debian.org/debian/ ../project/experimental main contrib

Any help would be greatly appreciated

Cheers

Joe
 
Old 08-20-2007, 01:09 PM   #2
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 129Reputation: 129
I wouldn't mix stable with experimental to begin with, certainly not on a system wide basis. Disable sid and testing and pray that no serious damage has been done yet.
 
Old 08-20-2007, 02:00 PM   #3
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 59
Dido:
Only un-comment those repositories that are not part of the version you're running when you need a specific package from that repository. For example:
If you do and "apt-get update" with all those repositories un-commented and apply all updates, you'll be running mostly unstable with stable base, which will give headaches till the day you decide to re-install from scratch. I usually only install the kernel from unstable, I'll un-comment the unstable repositories and do an apt-get update, there will be up to 200+ packages in the update section, I don't touch those, I normally only install the kernel and headers and their dependencies from unstable, then re-comment the unstable repositories and do another "apt-get update" so only testing updates are in the list as I'm running testing.
You may want to just stick with unstable now.

Also, not sure where your location is, but it may be better to use a mirror repository closer to your location rather than use the Debian main servers that most people use, which can reduce download speed, the mirrors will have the exact same packages. There is a list of all Debian mirrors in section 2.3 of the Apt Howto.
EDIT: Section 3 of the Apt Howto may help you get your system back on the right track.

Last edited by Junior Hacker; 08-20-2007 at 02:09 PM.
 
Old 08-20-2007, 03:55 PM   #4
Josephus Ross
LQ Newbie
 
Registered: Mar 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Sorry That was a mistake my debian list looks as follows;

# official Debian archives
#deb http://security.debian.org/ stable/updates main contrib non-free
#deb http://http.us.debian.org/debian/ stable main contrib non-free
#deb http://http.us.debian.org/debian/ testing main contrib non-free
deb http://http.us.debian.org/debian/ unstable main contrib non-free
#deb-src http://http.us.debian.org/debian/ unstable main contrib non-free

# Experimental
deb http://http.us.debian.org/debian/ ../project/experimental main contrib

As I can see it that should be ok right as both entries are unstable.
 
Old 08-20-2007, 04:39 PM   #5
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 129Reputation: 129
Disable Experimental. That repo is for developers only. In fact, if you look into the docs, people are emphatically discouraged from using it because it offers only half-completed, totally unstable packages that are too tricky to be included even in sid.
 
Old 08-20-2007, 08:19 PM   #6
Josephus Ross
LQ Newbie
 
Registered: Mar 2007
Posts: 22

Original Poster
Rep: Reputation: 15
ok cool, now I seem to be making some progress, However when I run apt-get update all seems well until after it has finished reading the package list when I get a warning as follows;

########################################################################

voyage:~# apt-get update
Get:1 ftp://ftp.uk.debian.org unstable Release.gpg [189B]
Hit ftp://ftp.uk.debian.org unstable Release
Err ftp://ftp.uk.debian.org unstable Release

Get:2 ftp://ftp.uk.debian.org unstable Release [79.6kB]
Ign ftp://ftp.uk.debian.org unstable Release
Get:3 ftp://ftp.uk.debian.org unstable/main Packages/DiffIndex [2038B]
Get:4 ftp://ftp.uk.debian.org unstable/contrib Packages/DiffIndex [2023B]
Get:5 ftp://ftp.uk.debian.org unstable/non-free Packages/DiffIndex [2023B]
Fetched 85.8kB in 24s (3463B/s)
Reading package lists... Done
W: GPG error: ftp://ftp.uk.debian.org unstable Release: Internal error: Good signature, but could not determine key fingerprint?!
W: You may want to run apt-get update to correct these problems

########################################################################

Not sure if this is important!?

Anyway, now when I try and install a package I get an error relating to dpkg;

########################################################################

voyage:~# apt-get install util-linux
Reading package lists... Done
Building dependency tree... Done
Suggested packages:
util-linux-locales kbd console-tools dosfstools
The following packages will be upgraded:
util-linux
1 upgraded, 0 newly installed, 0 to remove and 175 not upgraded.
Need to get 409kB of archives.
After unpacking 115kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
util-linux
Authentication warning overridden.
Get:1 ftp://ftp.uk.debian.org unstable/main util-linux 2.13~rc3-5 [409kB]
Fetched 409kB in 4s (97.9kB/s)
debconf: delaying package configuration, since apt-utils is not installed
dpkg: error processing /var/cache/apt/archives/util-linux_2.13~rc3-5_i386.deb (--unpack):
subprocess dpkg-deb --control killed by signal (Segmentation fault)
Errors were encountered while processing:
/var/cache/apt/archives/util-linux_2.13~rc3-5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

########################################################################

Thanks again for all the assistance so far.

Joe
 
Old 08-20-2007, 09:23 PM   #7
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 129Reputation: 129
Quote:
subprocess dpkg-deb --control killed by signal (Segmentation fault)
I don't like the look of that. Segmentation fault... I'm afraid that apt-get is completely disoriented what with all those repos. If you installed only recently, the most convenient solution would be to reinstall. It will take half an hour as opposed to a few days. If you do, just remember to use only one sort of repos an enable other ones only for the occasional package that is not available.

By the way, how come you have a 2.6.17 kernel? That doesn't really make sense if you're using unstable. 2.6.17, that must be Etch because unstable has reached 2.6.23 already... Which could indicate a second mistake: if you want to use sid, you need to get the cd for sid, not the one for Etch. Or you have to apt-get dist-upgrade from one to the other. But again,simply getting the sid iso and reinstalling is easier.
 
Old 08-21-2007, 12:36 AM   #8
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 59
If you want to use that specific mirror, the URL should be like this:
ftp://ftp.uk.debian.org/debian/
Personaly, I would use the http server unless net-select recommended the ftp server, because usually the http are faster, in which case the URL should be like this:
http://ftp.uk.debian.org/debian/
Your first error suggest there is a GPG key issue, I also had a look at that site by clicking on the link and saw Ubuntu in there, that's not normall for a Debian repository. Segmentation faults are usually produced by software not running right, try again with the proper URL first.
 
Old 08-21-2007, 12:46 AM   #9
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 59
Also, below is a sample of my unstable repository that works well, make sure to have spaces in the right places like this one:
Quote:
deb http://debian.yorku.ca/debian/ unstable main contrib non-free
 
Old 08-21-2007, 03:00 AM   #10
Josephus Ross
LQ Newbie
 
Registered: Mar 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Smile

when I try and run from that sources location I get the following issue;

:~# apt-get update
Get:1 http://debian.yorku.ca unstable Release.gpg [189B]
Hit http://debian.yorku.ca unstable Release
Err http://debian.yorku.ca unstable Release

Get:2 http://debian.yorku.ca unstable Release [79.6kB]
Ign http://debian.yorku.ca unstable Release
Get:3 http://debian.yorku.ca unstable/main Packages/DiffIndex [2038B]
Get:4 http://debian.yorku.ca unstable/contrib Packages/DiffIndex [2023B]
Get:5 http://debian.yorku.ca unstable/non-free Packages/DiffIndex [2023B]
Hit http://debian.yorku.ca unstable/main Packages
Fetched 85.8kB in 19s (4456B/s)
Reading package lists... Error!
E: Problem parsing Provides line
E: Error occurred while processing openoffice.org-l10n-ns (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/debian.yorku.ca_debian_dists_unstable_main_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.


It would be best for me to reinstall, Unfortunately I am accessing the system via ssh. Is there any way I can roll the system back to how it was when I first installed linux? Or alternatively can I install linux remotely?
 
Old 08-21-2007, 12:49 PM   #11
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 59
That link is a Canadian link and was just an example, you should stick with the UK mirror if it is closer. What you are missing in your UK mirror URL is the /debian/ at the end of the URL.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Amarok unmet dependencies erpe Debian 4 04-25-2006 02:23 AM
apt-get unmet dependencies, etc. knappster Linux - Software 13 12-14-2005 10:06 PM
unmet dependencies kpachopoulos Debian 3 11-23-2005 10:35 AM
apt-get unmet dependencies jeffbarish Debian 9 10-27-2005 12:19 AM
...packages have unmet dependencies? stribas Linux - Newbie 1 09-29-2004 09:55 AM


All times are GMT -5. The time now is 05:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration