LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-29-2003, 09:13 AM   #1
ixion
Member
 
Registered: Dec 2002
Location: USA
Distribution: SuSE, CentOS, Gentoo
Posts: 166

Rep: Reputation: 30
unable to view X in full res (only pans)


I cannot get X to run properly on an external monitor connected to my IBM Thinkpad laptop. I can startx, but the screen only shows 640x480 at a time. The actual desktop is 1024x768, and I can pan around it to see everything, but in all honesty, this is not a way to work.

These are the relevant sections of XF86Config:


Monitor(s)


Section "Monitor"

Identifier "Generic Monitor"

HorizSync 30-100
VertRefresh 60-160

EndSection

Section "Monitor"

Identifier "Laptop"
HorizSync 30-64
VertRefresh 60-75

EndSection



Device(s)


Section "Device"

Identifier "VESA"

Driver "vesa"

EndSection

Section "Device"
Identifier "RADEON"
Driver "radeon"
EndSection



Screen


Section "Screen"

Identifier "Screen 1"
Device "RADEON"
Monitor "Generic Monitor"

DefaultDepth 24

SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
Virtual 1024 768
EndSubsection

EndSection


edit: I'm using Fluxbox as my Window Manager.

Last edited by ixion; 07-29-2003 at 09:15 AM.
 
Old 07-29-2003, 09:21 AM   #2
fancypiper
Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Try control-alt-numpad+ or control-alt-numpad- to cycle through your resolutions, or remove the unwanted resolutions. My section:
Code:
Section "Screen"
        Identifier "Screen0"
        Device "NVIDIA GeForce 2 MX (generic)"
        Monitor "MAG 570V"
       	DefaultDepth 24
        Subsection "Display"
               	Depth 24
               	Modes "1024x768"
        EndSubSection
EndSection
 
Old 07-29-2003, 09:24 AM   #3
ixion
Member
 
Registered: Dec 2002
Location: USA
Distribution: SuSE, CentOS, Gentoo
Posts: 166

Original Poster
Rep: Reputation: 30
I had actually already tried that, but tried again (both the Ctrl+Alt+numpad +/-, and restricting the res to 1024x768) to no avail.

btw, it also occurs in Enlightenment, so apparently it's not a fluxbox problem as I thought it was.
 
Old 07-29-2003, 09:32 AM   #4
fancypiper
Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
# Configuring X
Linux Hardware Compatibility HOWTO - video cards
The Linux XFree86 HOWTO
Common X configuring tools:
Debian - dpkg-reconfigure xserver-xfree86
Mandrake - XFdrake
Redhat 7.3 down - the setup utility leads to several config tools
Redhat 7.3 up - redhat-config-xfree86
You may have these tools:
XF86Setup
XFree86 -configure
Xconfigurator
xf86cfg
xf86config
xconf
ATI Linux drivers
If you need the nVidia driver, most likely, you want the Linux IA32 driver
 
Old 07-29-2003, 09:37 AM   #5
ixion
Member
 
Registered: Dec 2002
Location: USA
Distribution: SuSE, CentOS, Gentoo
Posts: 166

Original Poster
Rep: Reputation: 30
how will those help this situation? I still need my laptop screen while on the road. There's got to be one setting somewhere in there that I don't know about so I can view full-screen with an external monitor. Is there something you see that's wrong with my XF86Config file? Here's the complete config:
Section "Files"

RgbPath "/usr/X11R6/lib/X11/rgb"

FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"

EndSection

Section "Module"

Load "dbe"

SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
Load "type1"
Load "freetype"
Load "glx"
Load "dri"

EndSection


Section "ServerFlags"

Option "blank time" "10" # 10 minutes

Option "standby time" "20"
Option "suspend time" "30"
Option "off time" "60"

EndSection

Section "InputDevice"

Identifier "Keyboard1"
Driver "keyboard"

Option "AutoRepeat" "500 5"

EndSection


Section "InputDevice"

Identifier "Mouse1"
Driver "mouse"

Option "Protocol" "PS/2"
Option "Device" "/dev/mouse"

EndSection

Section "InputDevice"
Identifier "Mouse2"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"

Identifier "Generic Monitor"

HorizSync 30-100
VertRefresh 60-160

EndSection

Section "Monitor"

Identifier "Laptop"
HorizSync 30-64
VertRefresh 60-75

EndSection

Section "Device"

Identifier "VESA"

Driver "vesa"

EndSection

Section "Device"
Identifier "RADEON"
Driver "radeon"
EndSection

Section "Screen"

Identifier "Screen 1"
Device "RADEON"
Monitor "Generic Monitor"

DefaultDepth 24

SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
Virtual 1024 768
EndSubsection
EndSection


Section "ServerLayout"

Identifier "Main Layout"
Screen "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Mouse2" "SendCoreEvents"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection
 
Old 07-29-2003, 09:45 AM   #6
fancypiper
Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
I was suggesting trying other configuration tools you might have.

Try saving your config file with a different name and try some of the other configuring tools to see if you can get the resolution you want.

If you can't, rename the backup to the orig name and you are back where you started.
 
Old 07-29-2003, 09:54 AM   #7
ixion
Member
 
Registered: Dec 2002
Location: USA
Distribution: SuSE, CentOS, Gentoo
Posts: 166

Original Poster
Rep: Reputation: 30
ok, I see what you mean..

actually I went with the VESA drivers instead of RADEON and the problem does not exist. It's got to be some setting with the RADEON kernel module. Oh well, I'm happy with VESA... this is a work laptop, so game playing is not really an option here anyway.


I mean NO FLAME in this, but it's just one more reason to not use Linux with ATI products. And since I'm a die hard linux'er, no ATI for me (when possible)..

edit: THANKS FOR YOUR HELP! :-D

Last edited by ixion; 07-29-2003 at 09:56 AM.
 
Old 07-29-2003, 10:02 AM   #8
fancypiper
Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
You have to admit that they are much slower than nvidia with their Linux support.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandriva 10.2 on Dell LS400 - Unable to Increse Video Res from 800x600 1mOrEnEwBiE Mandriva 3 08-21-2005 09:22 PM
unable to view contents of /home anubhuti_k General 4 11-20-2004 06:02 AM
unable to view contents of /home anubhuti_k Linux - Software 4 11-20-2004 12:04 AM
Unable to view cd files erycz Linux - General 1 11-04-2003 09:24 PM
Unable to view Windows from Linux studentforever Linux - Software 3 08-08-2003 11:45 PM


All times are GMT -5. The time now is 05:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration