LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-29-2006, 02:40 PM   #1
billybadfoot
LQ Newbie
 
Registered: Dec 2006
Location: UK
Distribution: Fedora
Posts: 8

Rep: Reputation: 1
Unable to access files from XP via Samba after upgrade to FC6


I had a working Samba configuration on a Linux box so that I could access some files in a public share on the Linux box from an XP desktop. When working, the Linux version was FC3 with Samba version 3.0.10-1.

I upgraded the Linux box to FC6, which included upgrading the Samba to 3.0.23c-2.

Now when I try and access the Linux files in the 'public' share. I can see the files (in explorer or using dir in a DOS box), but I can't copy the files or open them. In the dos box, when I try and copy them I get an 'Access is denied' error.

The smb.conf file is pretty minimal, but it worked before the upgrade and doesn't work following the upgrade.
[global]
workgroup = WWG
netbios name = SRV1
username map = /etc/samba/smbusers
security = user

[public]
path = /export
read only = yes
guest ok = yes
browseable = yes
I'm not sure whether the problem is with Samba, FC6 or XP, which is why I'm posting here.

Thanks for any hints
Bill
 
Old 12-29-2006, 02:54 PM   #2
dombrowsky
Member
 
Registered: Dec 2005
Location: New York
Distribution: Debian/GNU
Posts: 235

Rep: Reputation: 31
the problem is almost definitely in how you configure samba, and how you connect to it from windows.

good luck finding it

try and take as many users out of the picture as possible. RTFM for smb.conf(5).
 
Old 12-29-2006, 04:15 PM   #3
elmr007
Member
 
Registered: Aug 2006
Location: Texas
Distribution: FC6
Posts: 60

Rep: Reputation: 15
try adding "valid users = (xp address) to your smb.conf file if it is not already there. I will warn you tho, I have the same problem

It seems to me that fedora has incorporated a KDC controller that is messing mine up and it's beond me. neither have had any luck asking around about it. I get the same error you have in explorer but when I also try telnet,ftp or ssh I get "cannot resolve network address while getting inital credentials in KDC realm."

thers's not really much good documentation on Kurbose that I have found.
 
Old 12-29-2006, 06:07 PM   #4
Basslord1124
Member
 
Registered: Jun 2004
Location: Ashland, KY
Distribution: Debian, Puppy/Slacko
Posts: 351

Rep: Reputation: 31
Just out of curiosity, but did you run the smbpasswd script and add the necessary users? I have configured Samba under Slackware so not sure what small differences there are between it and FC. Was this an upgrade to FC6 or did you just reinstall? And if it is a permission error, I'd be looking at permissions on those said directories/files.
 
Old 12-30-2006, 05:14 AM   #5
billybadfoot
LQ Newbie
 
Registered: Dec 2006
Location: UK
Distribution: Fedora
Posts: 8

Original Poster
Rep: Reputation: 1
I read the smb.conf and couldn't see anything wrong with my simple smb.conf file. However I decided to restrict all of the user access to the 'nobody' account.

To do this I changed the security from 'user' to 'share', opened up the public share to be writeable by setting the 'read only' parameter to 'no', and set the 'guest only' parameter to yes. I also changed the ownership of all the files in the 'public' share to 'nobody'.

I don't knowingly use Kerberos, so I don't think that has any bearing on the issue.

I put in a 'valid users' parameter, but according to the man page for smb.conf, this should be a list of users rather than an xp address, so I set it to 'nobody'.

My smb.conf file now looks like this:
[global]
workgroup = WWG
netbios name = SRV1
security = SHARE
valid users = nobody

[public]
path = /export
read only = No
guest only = Yes
guest ok = Yes
However, now that the share is writeable, the behaviour of files is more ionteresting. I can create files in XP, but not rename them. I can copy files to the share, but then cannot read them. Having created a file under XP, I can rename it on the Linux box, and amend the contents. I can then read the amended file on the XP box, and can copy it elsewhere, but I can't rename it under XP or do any further editing on XP.

Very strange. I'll keep trying.
 
Old 12-30-2006, 10:53 AM   #6
dombrowsky
Member
 
Registered: Dec 2005
Location: New York
Distribution: Debian/GNU
Posts: 235

Rep: Reputation: 31
keep hacking. If you find the answer, I'm sure everyone here would thank you for writing it up. Samba problems are such a bear to figure out. I think its because of all the reverse-engineering involved; micros0ft doesn't exactly stick to specifications very well, even their own.

As far as kerberos, I have to admit I'm clueless. Does samba use kerberos for authentication by default? Kerberos is an authentication/encryption scheme originally developed by MIT.
 
Old 12-31-2006, 04:08 PM   #7
elmr007
Member
 
Registered: Aug 2006
Location: Texas
Distribution: FC6
Posts: 60

Rep: Reputation: 15
Fedora 6 by default uses kerberos. However, your problem is sounding more like permissions...

See if adding "public = yes" helps any. are your logs giving any hints? also found the following that might be usefull:

create mask = 0644

The option create mask specifies and sets the necessary permissions according to the mapping from DOS modes to UNIX permissions. With this option set to 0644, all file copying or creating from a Windows system to the Unix system will have a permission of 0644 by default.

directory mask = 0755

The option directory mask specifies and set the octal modes, which are used when converting DOS modes to UNIX modes when creating UNIX directories. With this option set to 0755, all directory copying or creating from a Windows system to the Unix system will have a permission of 0755 by default.

hosts allow = 192.168.1.4 127.0.0.1

The option hosts allow specifies which hosts are permitted to access a Samba service. By default, we allow hosts from IP class C 192.168.1.4 and our localhost 127.0.0.1 to access the Samba server. Note that the localhost must always be set or you will receive some error messages.
 
Old 01-06-2007, 11:00 AM   #8
billybadfoot
LQ Newbie
 
Registered: Dec 2006
Location: UK
Distribution: Fedora
Posts: 8

Original Poster
Rep: Reputation: 1
I'm attempting to do an install of FC6 rather than an upgrade, and will re-enable Samba once I have got it up & running again.

However while waiting for the install to finish, I found an interesting article which seems to relate to my original problem and the article suggested that the issue might be SELinux related.

It also suggested that this theory can be checked by switching off SELinux for Samba by:
/usr/sbin/setsebool -P smbd_disable_trans 1
But this will obviously lose the benefits of SELinux

I also found a post in a different forum which explains how to configure for Samba/SELinux properly and also how to upgrade and reset the permissions properly. The post is at http://lists.samba.org/archive/samba...ay/120632.html

Last edited by billybadfoot; 01-06-2007 at 05:30 PM.
 
Old 01-21-2007, 09:17 PM   #9
Robert Moyer
LQ Newbie
 
Registered: Jan 2007
Posts: 3

Rep: Reputation: 0
Your suggestion solved my immediate problem, although I don't understand why.

Forums>linux>linux-software>linux-server>"Samba only shgares directories on system disk"

Thanks for the information.

Robert
 
  


Reply

Tags
permissions, samba, share, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC6 unable to acess shared files systemix Linux - Newbie 2 12-08-2006 03:34 PM
FC6 beta3 upgrade to Final FC6 thyraios Fedora 1 09-18-2006 07:55 PM
SAMBA:unable to access win2k from linx apit Linux - Networking 1 12-01-2004 07:19 PM
Samba 2.2.8 - Unable to access shared resources takatam Linux - Networking 2 08-10-2004 05:22 AM
unable to access files stress Mandriva 0 10-11-2003 01:29 PM


All times are GMT -5. The time now is 12:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration