LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Ugly Truetype font in GTK apps (http://www.linuxquestions.org/questions/linux-general-1/ugly-truetype-font-in-gtk-apps-143890/)

kvzrock 02-08-2004 10:35 PM

Ugly Truetype font in GTK apps
 
i did KDE Control Center=>System Administration=>font installer and installed the following fonts:
tahoma.ttf
arial.ttf
times.ttf

After I set tahoma as my default font, KDE's appearance is perfect. Fonts are crisp and they look as good as in windows. Openoffice can also recognize those fonts, the interface is using tahoma and i can type in Times New Roman. All fonts look fantastic.

but fonts in gtk2.0 apps don't have the same crisp look as they do in KDE and openoffice.
I have tested gtk depended apps such as Gaim 0.75 and ethereal, and fonts in them all have the same problem. After i have googled around, i'm pretty sure that what causes the truetype fonts in gtk app to look ugly is that fonts are not subpixel hinted (i'm using a Laptop w/ LCD).

Then i uncommment the stuff in /etc/fonts/local.conf that is supposed to enable subpixel hinting. But fonts in Gaim still look ugly as they were before.

Since i'm using a LFS system, i bring up the BLFS 5.0 book and trace the GTK dependency. I find that GTK depends on Pango which does the text rendering for GTK and I found that i forgot to set the environment variable PKG_CONFIG_PATH to /usr/X11R6/lib/pkgconfig after i have installed X. Without setting the PKG_CONFIG_PATH, pango won't recognize Freetype 2 which handles fonts in X. I am sure that Freetype 2 is working because otherwise i wouldn't get crisp truetypes fonts in KDE. So i recompile pango, make uninstall the existing version, and install the new version. Then i recompile and reinstall GTK 2.2.4 and gaim 7.5. But after all that, fonts in Gaim haven't changed a bit. It seems that no matter what i put in /etc/fonts/local.conf, fonts in GTK apps remain the same. I also try to sync the ~/.fonts.conf w/ /etc/fonts/local.conf, but doesn't seem to help either.

I am stuck. Appreciate any help in advance.

Here's my /etc/fonts/local.conf
?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>
<dir>/usr/X11R6/lib/X11/fonts/truetype</dir>

<match target="font">
<edit name="rgba" mode="assign"><const>rgb</const></edit>
</match>
</fontconfig>

My ~/.gtkrc-2.0 (specifies which font GTK apps use in their interfaces)

gtk-entry-select-on-focus = 1
#style "user-font"
#{
# font_name = "Tahoma 12"
#}

#widget_class "*" style "user-font"
#commented sections i am told are deprecated.

gtk-font-name = "Tahoma 12"

#gtk-key-theme-name = "Emacs"


All times are GMT -5. The time now is 01:45 AM.