LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   UEFI Grub2 and Boot Strange Boot Issues (http://www.linuxquestions.org/questions/linux-general-1/uefi-grub2-and-boot-strange-boot-issues-4175453772/)

zombieno7 03-12-2013 10:06 AM

UEFI Grub2 and Boot Strange Boot Issues
 
I've been encountering some strange issues with Grub2 as of late, and I don't quite know why. I don't have much experience with UEFI, but as I understand it, it can boot in a traditional bios fasion if the board is not locked down with secureboot. The board I have now does have UEFI bios, but no secureboot, yet every installer that I've tried(Debian 7, Fedora 18, Mint, and Arch) forces an EFI boot partition on me stating that it will not be able to boot if I have a standard /boot. When I do go with the EFI boot method, the system will install fine, but if I disconnect the HDD or change around devices on my SATA ports, the board no longer recognizes the instllation(whichever one it may be) and dows not boot. What is it that I'm missing? Is this normal for UEFI, or an issue with my motherboard?

ronlau9 03-21-2013 02:09 PM

Quote:

Originally Posted by zombieno7 (Post 4909976)
When I do go with the EFI boot method, the system will install fine, but if I disconnect the HDD or change around devices on my SATA ports, the board no longer recognizes the instllation(whichever one it may be) and dows not boot. What is it that I'm missing? Is this normal for UEFI, or an issue with my motherboard?

Well I am not a hardware expert but if you change the SATA connections of a hd's you also change the devices names .
So it can not find the correct installation place any more


All times are GMT -5. The time now is 12:44 PM.