LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-16-2007, 09:29 AM   #1
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
Trying webmin, getting "attempt to connect to 127.0.0.1:10000 (localhost) failed"


Hi folks, been a while...

I'm running fedora core 3 on my home linux box. I've got apache set up and use it for my webpage, have been for years. Recently I decided to try to set up a way to use a command shell via a webpage, so I can do regular maintenance, etc from my phone's web browser and from anybody's home internet connection, without having to use things like putty, etc.

So, I installed webmin. I've tried it both with the default location - by running setup.sh without any additional switches - and by installing it to /var/www/html/webmin.

In either case I use the following (this is a paste from the install instructions at doxfer.com):

################################################################################
The steps to follow are:

1. Make sure mod_proxy is installed on your Apache webserver.
2. Add the following directives to the Apache configuration file:

ProxyPass /webmin/ http://localhost:10000/
ProxyPassReverse /webmin/ http://localhost:10000/

3. Add the lines webprefix=/webmin and webprefixnoredir=1 to /etc/webmin/config.
4. In /etc/webmin/config, add the line referer=apachehost, where apachehost is the hostname from the URL used to access Webmin via Apache. If the referer line already has some hosts listed, add apachehost to it.
5. Re-start Apache to apply the configuration.

All requests to /webmin on the Apache server will then be passed through to the Webmin server on localhost port 10000. All features should work fine, including themes, with the exception of IP access control (because as far as Webmin is concerned, all connections will be coming from localhost).
################################################################################

I should add that in the part above where it says to replace apachehost with "the hostname from the URL used to access Webmin via apache" - I'm not sure what to put there. Do I put my IP, or the web address (theblumls.com), or what? PLEASE inform me on this one!!

Now, every time I point my browser to http://myhomepage.com/webmin I get the following:
"The proxy server received an invalid response from an upstream server."

When i look at /var/log/httpd/error_log i see this:
"[Thu Aug 16 07:52:04 2007] [error] (111)Connection refused: proxy: HTTP: attempt to connect to 127.0.0.1:10000 (localhost) failed"

I get this even if I try to connect straight to my IP address too, as in http://xxx.xxx.xxx.xxx/webmin ...
I can still access the normal webpages just fine.

At this point I'm not even sure what other info would be helpful to post here, so please let me know what else you need to see to help me figure this out. I still consider myself a bit of a newbie (even though I've been windows free for roughly 5 years now I think), so please bear with me if I use the wrong nomenclature or seem dense.

I should add I've also got ssh running on my machine, which works just fine and I can connect on both ports 22 and 25 (25 is so I can connect via my cell phone which has 22 blocked).

Please tell me what to check next. Or, if you know of a different utility that'll give me a bash shell in a webpage that is easier to set up, please point me in the right direction.

Thanks in advance!!

Jeff

Last edited by jeffreybluml; 08-16-2007 at 09:41 AM.
 
Old 08-16-2007, 11:16 AM   #2
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Original Poster
Rep: Reputation: 30
Hmmm,

Well, I changed the proxy section in my httpd.conf, where it said

<Proxy *>
Order deny,allow
Deny from all
Allow from all
</Proxy>

I changed it to

<Proxy *>
Order allow,deny
Allow from all
Deny from all
</Proxy>

And now I think I'm getting somewhere. Now when I try to access it I get my Error403 document. I think that's a permissions thing, right?

So, I tried to make sure everything is set up right as far as permissions go. I added the following to httpd.conf:

<Directory "/var/www/html/webmin">
Options FollowSymLinks ExecCGI +Includes
AllowOverride None
</Directory>

And I added index.cgi to the DirectoryIndex directive. No matter what I do I still get the 403 document.

Please help!!

Thanks,
 
  


Reply

Tags
apache, proxy, webmin


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"hub.c : connect-debounce failed, port 1 disabled " slk Linux - Software 3 11-10-2009 10:37 AM
connect debian etch to IBM SAN, meaning of "SNS scan failed" ? vmm_sys Linux - Enterprise 4 08-29-2007 04:37 AM
samba/swat: can't connect to "http://localhost:901/" bioe007 Slackware 5 06-05-2007 11:14 AM
KDE/CUPS printer slow to start up; fixed with "127.0.0.1 localhost" in /etc/hosts KWTm LinuxQuestions.org Member Success Stories 0 03-05-2005 11:11 AM
bind and named and "rndc: connect failed: connection refused" coffee9876 Linux - Networking 3 12-16-2003 10:50 AM


All times are GMT -5. The time now is 06:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration