LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-06-2005, 09:21 AM   #1
slinky2004
Member
 
Registered: Oct 2004
Posts: 309

Rep: Reputation: 30
tryhing to fix my system clock time


well, i've just reinstalled slackware and i selected eastern for my timezone, but for some reason the date and time are way off. how can i fix this? apparently this is controlled by some kind of hardware clock? so is that like a clock thats part of my mobo or what?
 
Old 10-06-2005, 09:26 AM   #2
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,006
Blog Entries: 5

Rep: Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782
You can use the "date" command to set system date and time.

You can also setup ntpd to synchronize your time automatically to external sources that have the correct time.
 
Old 10-06-2005, 12:03 PM   #3
slinky2004
Member
 
Registered: Oct 2004
Posts: 309

Original Poster
Rep: Reputation: 30
so, date sets the hardware clock? i guess this clock is part of my bios or something?
 
Old 10-06-2005, 04:53 PM   #4
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,006
Blog Entries: 5

Rep: Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782
You can set the clock by going into setup mode on boot (assuming this is a PC). Most systems will prompt you to hit F2 or Del during boot to get to that mode. Just be careful not to muck with anything else.

In any event I believe the date command will set the system clock so you shouldn't need to do that.
 
Old 10-06-2005, 05:08 PM   #5
paranoid times
Member
 
Registered: Jan 2005
Distribution: Fedora Core 3, 4
Posts: 135

Rep: Reputation: 16
I've fixed that problem in varous ways. the date command works sometimes, but I have had it (at least in FC3) be a timezone problem, where the clock apparently has 2 different time zone settings. one of which is configured somewhere relitivly odvious. but the one that causes me problems is I guess a filter for quick checking. if I right click on the clock there is a option for "show timezone" which has 7 different places in the world, and local time. sometimes when my clock is hours off one of the places in the world where I am not has been selected. so you might want to check that.
 
Old 10-06-2005, 06:00 PM   #6
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
You should have a read of this. Although it is Debian specific it is a good description of the standard linux setup.

http://www.debian.org/doc/manuals/sy...dmin-time.html

The normal thing is to have your hardware clock set to UTC time (basically London time with no daylight saving correction). Your local timezone setting converts this as needed, hiding the UTC time from the user. Systems on UTC can use the NTP protocol to synchronise their hardware clocks regardless of location and local daylight saving.

It is also possible to have the hardware clock set to local time. On slackware I think this is determined by the file /etc/hardwareclock. I'm guessing this does some contortions to present the time correctly, but I don't know if it can deal with daylight saving or NTP servers.

A standard mistake is to have the system configured for UTC with the hardware clock on local time.
 
Old 10-06-2005, 06:43 PM   #7
slinky2004
Member
 
Registered: Oct 2004
Posts: 309

Original Poster
Rep: Reputation: 30
well, my bios setup doesnt seem to have any clock settings, temperature readings, etc. for some reason, but since i can access them with date, acpi, etc. i'm fine. they kinda ripped me on the bios(phoenix) tho. my sister has a dell inspirion and her bios has like diagrams showing temperature, battery power, the works
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Various clock issues: Clock shows wrong time only in Knoppmyth, & CMOS time change ? davidbix General 1 04-05-2006 09:58 PM
need to fix system clock on slackware 10.0 salviadud Slackware 3 03-02-2005 01:50 PM
System clock loosing time... JaseP Linux - Hardware 5 11-05-2004 04:00 PM
synchronising system time with an atom clock schatoor Linux - Software 2 05-13-2003 07:58 AM
system clock is hideously slow - ntpd refuses to fix it elconde Linux - General 1 02-21-2003 12:07 PM


All times are GMT -5. The time now is 10:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration