LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-11-2004, 09:05 AM   #1
scottd431
LQ Newbie
 
Registered: Nov 2004
Location: NC
Distribution: RH
Posts: 2

Rep: Reputation: 0
Trouble with a shell script running with inetd


We are trying to get a shell script to run that listens on a port and when it receives the query it runs a program. Below are our entries in inetd,conf, services and the shell scripts. What is happening it recongnizes the quesrt coming in on the port and it runs the script but it only runs the 1st line. We have run the scrip from the command line and it works. Can anyone tell me what might be causing it to hang up after the first line. Could it be the inetd.conf entry? Thanks for all of you help in advance. Scott
1. /etc/services ENTRY

labcorp 9004/tcp # LABCORP HL7

2. the inted.conf ENTRY (SHOULD THERE BE an ARGUMENT at the end?)

labcorp stream tcp nowait root /boot/usr/newsoft/labhl7

3. the labhl7 script

/boot/usr/newsoft/lab_run

4. lab_run script (we had it all under one script and tried to break it out to see if that would work and it did not) (it only runs the 1st line)

cat > /boot/usr/newsoft/GETLAB
cp /boot/usr/newsoft/GETLAB /boot/usr/newsoft/GETLAB2
# /boot/usr/newsoft/rmrk /boot/usr/newsoft/GETLAB /boot/usr/newsoft/GETLAB2
/boot/usr/newsoft/labcor.lod
/boot/usr/newsoft/lab_omni.4ge
cat /boot/usr/newsoft/LABCOR >
#done
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
running a script from inetd/xinetd spyghost Linux - Networking 3 09-20-2005 04:12 AM
Trouble with a shell script running with inetd scottd431 Linux - Networking 0 11-11-2004 09:57 AM
Trouble in Shell Script Gerardoj Linux - General 6 12-02-2003 09:21 PM
inetd script in /etc/init.d is running amuck int0x80 Linux - Newbie 1 03-07-2003 09:51 PM
c/c++ running a shell script? thermalpants Programming 3 05-12-2002 11:41 AM


All times are GMT -5. The time now is 09:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration