LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-15-2002, 06:45 PM   #1
Venomous Squirr
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Rep: Reputation: 0
Total Newbie, pleae help me out


Well I just installed Linux Red Hat 8.0 today, and I really like it. Mostly just for the change of pace. Well anyways I have two problem.

First I can't get my wheel mouse to work, specificly the wheel part. Ive searched google and everything and found some stuff but it's super confusing for a newb like myself. Is there an easy way to do it? Or can somone explain the hard way to do it to me?

The second thing is I cannot get my sound blaster Audigy Gamer to work. It shows that it is detected, along with my onboard sound (which is disabled in bios) when I go to the gnome menu (start like thing) >> System Settings >> Sound Card Detection. But when I try to play a test sound nothing works (on either of them).

I have found the drivers from sourceforge (http://sourceforge.net/project/showf...group_id=44773) then I try to follow these instructions (http://sourceforge.net/docman/displa...group_id=44773), but I get tottaly lost. I dont know if I have the source go to my kernal (step 1). I don't know how to untar (step 2). I can't do anything. I really want to give Linux a fair shot, but I don't kow what the heck im doing. Can someone please help me out here? If you want you can message me on AIM at Venomous Squirrel.

Maybe just regular SB drivers will work?

Thanks in advance
 
Old 10-15-2002, 07:43 PM   #2
Venomous Squirr
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Original Poster
Rep: Reputation: 0
No one?
 
Old 10-15-2002, 08:07 PM   #3
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 57
Welcome to LQ, Squirrel.

Soundcard issues: Try, when you log in, open a text console (the thing that looks a bit like the ol' Dos box) and change to the superuser by typing su root, then enter root's password. Once you're running as root, try typing lsmod and post the output here.
 
Old 10-15-2002, 08:57 PM   #4
Venomous Squirr
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Thymox
Welcome to LQ, Squirrel.

Soundcard issues: Try, when you log in, open a text console (the thing that looks a bit like the ol' Dos box) and change to the superuser by typing su root, then enter root's password. Once you're running as root, try typing lsmod and post the output here.
tells me this:
[root@localhost RVB]# lsmod
bash: lsmod: command not found

In the instructions to the Audigy it says:
Before compiling the driver, you must make sure you have the source code to your kernel available on your system. If you haven't compiled your own kernel, you should install the kernel sources which came with your distribution. Typically, this is a package with "kernel-source" in its name. Most distributions will install the sources in either /usr/src/linux or /usr/src/linux-2.4

But I have nothing in either of thse folders, were is my kernel sources located? Could it be /lib/modules/2.4.18-14/kernel? If so how do I do what the instructions say? If not were is the RH 8 Kernel Source?
 
Old 10-16-2002, 06:35 AM   #5
Venomous Squirr
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Original Poster
Rep: Reputation: 0
anyone?
 
Old 10-16-2002, 07:46 AM   #6
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 57
Yeah, some of us have to sleep, you know!

Hmmm, not sure why lsmod isn't working... I'm sure that the Audigy works with the standard emu10k1 modules (Linux's term for drivers). To answer your questions, the kernel source has probably not been installed from your CDs, so you'll need to put in the CDs and find the file kernel-source-2.4.18-14.SOMETHING.rpm where something is either i386 or athlon, depending on your processor type (type uname -all to find out which kernel version you're running) and install it.
 
Old 10-16-2002, 10:14 AM   #7
Venomous Squirr
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Well if the emu10k1 is suspose to be working it's not.

Ok so I type uname -all in the terminal, to find out which kernal source to install, then find that kernel source on the disc (which one, anyone know?) then install that kernel source. Will it automatically go to the right spot for me to install the audigy drivers? Or will I need to change something. Thanks everyone for all there help.
 
Old 10-16-2002, 11:11 AM   #8
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 57
When you install the kernel source from the CD (I believe it's on CD1) then it should be put in the correct place (/usr/src/linux). But I'm still a little concerned as to why your lsmod doesn't work. a) are you sure you were running as root? b) This might sound rude, but you did type LSMOD in small letters? It's a common error when looking at something on screen to confuse l (little L) with I (capital I)?
 
Old 10-16-2002, 11:35 AM   #9
Vlad_M
Member
 
Registered: Aug 2002
Location: Cape Town, South Africa
Distribution: Red Hat 8.0 (Home), Red Hat 8.0 (Work)
Posts: 388

Rep: Reputation: 30
His lsmod is not working because he su'ed to root, and didn't load the root environment.

Try typing /sbin/lsmod and it will work. Or, once you have su'ed to root type

/bin/su -

and then you'll be able to see your modules by just typing lsmod at the command prompt.

As for the mouse, I had the same problem and I was kindly pointed to search this board. I had the answer within minutes. Basically you have to edit your pointer section in the /etc/X11/XF86Config-4... exactly what to change do a search on this board for 'mousewheel' and you'll find it.

Cheers,
Vlad
 
Old 10-16-2002, 12:28 PM   #10
Venomous Squirr
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Yes I was doing LSMOD in lower case.

So you can't SU to root? You have to load the root enviorment? How do you do that? I will try all your advice when I get home, and report what has happend. Thank you all for you help.
 
Old 10-16-2002, 12:37 PM   #11
The_Butler_1999
LQ Newbie
 
Registered: Oct 2002
Posts: 8

Rep: Reputation: 0
First
run mouseconfig and select MS Intellimouse /PS2 for your mouse
I dont like usb hardware so i dont use them
then restart X. If the mouse doesnt work use the following config in the XF86Config-4 file in your /etc/X11 directory
Section "InputDevice"
Identifier "Mouse0"
# Modified by mouseconfig
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

From one to another

 
Old 10-16-2002, 12:53 PM   #12
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 57
Now, you see, this is why it would be better to have started two threads with seperate questions in them...
 
Old 10-16-2002, 01:13 PM   #13
Vlad_M
Member
 
Registered: Aug 2002
Location: Cape Town, South Africa
Distribution: Red Hat 8.0 (Home), Red Hat 8.0 (Work)
Posts: 388

Rep: Reputation: 30
Quote:
Originally posted by Venomous Squirr
Yes I was doing LSMOD in lower case.

So you can't SU to root? You have to load the root enviorment? How do you do that? I will try all your advice when I get home, and report what has happend. Thank you all for you help.
You can su to root, but all you are doing is acquiring root permissions. Your path is still that of a user, and the /sbin directory is not in the user path by default (only in the root path).

That's why I said that you should type

/bin/su -

at the prompt, this way you will invoke the root path (among other things).

Later,
Vlad.
 
Old 10-16-2002, 04:43 PM   #14
Venomous Squirr
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Thymox
Yeah, some of us have to sleep, you know!

Hmmm, not sure why lsmod isn't working... I'm sure that the Audigy works with the standard emu10k1 modules (Linux's term for drivers). To answer your questions, the kernel source has probably not been installed from your CDs, so you'll need to put in the CDs and find the file kernel-source-2.4.18-14.SOMETHING.rpm where something is either i386 or athlon, depending on your processor type (type uname -all to find out which kernel version you're running) and install it.
I get this...
[root@localhost RVB]# uname -a
Linux localhost.localdomain 2.4.18-14 #1 Wed Sep 4 12:13:11 EDT 2002 i686 athlon i386 GNU/Linux

I see athlong in there and i386, so what do I do now? I found them on the disc. There is kernel-source-2.4.18-14.athlon.rpm, kernel-source-2.4.18-14.i586.rpm and kernel-source-2.4.18-14.i686.rpm in the rpms folder of the first disc.
 
Old 10-16-2002, 05:13 PM   #15
Vlad_M
Member
 
Registered: Aug 2002
Location: Cape Town, South Africa
Distribution: Red Hat 8.0 (Home), Red Hat 8.0 (Work)
Posts: 388

Rep: Reputation: 30
Lets start by posting the results of the lsmod first, so that we can see if the sound card modules are being loaded at all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 2 install with total Newbie davy999 Linux - Newbie 15 08-08-2004 01:07 PM
Total newbie, problems with lilo xanas3712 Linux - Newbie 27 04-09-2004 09:11 AM
Total newbie, sorry. How do you install software in Linux? chriswhitworth Linux - Software 10 11-08-2003 08:19 PM
Help-(Total Newbie) Dependency Problems thcmwz Linux - Software 1 09-01-2003 04:59 PM
Pleae Help to newbie to open port C2H5OH Linux - Networking 5 04-11-2003 02:25 PM


All times are GMT -5. The time now is 12:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration