LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   to switch from X window to console: (http://www.linuxquestions.org/questions/linux-general-1/to-switch-from-x-window-to-console-141688/)

go_sooner 02-03-2004 02:31 AM

to switch from X window to console:
 
Objective: to switch from X window to console window.

Problem in brief:
1) directly boots to X window.
2) tried to edit the default 5 to 3 in /etc/inittab and run telinit 3, and reboot. No success.
3) tried to use Ctrl+Backspace. gives me a blank or black screen.
4) Ctrl+Alt+F1 gives the same, the screen goes blank. I pressed again Ctrl+Alt+F1 just to check, no success.

Problem in detail:
I had an intel 845G chipset that doesnt work well with the xfree864.0 that came with the stable version of debian 3.0 r2. Initially X doesnt start, gave some error while booting.

But then after several tries I somehow figured out that it works for 8 bits color. (I use a monitor 19" Silicon Graphics, 30-82 KHz (H), 50-150 Hz (V), running 1024 x 768 pixels at 16 bits for windows 2000). Only problem working with the 8 bits was after you had quit to console window, you cannot come back, you got to reboot. Also if you use Ctrl+backspace, the screen will go black and you have to use Ctrl+Alt+F1 to comeback to console window. (you can read directly the 4th point now, if you feel i am doing right.)

After reading reviews about fixing intel related problems, I was required to update the kernel to atleast 2.4.11 or later, and xfree86 to 4.2 or later. So I updated both of them. Things I did when I updated kernel were

1) I used apt-get to update packages with sources.list containing one of the backports.

2) specified kernel-source-2.4.24-1-k7 i686, and got *.tar.bz2 in /etc/src folder, and then used bunzip to extract them , and then configured them using make menuconfig, and then make dep.

3) Then I rebooted (directly went to X window) and checked the version I am running, using uname -r, got 2.4.24 and everything was fine.

4) The usual keys Ctrl+Alt+F1 gives me a blank screen and nothing seems to come after.

5) I tried Ctrl+backspace, Ctrl+Alt+F1, Alt+F1, combinations. Also I edited the /etc/inittab default option from 5 to 3. no success.

6) Ctrl+Alt+ (+ or _) when inside the X window works good.

I need some help from you guys, to set this thing right. I want to get back to console window somehow after starting so I can follow the guidelines given by Intel to make my X window work better.

Thanks.
Sooner.

ascheepe 02-03-2004 07:14 AM

You can try several things to keep xdm from starting at boot, like removing it.
If it gets installed as some dependancy I usaullay don't bother and do a
'chmod a-x /etc/init.d/xdm' so that at the next reboot xdm will not start.

This should leave you with a framebuffer console, if that stays black you might try to build a kernel without framebuffer console but 80x25 text instead.
(or adjust the framebuffer video mode to a lower resolution)

From here on you can try to configure XFree for your card/chipset.

Good luck!

go_sooner 02-03-2004 09:36 AM

Yep, I did more or less the same thing you suggested. I reduced my video resolution by Shift+Alt+(-), then do Ctrl+Alt+F1. It worked fine.

But to my bad luck, I could only find that the intel driver support for the 845G chipsets were provided only for specific distributions like redhat several versions and SuSe several versions. No other distribution were supported for X window.

Thanks.


All times are GMT -5. The time now is 08:33 AM.