LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-13-2004, 02:03 PM   #1
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Rep: Reputation: 30
timezone problem


I'm having trouble setting the time properly. The displayed clock is correct, but the timezones seem off. This means that all email I get is displayed as having arrived at strange times, and if I tell my clock to display another city's time, it gives me a wrong time, even if the city I chose is in my timezone. Example: I'm in Toronto, and it is the same time in Toronto as in Thunder Bay and New York. But if I select those timezones, I get a weird time (it is 3:04 on my clock, but for New York and Thunder Bay, the time is 11:04). Also, it keeps defaulting to the UTC timezone. What the heck is that? I'm in EDT, but it doesn't seem to save that setting...even on the command line it says UTC.
I'm not sure why it is doing this. I'm running slackware 10.0, with KDE 3.2.3, and using KDE to set the clock.
 
Old 09-13-2004, 02:18 PM   #2
dannybpng
Member
 
Registered: Sep 2003
Location: USA
Distribution: Fedora 20
Posts: 60

Rep: Reputation: 19
Under the menu:

System Settings / Date & Time
pick the Time Zone tab
the "System clock uses UTC" setting should NOT be checked unless you set your computer BIOS clock to UTC time.

Try changing that and see what happens

Dan
 
Old 09-13-2004, 03:19 PM   #3
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Original Poster
Rep: Reputation: 30
UTC is not a check-option. I can't uncheck it. I can change it by changing the timezone, but then I exit, and restart the Control Centre, and I'm back in UTC!

[edit] Yes I'm doing this in Administrator mode.
 
Old 09-13-2004, 03:31 PM   #4
fphillips
Member
 
Registered: Sep 2004
Location: KS
Distribution: Slack 10-current
Posts: 87

Rep: Reputation: 15
slack has a timeconfig/tzconfig(?) command, or I do:
take the output from date, edit it as you want, insert
date -s '<insert string here>'
you can use hwclock to sync it up if needed to the...hardware clock. see man hwclock
 
Old 09-13-2004, 10:10 PM   #5
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Original Poster
Rep: Reputation: 30
I used tzconfig, and now it thinks it's 3 in the afternoon! It's 11 at night and I have to selecet the New York timezone for it to display the correct time. and when I run `date`, I still get the time in UTC. I just want the UTC to go away!
 
Old 09-13-2004, 10:38 PM   #6
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Original Poster
Rep: Reputation: 30
seems to be fixed. All I had to do was logout and then log back in...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
timezone problem Mathsniper Linux - Newbie 9 06-08-2005 12:55 PM
Evolution 2 / Multisync / WinCE Timezone problem on sync david.skinner Linux - Software 0 04-29-2005 09:58 PM
Timezone funny problem. ]un]ie Solaris / OpenSolaris 10 07-21-2004 10:08 PM
How do I get rid of UTC (timezone problem) Baldrick65 Mandriva 2 10-02-2003 07:48 AM
Timezone Again rch LQ Suggestions & Feedback 5 05-19-2003 11:49 PM


All times are GMT -5. The time now is 03:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration