LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-18-2007, 05:49 AM   #1
shankara
LQ Newbie
 
Registered: Jan 2006
Posts: 17

Rep: Reputation: 0
time zone setup


When i set up my time zone which files will get affected to reflect the time zone effect....

I have selected the timezone "Los_angeles" when I executed the date command it was showing me March Fri .... PST instead of PDT..

But if I set the date to 040110102007 (i.e, to April) and executed the date command then it is showing me as PDT.

Can u please show me light in this.

Thanks in advance.
 
Old 03-18-2007, 06:32 AM   #2
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,008
Blog Entries: 5

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
Wow - a little late. Time change in US was last weekend (March 11th).

You can learn more than you ever wanted to know about DST at the following thread:
http://www.linuxquestions.org/questi...d.php?t=518752
 
Old 03-18-2007, 08:45 AM   #3
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Moved: This thread is more suitable in Linux General and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 03-19-2007, 11:43 PM   #4
shankara
LQ Newbie
 
Registered: Jan 2006
Posts: 17

Original Poster
Rep: Reputation: 0
Time zone

Hi Guys,

I know that America has moved to PDT (DST) on March 11th. The problem is when I executed date command on March 15th the result is showing me still PST insted of PDT. So I manually set the date to first of April then its showing me PDT why this weird behavior.

I intentionally wanted to test for DST but it is not updating properly. The kernel was built by follwoing LFS..

Can any one tell me abt the problem.

If u need still more information let me know


Thanks in advance.
 
Old 03-20-2007, 10:44 AM   #5
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,008
Blog Entries: 5

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
America changed its DST schedule. Not all of a America is in the Pacific time zone though. We have Eastern, Central, Mountain and Pacific (within the contiguous 48 - Hawaii and Alaska have others).

If it is supposed to be in Pacific as indicated by your seeing either PST or PDT then the above doesn't matter - just wanted to make sure you understood that. California is in Pacific time zone.

Having said all that I'd again refer you to the thread link I posted above. It will tell you all you need to know.
Summarized it basically will tell you:
1) Update the timezone files in /usr/share/zoneinfo (either by using downloading the zoneinfo files tar and using zic to compile OR by using update provided for your distro if it exists).
2) Copy or link the newly compiled zoneinfo file to /etc/localtime.
3) Run zdump -v /etc/localtime |grep 2007 to insure it shows the correct dates for time change in 2007.

In your case you'd want either PST8PDT or America/Los_Angeles from /usr/share/zoneinfo.
 
Old 04-13-2007, 05:06 AM   #6
shankara
LQ Newbie
 
Registered: Jan 2006
Posts: 17

Original Poster
Rep: Reputation: 0
Detecting type of scsi disk

Hi guys,

I want to detect a raw SCSI DISK during installation. To detect scsi I have set the flags while
in kernel configuration file to "Y/y" to embbed the scsi modules into the kernel.

Example : for IDE disk in proc we ll have /proc/ide/ide0/hda or /proc/ide/ide1/hdc. In these
directory there is a file called "media" which tells the type of the device either disk
or cdrom.

I am trying to figure out samething in case of SCSI devices .... didnt get any help

help me if any one knows abt this.

Thanks in advance
 
Old 04-13-2007, 08:53 AM   #7
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,008
Blog Entries: 5

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
You should start a new thread rather than appending to an old thread that has nothing to do with the question you asked.

This will help insure people see it. Usually the only people that see old threads like this are the people who subscribed to it. For new threads people will see it when they look at "zero reply threads".
 
  


Reply

Tags
dst


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot set time/date to other time zone than UTC (Kubuntu) jamangold Ubuntu 1 12-23-2005 05:42 PM
Time Zone cherukuri_sr Linux - Newbie 2 02-02-2005 11:20 AM
Display the date and time from another time zone lothario Linux - Software 4 07-31-2004 03:27 PM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 03:25 PM
time zone exigent Linux - General 4 09-17-2002 03:41 PM


All times are GMT -5. The time now is 06:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration