LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Time stamp in Samba is 11 hours behind time stamp in Linux (http://www.linuxquestions.org/questions/linux-general-1/time-stamp-in-samba-is-11-hours-behind-time-stamp-in-linux-88902/)

Linh 09-03-2003 02:24 PM

Time stamp in Samba is 11 hours behind time stamp in Linux
 
Time stamp in Samba is 11 hours behind time stamp in Linux

on Windows 2000 workstation, the time is 12:00PM, 9-3-2003
on Linux workstation, the time is 12:00PM, 9-3-2003
using Samba Version 2.2.8a in the Linux computer

I mapped a Samba drive from a Windows 2000 workstation to a Linux
computer. Next, I created a folder named New_Folder. the date created on this
folder indicates 9/3/2003 1:00AM

When I went in to the Linux command line and looked at the New_Folder directory
using the command "ls -al", the date created indicates 9/3/2003 12:00PM

drwxrwx--- 2 admin engineer 4096 Sep 3 12:00 New_Folder
==================================

The date of when the New_Folder directory was in Samba is 11 hours earlier
than the one in the Linux computer using "ls -al" command.

9-3-2003
12:00AM
1:00 AM --> Samba time displayed
2:00 AM
3:00 AM
4:00 AM
5:00 AM
6:00 AM
7:00 AM
8:00 AM
9:00 AM
10:00 AM
11:00 AM
12:00 PM --> Linux time display

Other users also confirmed to me this bug in Samba 2.2.8a.

======================================

Is there anyway to fix this bug so that the date and time of when the
files and folders in Samba is created is the same as that showed in Linux
when use the command line "ls -al" ?

I figure that if there is a way to fix it, you would have to change
certain parameter in /etc/samba/smb.conf. If this is the case, then which one ?

david_ross 09-03-2003 02:33 PM

Take a look at this variable:
time offset

For more details:
man smb.conf

Linh 09-03-2003 03:04 PM

Reply to David_Ross
 
Hi David_Ross and thank you for your help.

Both the win2K workstattion and the Linux computer time zone
are set as Central Time USA, and both are set for enable "daylight saving times"

I used the time offset = 780 in smb.conf and when I created a new file/folder in Samba, the time matched that of the Linux computer. 780 is 780 minutes.
780 / 60 = 13 hours

I have to offset Samba by 13 hours so that the Samba time would be the same as that in Linux. The fact is the Samba time is only 11 hours earlier than Linux. Any ideas why I have to offset it by 13 hours to get it to offset by 11 hours ?

david_ross 09-04-2003 12:44 PM

It could be that your harware clock is set to a different time but I'm not sure.


All times are GMT -5. The time now is 01:28 AM.