LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 04-27-2003, 09:23 PM   #1
itsjustme
Senior Member
 
Registered: Mar 2003
Location: Earth
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 1,571

Rep: Reputation: 45
Time resets magically....


Ok, I'm having touble with my clock losing 5 hours during the boot process. Here's what I see in:
/var/log/messages:
.
>>>>Here's the reboot. Before it booted back up I checked BIOS and the time was still correct, 18:45, however, after reboot I lost 5 hours, 18:45 to 13:45.
.
Apr 27 18:45:06 localhost kernel: Kernel logging (proc) stopped.
Apr 27 18:45:06 localhost kernel: Kernel log daemon terminating.
Apr 27 18:45:07 localhost syslog: klogd shutdown succeeded
Apr 27 18:45:07 localhost exiting on signal 15
Apr 27 13:47:06 localhost syslogd 1.4.1: restart.
Apr 27 13:47:06 localhost syslog: syslogd startup succeeded
.
....then the time magically changes back to the correct time here after autofs, maybe in rc.sysinit
Apr 27 13:47:07 localhost kernel: eth0: Setting full-duplex based on MII#1 link partner capability of 45e1.
Apr 27 13:47:07 localhost autofs: automount startup succeeded
Apr 27 18:46:34 localhost rc.sysinit: Mounting proc filesystem: succeeded
Apr 27 18:46:34 localhost rc.sysinit: Unmounting initrd: succeeded
Apr 27 18:46:34 localhost sysctl: net.ipv4.ip_forward = 0
Apr 27 18:46:34 localhost sysctl: net.ipv4.conf.default.rp_filter = 1
Apr 27 18:46:34 localhost sysctl: kernel.sysrq = 0
Apr 27 18:46:34 localhost sysctl: kernel.core_uses_pid = 1
Apr 27 18:46:34 localhost rc.sysinit: Configuring kernel parameters: succeeded
Apr 27 18:46:34 localhost date: Sun Apr 27 18:46:32 UTC 2003
Apr 27 18:46:34 localhost rc.sysinit: Setting clock : Sun Apr 27 18:46:32 UTC 2003 succeeded
Apr 27 18:46:34 localhost rc.sysinit: Loading default keymap succeeded
.
....then a few lines later, apparently in rc.sysinit, the 5 hours get's lopped off again...
Apr 27 18:46:41 localhost fsck: /usr/local: clean, 1715/513024 files, 247948/1024135 blocks
Apr 27 18:46:41 localhost fsck: /var: clean, 5772/384000 files, 73446/767095 blocks
Apr 27 18:46:41 localhost rc.sysinit: Checking filesystems succeeded
Apr 27 13:46:41 localhost rc.sysinit: Mounting local filesystems: succeeded
Apr 27 13:46:41 localhost rc.sysinit: Enabling local filesystem quotas: succeeded
Apr 27 13:46:42 localhost rc.sysinit: Enabling swap space: succeeded
Apr 27 13:46:44 localhost init: Entering runlevel: 5

I looked in rc.sysinit, but don't really know what I'm looking for in there.
There are several instances of 'time' and 'clock' in there.

Also, I am still getting the weird phenomenon where pressing the OK button after running redhat-config-date causes the screensaver to start up. Also, after running redhat-config-date, I see this:

Apr 27 13:52:19 localhost su(pam_unix)[1097]: session opened for user root by (uid=500)
Apr 27 14:05:30 localhost userhelper: pam_timestamp: timestamp file `/var/run/sudo/bsl1/unknown:root' is too old,
disallowing access to redhat-config-date for UID 500
Apr 27 14:05:44 localhost ntpd: ntpd shutdown failed
Apr 27 19:15:15 localhost kernel: eth0: Setting full-duplex based on MII#1 link partner capability of 45e1.

I'm not running ntpd. And, the time DOES change.

And, whether I select to use UTC or not I get the same result and if I select to use UTC, when I reboot and come back in, the UTC selection is no longer selected.

Any ides what's going on here?

Thanks.
 
Old 04-27-2003, 09:54 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,593

Rep: Reputation: 188Reputation: 188
Switching to local time

As a guess, you might try editing the file:
/etc/sysconfig/clock

Set:
UTC=false
 
Old 04-27-2003, 10:10 PM   #3
itsjustme
Senior Member
 
Registered: Mar 2003
Location: Earth
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 1,571

Original Poster
Rep: Reputation: 45
Ok, I tried that, but it had no effect. I get the same weird time changes.

[root@localhost root]# cd /etc/sysconfig
[root@localhost sysconfig]# cat clock
ZONE="America/Chicago"
UTC=0
ARC=0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xfce perplexity ;) (magically disappears?!?!) itsjustme Slackware 2 04-24-2005 05:17 AM
redhat 9.0 randomly resets time rioguia Linux - Newbie 2 09-21-2004 01:55 PM
My mouse just magically stopped working... Nikon01 Slackware 11 09-12-2004 08:39 PM
Help: Directories magically chgrp and chown by themselves! Blazer79 Mandriva 2 09-07-2004 12:52 PM
magically vanishing downloads!? tyccea Linux - General 4 10-24-2003 10:14 AM


All times are GMT -5. The time now is 07:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration