LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-14-2010, 01:58 AM   #1
Suppen
Member
 
Registered: Mar 2009
Distribution: Ubuntu, Linux Mint
Posts: 35

Rep: Reputation: 17
The shutdown-command doesnt work properly


When i use the shutdown-command in the terminal as root, it nearly works. It starts to shut down, and it looks like all programs and the kernels shuts down. I end up with a black screen, sometimes with the ubuntu-logo on, but it never powers off. I have to force it off by holding the power button. When i use the graphical interface to shut it down, it works perfectly. The poweroff-command works without problem too.

Here is the command i use:
Code:
$ sudo shutdown <time>
OS is Ubuntu 9.10 64-bit
 
Old 01-14-2010, 02:24 AM   #2
neonsignal
Senior Member
 
Registered: Jan 2005
Location: Melbourne, Australia
Distribution: Debian Wheezy (Fluxbox WM)
Posts: 1,363
Blog Entries: 52

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Shutdown defaults to dropping down to runlevel 1. To force a proper halt, you need to use the '-h' flag:
Code:
shutdown -h 0
 
Old 01-14-2010, 02:34 AM   #3
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,219

Rep: Reputation: 131Reputation: 131
see this
http://www.cyberciti.biz/faq/shutdow...inux-computer/
 
Old 01-14-2010, 06:14 AM   #4
devnull10
Member
 
Registered: Jan 2010
Location: Lancashire
Distribution: Slackware Stable
Posts: 547

Rep: Reputation: 115Reputation: 115
Try sudo poweroff
 
Old 01-14-2010, 08:52 AM   #5
Suppen
Member
 
Registered: Mar 2009
Distribution: Ubuntu, Linux Mint
Posts: 35

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by neonsignal View Post
Shutdown defaults to dropping down to runlevel 1. To force a proper halt, you need to use the '-h' flag:
Code:
shutdown -h 0
Thanks. That did it. I am used to the Windows shutdown-command, which takes it all the way. Problem solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
my iptables command doesnt work rohit83.ken Linux - Networking 1 04-01-2008 06:24 AM
KDE and mousewheel. Doesnt work properly kc0eks Linux - Hardware 1 04-03-2007 03:46 PM
CP command doesn't work properly? itz2000 Linux - Newbie 1 08-02-2005 01:14 PM
Transparencies doesnt work properly Slackware 10.1 + fluxbox Nah Slackware 5 03-06-2005 07:19 PM
Updated Firmware of Wireless card, now doesnt work properly? kromatic Linux - Hardware 1 02-18-2005 01:36 PM


All times are GMT -5. The time now is 01:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration