Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 06-23-2005, 04:42 AM   #1
Registered: Apr 2005
Distribution: Red Hat / Fedora / CentOS
Posts: 508

Rep: Reputation: 30
Takes ages to connect to smtp

I realise that after i setup my new mail server... my clients are taking a while to connect to the SMTP (Send/Receive in Outlook), it will take quite a while, but still send out...

any possible reasons for this? Anyway to shorten this "delay"?

Please advise
Old 06-23-2005, 06:22 AM   #2
Registered: Jun 2005
Location: Canada
Distribution: Debian Etch/Sid, Ubuntu
Posts: 529

Rep: Reputation: 32
Could it be that your smtp server looks for ident?
I remember having this problem a long time ago, and I think that disabling ident is what solved it.

Last edited by stefan_nicolau; 06-23-2005 at 06:23 AM.
Old 08-18-2005, 02:40 AM   #3
Registered: Apr 2005
Distribution: Red Hat / Fedora / CentOS
Posts: 508

Original Poster
Rep: Reputation: 30
I read the article (woah) and find it quite heavy, but nevertheless it worked, after doing some googling on PLESK (oh yah, my email server is running plesk control panel)

with regards to this, have some questions

1) If I am just using the regular sendmail in RHEL, how do I adjust the ident? Can't find it

2) I think plesk is using qmail, added the extension -Rt0 in the /etc/xinted.d/smtp_psa
What doess -Rt0 do? I just follow the forum (in the given URL) instructions...

3) xinted, what does this do?

updated: guys, I also found out that it could be due to reverse dns..
From plesk FAQ
Check to make sure that the name servers that are used for reverse resolution have not been shut down or are working properly. These name servers are specified within the /etc/resolv.conf file and can be replaced if need be.

It's also very possible that the name servers in the /etc/resolv.conf file are working fine but the ip from where the client is accessing the server is not reverse resolvable. In this case you could turn off the reverse lookup completely.
- my email server is also my primary DNS server. in resolv.conf, nameserver is pointing to correct? does it has anything to do with this reverse resolution? What is reverse resolution meaning?

- do I need to point to the secondary one too?

Many wonderful thanks to you guys
LQ Make my life so much better hehehe

Last edited by Swakoo; 08-18-2005 at 03:35 AM.
Old 08-23-2005, 04:32 AM   #4
Registered: Apr 2005
Distribution: Red Hat / Fedora / CentOS
Posts: 508

Original Poster
Rep: Reputation: 30
guys... headache!!

with the -Rt0 it works.. faster..

but mails get stuck in remote queue after a while.. it doesn't move out!!!


I am using Plesk control panel which uses qmail... :S

I edit the file in /etc/xinted.d/smtp_psa

by adding Rt0 to server_args



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting takes ages! Steave Linux - General 3 02-23-2006 07:39 AM
Configuring network interfaces..takes AGES! coolblue Linux - Newbie 6 07-20-2005 08:33 AM
X takes ages and ages to load! dcdbutler Slackware 9 03-23-2005 08:53 AM
'Whatever' login takes ages... Worstje Slackware 7 10-15-2004 04:06 PM
Webpages/Email takes ages to load after period of inactivity Robstro Linux - Networking 1 05-26-2004 02:31 AM

All times are GMT -5. The time now is 03:38 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration