LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Systray-only XMMS in KDE3.3--Here's how to do it! (http://www.linuxquestions.org/questions/linux-general-1/systray-only-xmms-in-kde3-3-heres-how-to-do-it-235936/)

David the H. 09-27-2004 06:31 PM

Systray-only XMMS in KDE3.3--Here's how to do it!
 
I've wanted to have XMMS run as a notification area (system-tray) only application since I first tried it out, but as most of you probably know, that wasn't possible. Until now, that is. I've discovered that KDE 3.3 makes it quite easy to have XMMS (or any other app for that matter) hidden from the task bar. Then, with the status docklet plugin, you can access it from the system tray only. I know I'm not the only one who wanted this, so I'm going to tell you all how to do it.

First, start up XMMS normally. Configure the status docklet plugin the way you like. I suggest setting one button as a "toggle all windows" button so that you can easily pop the main window on and off once the task bar button is gone. Make sure it displays normally in your system tray. You might also want to toggle the "always on top" setting as well to keep it from being hidden by other windows when you pop it up.

Next, open up the KDE control panel and switch to the Desktop tab. There you'll find an entry for "Window-Specific Settings". That's what we want. Create a new entry and click on the "detect" button on the first tab that comes up. Your pointer will turn into a crosshair. Now click on the XMMS window. An information window will pop up. Make sure "Use window class (whole application)" is selected and hit ok. The window info will be entered into the settings.

We're almost done. Switch to the "Preferences" tab and enable the entry for "skip taskbar". In the dropdown next to it select "Apply Initially" and checkmark the box on the right. Now simply save your settings and restart XMMS. It should launch without appearing in the task bar, but you'll still be able to pop it up through the docklet plugin. Enjoy!

BTW, remember that this is for KDE 3.3 only. But for those using older versions or for Gnome users there is something you can use to get almost the same effect. There's a small applet called KDocker that will force apps into the notification area. You'll probably have to compile it from source, but that's not too hard. Then you can simply run "kdocker xmms" and XMMS will be reduced to a tray icon. It's not quite as good as it will only toggle the main window on and off and doesn't have any menu controls, but you can use the docklet plugin next to it if you want that kind of control. The main thing is, it's off of your task bar.

RoaCh Of DisCor 10-16-2004 07:59 PM

I found this useful. Thanks :)

pickarooney 11-04-2004 08:29 AM

That's excellent, thanks for the detailed, clear guide :)
It's normal that the minimise button has no effect now, right?

Actually, I can't call the window up by (double-)clicking on the sustray icon or alt-tabbing it. I think I've done something wrong...

David the H. 11-19-2004 01:05 PM

Well, I see somebody found my old thread! :)

I'm glad I could help out. Just to answer, yes, I found that my minimize button doesn't work either. I have no idea why. I don't have any trouble toggling it from the tray icon though. Double-check your tray docklet settings.

I do get one bug that annoys me though. I like keeping the playlist window open. Sometimes when I call the program up from the tray, the playlist window appears overlapped over the main control window. I haven't been able to figure out just when or why it does it, but once it does, it will keep doing it until you kill and restart the program. It's annoying, but not that serious, I think.

pickarooney 11-19-2004 03:18 PM

What version of xmms are you running? I found that version 1.2.8 and 1.2.9 had a few bugs with docking/minimising/maximising the playlist and equaliser window. 1.2.1 fixed it.

esteeven 12-12-2004 05:27 PM

Wonderful. I came across this thread by chance and I now have something that I didn't know I wanted. :)
My weekend ends well!!!!
Thanks

pickarooney 04-27-2005 01:56 PM

Just wondering, does anyone know how to disable this feature? I installed xmms-kde which has basicaly the same function, but I can't get rid of the systray icon for XMMS now. I deleted the entry for xmms in Window-specific settings but it still pops up the systray icon when I run xmms. Is this somewher in my kde settings or xmms or... ?


All times are GMT -5. The time now is 06:45 AM.