LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-16-2004, 02:52 PM   #1
Xris718
Member
 
Registered: May 2003
Location: NYC
Distribution: CentOS
Posts: 261

Rep: Reputation: 30
Angry system FONTS are gone!!!!!!


Hey guys

I have seriouse problem with my linux box. I was configuring mozilla for different plugins. Hence I needed to install different applications to support these pluggins.

Stuff I installed (using tar):

gtk+-2.2.2
glib-2.2.2
pango-1.2.2
jpeg-6b
tiff-v3.5.7
atk-1.2.4

So Everything worked fine i installed all these packages got mozilla to work with plugins then i rebooted my machine and BANG!! .... Upon the logon screen I see no fonts whatsoever i type my user name and password cant see the fonts. So i blindly login and now i cant see fonts that were in my menu icons and desktop icons dont have any fonts under them either.

Only fonts i CAN see is inside a terminal i can see what i type and in mozilla.

My question how can i restore my system fonts? Because my system is like crippled now.

Need HELP. Thanks in advance
 
Old 02-16-2004, 03:03 PM   #2
exodist
Senior Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: Gentoo
Posts: 1,372

Rep: Reputation: 46
Wow... Thats scary, I have no idea how to help, but I am very intereted in finding a way. I will see if I can find anything on this anywhere else, have you tied googling it?
 
Old 02-16-2004, 03:11 PM   #3
Xris718
Member
 
Registered: May 2003
Location: NYC
Distribution: CentOS
Posts: 261

Original Poster
Rep: Reputation: 30
OH yeah i tried googling it but no luck. Hopefully someone here can help me out. I tell ya its like working in a dark room with no fonts. This sucks. I also tried restarting xfs no luck in resolving this problem. I also did:

# chkfontpath --list
Current directories in font path:
1: /usr/X11R6/lib/X11/fonts/misc:unscaled
2: /usr/X11R6/lib/X11/fonts/75dpi:unscaled
3: /usr/X11R6/lib/X11/fonts/100dpi:unscaled
4: /usr/X11R6/lib/X11/fonts/misc
5: /usr/X11R6/lib/X11/fonts/Type1
6: /usr/X11R6/lib/X11/fonts/Speedo
7: /usr/X11R6/lib/X11/fonts/cyrillic
8: /usr/X11R6/lib/X11/fonts/TTF
9: /usr/share/fonts/default/Type1
10:
11: /usr/lib/openoffice/share/fonts/truetype

Maybe the problem is with item '10' theres no path there im not sure. But the problem is still active.
 
Old 03-28-2004, 07:54 PM   #4
skog
Member
 
Registered: Sep 2003
Location: TX
Distribution: slackware
Posts: 301

Rep: Reputation: 30
my chkfontpath --list shows the exact same info ...

get to a terminal and try fc-cache and fc-list
 
Old 04-06-2004, 12:14 PM   #5
JesusFreak
LQ Newbie
 
Registered: Apr 2004
Location: Germany - NRW - Minden
Distribution: Debian Sid
Posts: 7

Rep: Reputation: 0
i have the same problem:


Please someone tell me when you got a solution...
 
Old 04-06-2004, 04:51 PM   #6
JesusFreak
LQ Newbie
 
Registered: Apr 2004
Location: Germany - NRW - Minden
Distribution: Debian Sid
Posts: 7

Rep: Reputation: 0
I've just installed amsn, now I wanted to start it (as root, stupid... anyway: ) and got that error:

[root@Wohnzimmer jonas]# amsn
TkpGetFontFromAttributes: cannot get any font

Perhaps it's useful for some of you and you know now how to fix everything? I hope so... ;-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
system fonts phsythax Linux - General 5 11-17-2005 11:40 AM
System fonts unreadable; SUSE 10 benighted Suse/Novell 3 11-14-2005 02:46 PM
Installing new fonts in my Slack system Shagrath239 Slackware 11 02-18-2005 10:17 AM
Arrrrrgh! I have messed up my system fonts njschroe Linux - General 0 02-01-2005 12:01 PM
help with wine system fonts please jaybee Linux - Software 0 08-05-2003 02:54 PM


All times are GMT -5. The time now is 12:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration