LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   symlinks not working right (http://www.linuxquestions.org/questions/linux-general-1/symlinks-not-working-right-28261/)

sidhighwind 08-19-2002 12:31 PM

symlinks not working right
 
all of my symlinks on my RedHat 7.1 system are comming up as orphaned/missing links. I know that they are fine because this still work it is just kind of a pain in the butt to look at the broken links when the flash in my terminal window.

I am wondering if anyone know how to fix this problem.

Thanks in advance

Jon.

neo77777 08-19-2002 12:42 PM

How it would work if it is broken? How do you create them?

sidhighwind 08-19-2002 12:54 PM

well considering it is in the etc filder.


aka
RooT :: [/etc]> cd /etc
RooT :: [/etc]> ls -las rc*
0 lrwxrwxrwx 1 root root 13 Jan 4 2002 rc.local -> rc.d/rc.local
0 lrwxrwxrwx 1 root root 15 Jan 4 2002 rc.sysinit -> rc.d/rc.sysinit
0 lrwxrwxrwx 1 root root 10 Jan 4 2002 rc0.d -> rc.d/rc0.d
0 lrwxrwxrwx 1 root root 10 Jan 4 2002 rc1.d -> rc.d/rc1.d
0 lrwxrwxrwx 1 root root 10 Jan 4 2002 rc2.d -> rc.d/rc2.d
0 lrwxrwxrwx 1 root root 10 Jan 4 2002 rc3.d -> rc.d/rc3.d
0 lrwxrwxrwx 1 root root 10 Jan 4 2002 rc4.d -> rc.d/rc4.d
0 lrwxrwxrwx 1 root root 10 Jan 4 2002 rc5.d -> rc.d/rc5.d
0 lrwxrwxrwx 1 root root 10 Jan 4 2002 rc6.d -> rc.d/rc6.d

RooT :: [/etc]> cd rc.d
RooT :: [/etc/rc.d]> ls
init.d rc.sysinit rc1.d rc4.d
rc rc.sysinit.rpmsave rc2.d rc5.d
rc.local rc0.d rc3.d rc6.d
RooT :: [/etc/rc.d]>


as you can see the all of the rc fodler exists but when i do the ls i get the broken links
http://www.sweetwater.com/terminal.jpg

Half_Elf 08-19-2002 02:53 PM

I like your terminal it's just like the matrix, but with a LQ background :P

about your symlink, try to include the complete path when you create them, maybe it can fix that bug. Example, instead of "ln -s rc.d/rc.local rc.local , try :
ln -s /etc/rc.d/rc.local rc.local

hope it will works

sidhighwind 08-20-2002 12:16 PM

Ya that is the way i make then. but the ones i display are the ones that redhat made when it installed the system. they dont really bother me now that i have turned off the blinking and thet box around the text.

techsearch 01-23-2004 12:34 AM

symlinks flashing in RH-7.2
 
hi friends ,
I found the same problem what sighhigh posted,can anyone help me get out of this.


All times are GMT -5. The time now is 11:57 PM.