LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 08-05-2004, 12:25 PM   #1
Doug.Gentry
Member
 
Registered: Aug 2003
Location: Enumclaw, Washingtion. USA
Distribution: Suse 9.2, Fedora 3, wifes XP
Posts: 143

Rep: Reputation: 15
switch from KDE to Gnome?


I'm using Suse 9.1 and the KDE desktop. I know when I installed this I said all of KDE and I believe I also said gnome also.

How does one switch from one to the other and then back again?

Or is switching back and forth a hassle?

If it is a hassle how do I go about deleting the gnome stuff?
 
Old 08-05-2004, 12:30 PM   #2
max_sipos
Member
 
Registered: Jul 2004
Posts: 96

Rep: Reputation: 15
On my system (slackware), just type xwmconfig and it will change the default desktop environment. I think you can also edit .xinitrc or something of the sort.

Changing a desktop environment is not such a big deal in Linux, you'll probably just spend some time customizing gnome to your needs (in Gnome it's very easy)..
 
Old 08-05-2004, 12:56 PM   #3
Doug.Gentry
Member
 
Registered: Aug 2003
Location: Enumclaw, Washingtion. USA
Distribution: Suse 9.2, Fedora 3, wifes XP
Posts: 143

Original Poster
Rep: Reputation: 15
xwmconfig doesn't do it with suse 9.1

Yeah it seems to me in 8.1 or maybe even 9.0 there was something you could select and switch from one to the other.

I know it's right here in front of me somewhere.

thanks for the help tho.
 
Old 08-05-2004, 03:38 PM   #4
atmckd
LQ Newbie
 
Registered: Jun 2004
Location: Santa Barbara,CA
Distribution: SuSE Linux 9.1
Posts: 14

Rep: Reputation: 0
Just log out and click the sessions button at the login screen and select gnome, then log in.
 
Old 08-05-2004, 04:24 PM   #5
Doug.Gentry
Member
 
Registered: Aug 2003
Location: Enumclaw, Washingtion. USA
Distribution: Suse 9.2, Fedora 3, wifes XP
Posts: 143

Original Poster
Rep: Reputation: 15
??

When I log out... and it comes back in there is no screen, It just opens up, I don't have to put in a username or anything. I can close session and log in as root tho.
 
Old 08-05-2004, 04:40 PM   #6
atmckd
LQ Newbie
 
Registered: Jun 2004
Location: Santa Barbara,CA
Distribution: SuSE Linux 9.1
Posts: 14

Rep: Reputation: 0
Ok. Go to the KDE control center and search for the login manager and make sure that automatic login is disabled. Might work even though logging out shold give you the login screen.
 
Old 08-05-2004, 04:51 PM   #7
darin3200
Guru
 
Registered: Dec 2002
Distribution: Gentoo!
Posts: 1,153

Rep: Reputation: 45
You can also create a file called .xinitrc in you /home/username directory and then put in
Code:
exec gnome-session
To run gnome or for kde
Code:
startkde
or
Code:
exec kde

Last edited by darin3200; 08-05-2004 at 04:52 PM.
 
Old 08-10-2004, 05:29 PM   #8
kubro
LQ Newbie
 
Registered: Jul 2004
Location: Idaho
Distribution: Suse 9.1
Posts: 9

Rep: Reputation: 0
changing from KDE to Gnome

I don't know "what" I'm doing wrong, but I "STILL" am unable to switch to Gnome! I've tried al of the above, and double and re double checked to insure I was doing it correctly. I've searched Suse database, and can find no instructions or help on this issue. Can anyone PLEASE point me in the right direction. I just want to be able to load Gnome! How do I do it?
 
Old 08-10-2004, 05:41 PM   #9
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Rep: Reputation: 15
I am using Fedora Core 2. The way I changed mine was opening up /etc/sysconfig/desktop as root and changing DESKTOP="GNOME" to DESKTOP="qwe" where qwe is either GNOME, KDE, WINDOWMAKER, or ICEWM. (They have to be in caps).
OR
You can just change /etc/X11/xinit/Xclients so it always opens either gnome or kde always.

These methods are a little more complicated but it will change the window manager default system-wide.
 
Old 08-10-2004, 06:18 PM   #10
Fartwiz
Member
 
Registered: May 2004
Location: Wiltshire UK
Distribution: SuSE 9.2 AMD64
Posts: 50

Rep: Reputation: 15
In KDE Control centre > System Administration > Login Manager.
Make sure you click the "Administrator Mode" Button at the bottom of the window.
Enter your root password in the box that appears.
Click the "Convenience" tab at the top.
Make sure that the "Auto Login" box isn't checked, also the "Autologin after XServer crash" box.
Hit "Apply" and log out.
you SHOULD see the KDM login screen. If you don't then im not sure what the problem is.
If you do , then click on the session button and choose Gnome.
If you don't see KDM, you could try changing your login manager to GDM, but thats a bit fiddly.
If you want to just check that Gnome is at least working, you could open a terminal, type "su" (without the quotes) and enter your root password. Then type "init 3" (again without quotes) this will take you to text mode.
Login, and type "startx gnome" (once more without the quotes)
That should log you into Gnome
Good Luck.
 
Old 08-10-2004, 06:27 PM   #11
kubro
LQ Newbie
 
Registered: Jul 2004
Location: Idaho
Distribution: Suse 9.1
Posts: 9

Rep: Reputation: 0
I appreciate your reply unfortunately Suse 9.1 doesn't seem to be setup the same. When I went to /etc/sysconfig there is no "desktop" file, however there is a "displaymanager" in which it said you may change the default windowsmanager, so I changed the KDM references to GDM, upon reboot it did change the login screen however still logs into KDE. I had previously changed the .xinitrc file to read "exec gnome-session" for the login I'm using, but to no effect.

Finally when I went to the following directory /etc/X11/ there is no Xclients file only xinitrc and xserverrc, neither of which I care to modify.

I'm stunned that it should be this difficult. Everything else seems so easy in Suse!

Any other ideas?
 
Old 08-10-2004, 06:43 PM   #12
Fartwiz
Member
 
Registered: May 2004
Location: Wiltshire UK
Distribution: SuSE 9.2 AMD64
Posts: 50

Rep: Reputation: 15
Strange,
you could try editing /etc/sysconfig/windowmanager, near the top of the file :-
---------------------------------------------------------------------------------
# Here you can set the default window manager (kde, fvwm, ...)
# changes here require at least a re-login
DEFAULT_WM="kde"
---------------------------------------------------------------------------------
try changing the default to Gnome rather than KDE
I cant guarantee that this will work and i take no responsibility if it messes up your installation... its your choice, im guessing it should be ok.

HOWEVER .....

I would STRONGLY suggest that you try switching to init 3 and doing a startx gnome as i described before, to at least verify that Gnome runs ok and you're happy using it.

i would be interested to know if this resolves your problem.
good luck.
 
Old 08-10-2004, 07:36 PM   #13
kubro
LQ Newbie
 
Registered: Jul 2004
Location: Idaho
Distribution: Suse 9.1
Posts: 9

Rep: Reputation: 0
switching from KDE to Gnome

ok, tried changning to gdm as default in windowsmanager, had no affect after complete reboot.

tried going to control center>sys admin>login manager and insured that auto login and auto login after Xcrash were unchecked, logged out, I did get the KDE login screen as usual but there is no "session" option.

opened terminal as root entered init 3, system went to the initial Suse screen and froze..hit Alt F3 to go to another session, logged on as root entered init 3 , then startx gnome would you believe KDE started up! argh!
 
Old 08-11-2004, 12:47 AM   #14
Fartwiz
Member
 
Registered: May 2004
Location: Wiltshire UK
Distribution: SuSE 9.2 AMD64
Posts: 50

Rep: Reputation: 15
I would check that you actually have Gnome installed then.
If startx gnome is logging you into KDE and there are no session options in KDM, i would suspect that you have no other windowmanagers installed.

KDE Control Centre>Yast Modules>Software>Install & Remove Software

In the filter at the top, choose selections,
make sure that Gnome & Gnome development boxes are checked.
 
Old 08-11-2004, 09:12 AM   #15
kubro
LQ Newbie
 
Registered: Jul 2004
Location: Idaho
Distribution: Suse 9.1
Posts: 9

Rep: Reputation: 0
ok, maybe this is where I've been stupid! at control center>yast>install & remove software, I chose filter "Selections" in the window on the left Gnome is "not" listed. However under filter "Package Groups" System>GUI Gnome is listed, and in the right screen everything is checked except the tamil-gtk2im keyboard layout. Additionally if I use the Search filter and search for Gnome it lists what I assume to be all of the Gnome components.

Also earlier I'd thought I'd confirmed Gnome's installation because Gnome is listed in the /opt directory.

I hope I'm not wasting anyone's time. I am "very" new to this. I apologize in advance.
Thank you all for your patience!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to switch from KDE to Gnome woopud Slackware 2 10-01-2005 10:17 PM
Switch from KDE to Gnome rockytriton Mandriva 5 07-20-2005 03:02 PM
Switch to Gnome to KDE? donaldtalbert Linux - Newbie 4 06-20-2005 04:15 PM
How-to switch from GNOME to KDE? aurelio26 Linux - Newbie 2 12-02-2004 11:21 AM
switch from GNOME to KDE zbably Mandriva 2 01-15-2004 05:06 AM


All times are GMT -5. The time now is 02:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration