LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Strange Gnome-terminal output on Fedora 11 64bit (http://www.linuxquestions.org/questions/linux-general-1/strange-gnome-terminal-output-on-fedora-11-64bit-739425/)

ESC201 07-11-2009 01:29 PM

Strange Gnome-terminal output on Fedora 11 64bit
 
1 Attachment(s)
Hi all, I just upgraded my system to Fedora 11 (64bit). When using the Gnome terminal I'll type something in and it will show up as a solid block; this happens quite frequently. Attached is a screenshot.

Coincidently I also just dropped a new GeForce 9500 GT into my system. I don't even know where to start with this one. Any help or a point in the right direction is awesome. Thanks! :)

marozsas 07-11-2009 05:29 PM

uhmm. for me looks like escape sequences used to set advanced terminal features like title, background and foreground colors, etc...
You are seeing theses "blocks" because the terminal you are using does not have this capability or they are not right for this terminal.
Try to reset your prompt (where theses escape sequences lives). From the image, are we seeing a remote host ? If yes, then you have to change the prompt on the remote host, not on your local machine.

ESC201 07-12-2009 01:45 PM

The only changes I've made to my terminal are I changed the color scheme and set a transparent background in the default profile.

I've tried setting everything back to default but the problem persists. And no, this is my local system, not a remote one.

When you say resetting my prompt do you mean setting the profile I'm using back to defaults, running a reset command, or something else?

marozsas 07-13-2009 11:25 AM

no, not your entire profile, just the prompt. To do this, if you are using bash, try:
Code:

PS1="[\u@\h \W]\$ "
it should display a prompt like this: "[username@hostname currdir]$ ".

However, having a second thought and re-reading your first post, you said this not happens all the time, just "quite frequently" what make me wondering if the problem is in another place, not the prompt.

From this terminal, run/type "gnome-terminal" and check if the problem persist in the new terminal.

PTrenholme 07-13-2009 12:11 PM

In the terminal window menu bar, click on "Terminal -> Character Encoding" and verify that your terminal is using the same character encoding as your applications. (The default is usually UFT-8, but you may have changed it.)

ESC201 07-14-2009 04:47 PM

2 Attachment(s)
PTrenholme, my character encoding is set as UTF-8.

marozsas, the command, PS1="[\u@\h \W]\$ ", did not work; nor did a new window spawned by running gnome-terminal.

Some more details I've noticed, when I click anywhere inside terminal with my mouse the "blocks" go back to the original character I typed in. Also, whenever the text I type in wraps to a new line the "blocks" that were on the first line disappear and go back to the original character I typed in.

I also tried changing the cursor shape to an I-beam and an underline. Attached are two screenshots of those two cursor types. (I just mashed keys to produce the problem.) It seems to be leaving behind whatever cursor type I have set in place of the character. Could this be a problem with my Nvidia 9500 GT? I never had this problem with my old Nvidia 7900. Unfortunately, I upgraded from Fedora 10 to Fedora 11 the same day I put in my new video card so I can't isolate either the card or Fedora 11 as the problem.

PTrenholme 07-14-2009 05:27 PM

I just installed the "official" nVidia driver, and have started to see this problem, but very rarely.

Suggestion: Try changing your xorg.conf file so you use the nouveau driver instead on the nvidia one. (The X-server may complain about invalid GLX modules, etc, since the nVidia versions are not compatible with the nouveau driver, but I think it may work.

To try it out, make the change and then open a terminal and type startx -- :1 That should start a second X-server attached to tty8 and switch you to that new session. If you just get a blank or black screen, press <ctrl>-<alt>-<F7> (all three keys together) to switch back to the server running on tty7 and undo the changes you made in xorg.conf.

If you're switched to the new server session, see if you have the problem in the terminal window. If it's gone away, you know it is caused by the nVidia driver, or some setting you're using. I haven't checked this, but I don't remember seeing the problem before I switched to using xrandr instead on composting in my display settings, so you might want to see if changing that setting might make a difference.

Anyhow, to close the X-server on tty8, if it started correctly, just select "Logout" from the exit menu and you'll be automatically switched back to your session on tty7.

ESC201 07-14-2009 08:50 PM

Well, changing the driver did nothing but prevent X from starting and locked up my system. I don't know if it helps, but below is my xorg.conf file. Would it also be beneficial to post my Xorg.0.log file?

Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder62)  Wed May 27 01:58:49 PDT 2009


Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"

    # generated from default
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/keyboard"
    Identifier    "Keyboard0"
    Driver        "kbd"
    Option        "XkbLayout" "us"
    Option        "XkbModel" "pc105"
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "Unknown"
    HorizSync      28.0 - 33.0
    VertRefresh    43.0 - 72.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "TwinView"
    Option        "SLI" "Auto"
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection


PTrenholme 07-14-2009 09:08 PM

Try this:
Code:

Section "Device"
    Identifier    "Device0"
    Driver        "nouveau"
#  Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
#  Option        "TwinView"
#  Option        "SLI" "Auto"
    SubSection    "Display"
        Depth      24
    EndSubSection

And, did you try the "startx" method I described, above? The "lock-up" should have been limiter to the new X-server, leaving the one connected to tty7 function as it was.

I notice that you don't have any of the fancy nVidia stuff referenced in your xorg.conf file, so perhaps my conjecture is wide of the mark. For your reference, here's the nVidia-relavent parts on my xorg.conf:
Code:

Section "Files"
        ModulePath  "/usr/lib64/xorg/modules/extensions/nvidia"
        ModulePath  "/usr/lib64/xorg/modules"                 
EndSection                                                     

Section "ServerFlags"
        Option      "AIGLX" "on"
        Option      "Xinerama" "0"
EndSection                       

Section "Monitor"
        Identifier  "Monitor0"
        VendorName  "HP"     
        ModelName    "Seiko" 
        HorizSync    30.0 - 75.0
        VertRefresh  60.0 - 60.0
        Option      "DPMS"     
EndSection                     

Section "Monitor"
        Identifier  "Monitor1"
        VendorName  "AIKI"   
        ModelName    "CRT-0" 
        HorizSync    28.0 - 33.0
        VertRefresh  43.0 - 72.0
EndSection                     

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"   
        VendorName  "NVIDIA Corporation"
        BoardName  "GeForce 7150M / nForce 630M"
        Option      "AddARGBGLXVisuals" "True" 
        BusID      "PCI:0:18:0"               
EndSection                                     

Section "Device"
        Identifier  "Videocard1"
        Driver      "nvidia"
        VendorName  "NVIDIA Corporation"
        BoardName  "GeForce 7150M / nForce 630M"
        Option      "AddARGBGLXVisuals" "True"
        BusID      "PCI:0:18:0"
        Screen      1
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth    24
        Option      "TwinView" "0"
        Option      "metamodes" "DFP: nvidia-auto-select +0+0"
        SubSection "Display"
                Depth    24
        EndSubSection
EndSection

Section "Screen"
        Identifier "Screen1"
        Device    "Videocard1"
        Monitor    "Monitor1"
        DefaultDepth    24
        Option      "TwinView" "0"
        SubSection "Display"
                Depth    24
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "Extensions"
        Option      "Composite" "Enable"
EndSection

<edit>
Oh, also for reference, here's the noveau xorg.conf file that the Fedora 11 installation created from the nvidia one when I upgraded from F10 to F11:
Code:

Section "ServerLayout"
        Identifier    "Default Layout"
        Screen      0  "Screen0" 0 0 
        Screen      1  "Screen1" RightOf "Screen0"
        InputDevice    "Mouse0" "CorePointer"   
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection                                       

Section "Files"
        ModulePath  "/usr/lib64/xorg/modules"
EndSection                                   

Section "ServerFlags"
        Option      "AIGLX" "on"
        Option      "Xinerama" "0"
EndSection                       

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "Emulate3Buttons" "no"   
        Option      "ZAxisMapping" "4 5"     
EndSection                                   

Section "InputDevice"
        Identifier  "Mouse1"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mouse1"
        Option      "SHMConfig" "true"         
        Option      "Emulate3Buttons" "yes"   
EndSection                                     

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"     
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us" 
EndSection                           

Section "Monitor"
        Identifier  "Laptop"
        VendorName  "HP"   
        ModelName    "Seiko"
        HorizSync    30.0 - 75.0
        VertRefresh  60.0 - 60.0
        Option      "DPMS"     
EndSection                     

Section "Monitor"
        Identifier  "HDTV"
        VendorName  "AIKI"
        ModelName    "CRT-0"
        HorizSync    28.0 - 33.0
        VertRefresh  43.0 - 72.0
EndSection                     

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"   
        VendorName  "NVIDIA Corporation"
        BoardName  "GeForce 7150M / nForce 630M"
        BusID      "PCI:0:18:0"               
        Screen      0                           
EndSection                                     

Section "Device"
        Identifier  "Videocard1"
        Driver      "nouveau"
#      Driver      "nvidia"
        VendorName  "NVIDIA Corporation"
        BoardName  "GeForce 7150M / nForce 630M"
        BusID      "PCI:0:18:0"
        Screen      1
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        Monitor    "Laptop"
        DefaultDepth    24
        Option      "TwinView" "0"
        SubSection "Display"
                Depth    24
                Modes    "1440x900" "1280x800" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "Screen"
        Identifier "Screen1"
        Device    "Videocard1"
        Monitor    "HDTV"
        DefaultDepth    24
        Option      "TwinView" "0"
        SubSection "Display"
                Depth    24
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "Extensions"
        Option      "Composite" "Enable"
EndSection

</edit>

ESC201 07-14-2009 10:00 PM

By lock-up I mean that when I ran the command "startx -- :1" my system started the new X session and switched to it but it displayed nothing but a black screen. Ctrl alt F7/F2/F*/Backspace/Delete did nothing, so I was forced to reset the system.

I've long since wondered why I did not have any of the fancy Nvidia info in my xorg.conf. I installed my drivers by downloading the installer from Nvidia's website. I run that, it compiles the drivers, then asks me if I want it to configure my xorg.conf file (excuse me if I am being redundant here) and I tell it yes and everything has always worked for me. That being said, I just got a new Nvidia 9500 GT (a second one) today (why I have the SLI line in my xorg.conf) and X won't start when it is in my system (my thread relating to that issue can be found here). I am thinking that my problem lies with a lack of proper configuration of my drivers. Anyway, should the Nvidia installer have put all that info in my xorg.conf file for me? Is there another utility that does that? or do I have to do it manually? If so, how would I do that? Thank you for all your help. It's very much appreciated.

ESC201 07-15-2009 09:19 PM

I got the issue with my new graphics cards sorted out. Turns out I needed to specify the BusID for each of them in my xorg.conf. I was hoping that adding a little more configuration to xorg.conf would fix this problem with my terminal but it still persists.

ESC201 07-19-2009 11:12 PM

continuing frustration... :(

gobiigloo 08-03-2010 01:40 PM

strange gnome terminal keystroke behavior
 
I had strange gnome terminal keystroke behavior. After reading this semi-fortuitous [google.com/linux "cherry picking"] column (and after reinstalling 'some' non-offending RedHat RHEL 5 packages, etc. etc. to solve my odd ' i ' behavior problem.) Reading this column put me onto going to my gnome console menu at the top and looking around.

So, I went to the terminal's edit->Keyboard Shortcuts->Edit And I saw that somehow -- or someone [I use a #trivia chatroom (but my 24/7 RedHat Network updating and security bug fixing should have caught any intrusion, right?)] I certainly did not make the change with either volition or veleity. -resuming- someone or some synchronicity-intensive event had changed my 'paste' Keyboard Shortcut, in the gnome terminal only, to the single letter ' i ' !?!?!?!

Changed it back to Ctrl+v with the help of some very good gnome documentation/programming in that console (N.B.: in KDE it did not happen, maybe that fact should have given me more info than it did... next time I'll try ratiocination more vigorously.) Now I'm good to go.

I was bummed out. [Not a good thing, you will tell me, for a programmer / SysAdmin to allow him/herself to enjoy: shame, visions of "The Complete Dummies Guide to __" which series is possibly a typical cunning excuse-pregnant tactic of the _______ party; or anger, frustration, creeping rumination of low self-worth...]

e.g.: Yesterday, I fixed a kitchen plumbing problem two minutes before a housing inspector arrived. I am not a plumber; but I am becoming a better problem solver. "He fixes radios by THINKING!" (--Richard Feynman quoting someone else in re. his capabilities showing up early-on. I've bought "The Pleasure of Finding Things Out" -- and 49 other tomes from _____ within the most recent 10 months. 132 more on my wish list [RT(Fascinating)Ms] but problems, currently, with USPS delivery of too many in ______. FedEx next time. Maybe these represent the _____ party's tactics. In situations in history such as the current "political" scenario, intellectuals and books 'go', or are targeted first. Polymathy is a Good Thing for anybody to flirt with, if not marry.)

BACK TO MAIN THEME: John Paul Sartre said (yes, this applies, admin/moderator; respectfully -- it may even be "key" <--humor :) **"I have never thought myself the possessor of any special talent, rather I have applied myself to Work and faith." (possibly Faith for myself, gobiigloo: both.)" [**Fairly close paraphrase.]

Thanks for the leg up! and for not being of the ______ party, clearly! Last polymath-intensive quote today: "A paranoid is just a person who knows a little bit about what's really going on." --William S. Burroughs

gobiigloo, from atop his personal giants' shoulders (see above for small sampling of that personnel list; larger list on request, but probably highly subjective, must find your own, I presume -- but one word: Lateral. I also take advice! ... :)


All times are GMT -5. The time now is 03:51 AM.