LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 02-07-2003, 09:52 AM   #1
Registered: Dec 2002
Location: Omaha, Nebraska
Distribution: Ubuntu 8.10
Posts: 79

Rep: Reputation: 15
Unhappy Startx still runs KDE 3.0.1 instead of KDE 3.1


I have recently and successfully installed KDE 3.1. I have gone through completed the post installation set-up requirements:

1. Added /root/kde3.1/bin to PATH
2. export QTDIR=~/kde3.1
3. export KDEDIRS=~/kde3.1
4. export LD_LIBRARY_PATH=~kde3.1/lib
5. export KDEHOME=~/.kdetest


However, when I run xwmconfig and choose KDE and then run startx, I still start KDE 3.0.1 instead of KDE 3.1.

"How do I properly start KDE 3.1?"

Any direction or suggestions would be appreciated. Thank you in advance!
Old 02-07-2003, 10:08 AM   #2
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,544

Rep: Reputation: 160Reputation: 160
If you're not root, it shouldn't work (because usually only root has read access to /root). Try to copy your KDE somewhere.
The manula version. Try it first with one user. Find out where's 'startkde' executable from new KDE. Let's say it's in /usr/local/kde31/bin. Create a file .xinitrc in your home directory and type inside
When you run startx as that user, new KDE should start.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Enemy Territory runs under GNOME but not KDE DonbertK Linux - Games 4 05-01-2005 08:46 AM
Item in ~/.kde/Autostart runs twice hand of fate Linux - Software 1 04-29-2005 11:53 PM
i prelinked kde, but kdeinit still runs ?! qwijibow Linux - General 1 10-31-2004 08:56 AM
KDE runs s l o w.... CPUguy387 Linux - Newbie 7 07-27-2004 02:22 PM
Less memory usage when KDE runs with XFwm shad061 Linux - General 2 02-07-2004 03:12 PM

All times are GMT -5. The time now is 12:29 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration