LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   startx -- -dpi 100 .. automatically? (http://www.linuxquestions.org/questions/linux-general-1/startx-dpi-100-automatically-50058/)

doublefailure 03-16-2003 02:56 AM

startx -- -dpi 100 .. automatically?
 
hi.
my default run level is 4
and kdm seems to do startx

i can't find where i can give option to startx?
(i don't want to login to command shell and type startx -- -dpi 100)

where should i modify to startx starts with the option ?

rch 03-16-2003 05:04 AM

Re: startx -- -dpi 100 .. automatically?
 
Quote:

Originally posted by doublefailure
hi.
my default run level is 4
and kdm seems to do startx

i can't find where i can give option to startx?
(i don't want to login to command shell and type startx -- -dpi 100)

where should i modify to startx starts with the option ?

edit your xinitrc file
usually located in /etc/X11 folder

doublefailure 03-16-2003 02:44 PM

thanks
i managed to do it with modifying this file.
/usr/X11R6/lib/X11/xdm/Xservers

$ps -ef | grep dpi
root 1615 135 0 02:07 ? 00:00:26 /usr/X11R6/bin/X -dpi 100 -auth /var/run/xauth/A:0-rNRKAs

by the way.. my applications don't seem to use 100 instead of 75?

my main concern is font in galeon browser.

galeon font information gives
-Adobe-Helvetica-Medium-R-Normal--12-120-75-75-P-67-ISO8859-1

which looks like 75..

what do i do?

thanks again

rch 03-17-2003 09:27 AM

Quote:

Originally posted by doublefailure
thanks
i managed to do it with modifying this file.
/usr/X11R6/lib/X11/xdm/Xservers

$ps -ef | grep dpi
root 1615 135 0 02:07 ? 00:00:26 /usr/X11R6/bin/X -dpi 100 -auth /var/run/xauth/A:0-rNRKAs

by the way.. my applications don't seem to use 100 instead of 75?

my main concern is font in galeon browser.

galeon font information gives
-Adobe-Helvetica-Medium-R-Normal--12-120-75-75-P-67-ISO8859-1

which looks like 75..

what do i do?

thanks again

i don't know about galeon
but for availability of 100 dpi fonts
check the xfs (x font server) config file
it should point to 100 dpi font folder
check man xfs
keep posted

doublefailure 03-17-2003 11:09 AM

less /usr/X11R6/lib/X11/fs/config

clone-self = on
use-syslog = off
catalogue = /usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/Ty
pe1/,/usr/X11R6/lib/X11/fonts/CID/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/
error-file = /var/log/fs-errors
# in decipoints
default-point-size = 120
default-resolutions = 75,75,100,100

# font cache control, specified in KB
cache-hi-mark = 2048
cache-low-mark = 1433
cache-balance = 70

should i remove /usr-----/75dpi ?

thanks again

rch 03-17-2003 11:19 PM

Quote:

Originally posted by doublefailure
less /usr/X11R6/lib/X11/fs/config

clone-self = on
use-syslog = off
catalogue = /usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/Ty
pe1/,/usr/X11R6/lib/X11/fonts/CID/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/
error-file = /var/log/fs-errors
# in decipoints
default-point-size = 120
default-resolutions = 75,75,100,100

# font cache control, specified in KB
cache-hi-mark = 2048
cache-low-mark = 1433
cache-balance = 70

should i remove /usr-----/75dpi ?

thanks again

maybe you should change the default resolutions
that should work


All times are GMT -5. The time now is 12:41 AM.