Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 01-13-2004, 12:11 PM   #1
Registered: Oct 2003
Location: Riverside, CA
Distribution: Slackware/RedHat
Posts: 79

Rep: Reputation: 15
Starting Blackbox from runlevel 3

Starting Blackbox from runlevel 3

I have searched all over and cant find the command to start blackbox.
I boot into runlevel 3 and need to know the command to start blackbox. I do not want to make it my default WM. I have tryed numerous commands but cant seem to find the right one.

Can someone give me the command with startx to get blackbox up?

Im on a redhat 9 machine at moment but also have slackware 9.1 that I want to use it on. I know it works because I have changed to runlevel 4/5 and opened it from there.
Thx in advance.
Old 01-13-2004, 12:31 PM   #2
Senior Member
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
open up your .xinitrc file in your home directory and type in
exec blackbox
then save and exit the file
and type :
Old 01-13-2004, 01:33 PM   #3
LQ Guru
Registered: Jan 2001
Posts: 24,147

Rep: Reputation: 229Reputation: 229Reputation: 229
If on Slackware you can also do xwmconfig to change your default desktop/window-manager, etc.
Old 01-13-2004, 06:23 PM   #4
LQ Addict
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
And if you want to start blackbox occasionally (don't want it as default), you could
startx blackbox (if xinitrc is set up with windowmanager options)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Services not starting in runlevel 3 JesusAddict3791 Linux - Newbie 4 04-26-2005 01:49 AM
[SOLVED] Starting in runlevel 4 + nvidia question. Linux.tar.gz Slackware 6 09-14-2004 02:44 AM
Autostart Programs (Xscreensaver) When Starting Blackbox Ian Linux - Software 0 05-09-2004 04:05 PM
Need help starting blackbox Nylex Linux - Software 3 07-08-2003 05:47 PM
error starting blackbox glock19 Linux - General 7 03-19-2002 07:59 PM

All times are GMT -5. The time now is 06:50 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration