LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-25-2007, 06:34 PM   #1
Sessel
LQ Newbie
 
Registered: Dec 2007
Distribution: Gentoo
Posts: 9

Rep: Reputation: 0
start-stop-daemon: stat /usr/bin/xdm


Hello,

I was facing some trouble with my ethernet card and apparently we couldn't find a solution. So I just install the last release of gentoo (2.6.23 r3). I just installed GNOME and configured it as my default session manager. After rebooting, at the end of the booting sequence, I got a strange message:
Quote:
* Setting up xdm ...
start-stop-daemon: stat /usr/bin/xdm: No such file or directory (No such file or directory)
* ERROR: could not start the Display Manager [ok]
I thought it was a typo I made ("stat" instead of "start") while configuring but I can't find any occurence of this in the handbook I used.

I would gladly appreciate your help. Thanks.
 
Old 12-25-2007, 06:42 PM   #2
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Hi,

Actually, no, it's not a typo, the problem is that your system doesn't have xdm installed, even if you use gdm (Gnome Display Manager) as your dm, you need to have installed xdm since gdm/kdm/slim depends on it to work. So, install it:

Code:
emerge xdm
(It's adviced that you should run emerge using the --pretend option before to install that or anyother package so you don't install dependencies that you don't want to)




Regards
 
Old 12-26-2007, 06:58 AM   #3
Sessel
LQ Newbie
 
Registered: Dec 2007
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for your answer.
Yet, I wonder why when I run startx, gnome does run.
 
Old 12-26-2007, 07:18 AM   #4
Sessel
LQ Newbie
 
Registered: Dec 2007
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
I tried to emerge xdm.
Now it allmost works, but I don't understand why it launches
xdm instead of gnome at startup. I checked the configuration files /etc/conf.d/xdm and ~/.xinitrc but everything looks ok.
 
Old 12-26-2007, 07:30 AM   #5
Sessel
LQ Newbie
 
Registered: Dec 2007
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
Uncommenting XSESSION="Gnome" in /etc/rc.conf finally solved the problem. Yet, if you can explain me why, I'd be glad to know. Thanks.
 
Old 12-26-2007, 08:03 AM   #6
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
startx will call .xinitrc and then, whatever it is configured in it, i. e. if you have in your .xinitrc startgnome, then, by typing startx, you're calling .xinitrc and startgnome.

.xinitrc doesn't have anything to do with DMs, since to run startx you've to be already logged in, so, when you used startx, gnome came up because .xinitrc was configured to do that.

From conf.d, you configure xdm to call any DM you want using the DISPLAYMANAGER variable, when it's installed for the first time (xdm), it's configured like this:
Code:
DISPLAYMANAGER="xdm"
So, if you want to use gdm instead, you change that line to:
Code:
DISPLAYMANAGER="gdm"
However, if you read the comments about DMs in /etc/conf.d/xdm, you'll see:
Code:
# What display manager do you use ?  [ xdm | gdm | kdm | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
And that's what happen when you edit your rc.conf, setting XSESSION="Gnome", the system is instructed to call Gnome the same way you did using .xinitrc regardless the configuration of xdm daemon, if the systems has to use XSESSION="Gnome", and nobody has logged in (which wasn't the case when you used .xinitrc), then, it has to call some DM to ask for login credentials, in this case, called GDM.




Regards
 
Old 12-26-2007, 08:56 AM   #7
Sessel
LQ Newbie
 
Registered: Dec 2007
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for your explanation. Yet there's something I don't understand:
in /etc/conf.d/xdm I had already changed DISPLAYMANAGER="gdm"
(That's what I wanted to say when I said that I had checked configuration files)
Or maybe there's something I have misunderstood?
 
Old 12-26-2007, 11:24 AM   #8
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
And xdm was still loading it self instead gdm?

Odd, never had that problem.

One thing is that xdm always going to be loaded, no matter if you set gdm, kdm, entrance, slim, etc, /etc/ini.t/xdm will load first but it will check and try to load DISPLAYMANAGER setting for another DM. However, if you put gdm as your DM in conf.d/xdm, xdm will load but you'll see gdm, not xdm. If you changed the setting and it was still loading xdm (nowhere you saw gdm), then I'm clueless =/

Hope some other LQ member has a proper explanation to that




Regards
 
  


Reply

Tags
display, gnome, manager, start, startx, xdm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
path in services wrong for clamav updated frm 0.75 to 0.80 usr/bin vs usr/local/bin Emmanuel_uk Linux - Newbie 3 04-22-2005 01:02 AM
Logging with Start stop daemon bigsness Linux - General 0 01-19-2005 03:25 PM
/usr/bin/stat not present. Can I just copy the file mystique98ls Linux - Newbie 2 01-06-2005 02:02 PM
Start program in daemon mode from cgi-bin Xa! Programming 1 11-30-2004 11:00 PM
start daemon from cgi-bin via web-interface Xa! Programming 1 07-26-2004 03:08 PM


All times are GMT -5. The time now is 07:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration