LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   start-stop-daemon: stat /usr/bin/xdm (http://www.linuxquestions.org/questions/linux-general-1/start-stop-daemon-stat-usr-bin-xdm-609095/)

Sessel 12-25-2007 06:34 PM

start-stop-daemon: stat /usr/bin/xdm
 
Hello,

I was facing some trouble with my ethernet card and apparently we couldn't find a solution. So I just install the last release of gentoo (2.6.23 r3). I just installed GNOME and configured it as my default session manager. After rebooting, at the end of the booting sequence, I got a strange message:
Quote:

* Setting up xdm ...
start-stop-daemon: stat /usr/bin/xdm: No such file or directory (No such file or directory)
* ERROR: could not start the Display Manager [ok]
I thought it was a typo I made ("stat" instead of "start") while configuring but I can't find any occurence of this in the handbook I used.

I would gladly appreciate your help. Thanks.

Acron_0248 12-25-2007 06:42 PM

Hi,

Actually, no, it's not a typo, the problem is that your system doesn't have xdm installed, even if you use gdm (Gnome Display Manager) as your dm, you need to have installed xdm since gdm/kdm/slim depends on it to work. So, install it:

Code:

emerge xdm
(It's adviced that you should run emerge using the --pretend option before to install that or anyother package so you don't install dependencies that you don't want to)




Regards

Sessel 12-26-2007 06:58 AM

Thanks for your answer.
Yet, I wonder why when I run startx, gnome does run.

Sessel 12-26-2007 07:18 AM

I tried to emerge xdm.
Now it allmost works, but I don't understand why it launches
xdm instead of gnome at startup. I checked the configuration files /etc/conf.d/xdm and ~/.xinitrc but everything looks ok.

Sessel 12-26-2007 07:30 AM

Uncommenting XSESSION="Gnome" in /etc/rc.conf finally solved the problem. Yet, if you can explain me why, I'd be glad to know. Thanks.

Acron_0248 12-26-2007 08:03 AM

startx will call .xinitrc and then, whatever it is configured in it, i. e. if you have in your .xinitrc startgnome, then, by typing startx, you're calling .xinitrc and startgnome.

.xinitrc doesn't have anything to do with DMs, since to run startx you've to be already logged in, so, when you used startx, gnome came up because .xinitrc was configured to do that.

From conf.d, you configure xdm to call any DM you want using the DISPLAYMANAGER variable, when it's installed for the first time (xdm), it's configured like this:
Code:

DISPLAYMANAGER="xdm"
So, if you want to use gdm instead, you change that line to:
Code:

DISPLAYMANAGER="gdm"
However, if you read the comments about DMs in /etc/conf.d/xdm, you'll see:
Code:

# What display manager do you use ?  [ xdm | gdm | kdm | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.

And that's what happen when you edit your rc.conf, setting XSESSION="Gnome", the system is instructed to call Gnome the same way you did using .xinitrc regardless the configuration of xdm daemon, if the systems has to use XSESSION="Gnome", and nobody has logged in (which wasn't the case when you used .xinitrc), then, it has to call some DM to ask for login credentials, in this case, called GDM.




Regards

Sessel 12-26-2007 08:56 AM

Thanks for your explanation. Yet there's something I don't understand:
in /etc/conf.d/xdm I had already changed DISPLAYMANAGER="gdm"
(That's what I wanted to say when I said that I had checked configuration files)
Or maybe there's something I have misunderstood?

Acron_0248 12-26-2007 11:24 AM

And xdm was still loading it self instead gdm?

Odd, never had that problem.

One thing is that xdm always going to be loaded, no matter if you set gdm, kdm, entrance, slim, etc, /etc/ini.t/xdm will load first but it will check and try to load DISPLAYMANAGER setting for another DM. However, if you put gdm as your DM in conf.d/xdm, xdm will load but you'll see gdm, not xdm. If you changed the setting and it was still loading xdm (nowhere you saw gdm), then I'm clueless =/

Hope some other LQ member has a proper explanation to that




Regards


All times are GMT -5. The time now is 09:05 AM.