LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-09-2003, 03:00 PM   #1
ashley75
Member
 
Registered: Aug 2003
Posts: 231

Rep: Reputation: 30
ssh and using putty from the client


I am trying to connect the server Redhat Advance server 2.1, using putty program and I have some problems. I was able to telnet to this server but I understand it's not safe so I am trying to ssh.

From the server, I was able to do:
#ssh oracle@machine_name

and it connected. when I do that from the client I can't.

could someone please give me some instruction of how to do this????

thanks,
 
Old 09-09-2003, 05:42 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
Check your firewall. Probably you're blocking ssh.
 
Old 09-10-2003, 08:46 AM   #3
ashley75
Member
 
Registered: Aug 2003
Posts: 231

Original Poster
Rep: Reputation: 30
I don't think firewall is a problem b/c I reside internally another word, I am on the same side as the server locate. it's not like I am from outside. plus telnet is owrking fine for me.

any thought???
 
Old 09-10-2003, 10:46 AM   #4
tefal
Member
 
Registered: Jul 2003
Location: S. Wales
Distribution: Fedora Core 5, SuSE 9.1 Pro
Posts: 30

Rep: Reputation: 15
How about the firewall settings on the server - is the incoming port blocked?
 
Old 09-10-2003, 01:57 PM   #5
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
From the client, run something like
telnet serverIP ssh
(it connects to the ssh port using telnet, so you can see all messages). Check what happens.
 
Old 09-11-2003, 09:40 AM   #6
ashley75
Member
 
Registered: Aug 2003
Posts: 231

Original Poster
Rep: Reputation: 30
when I say:

telnet ServerIP 23

it works fine


but when I say:
telnet ServerIP 22

and I got the error:

Connecting To 172.23.1.8...Could not open a connection to host on port 22 : Connection failed

I believe ssh using port 22 and seem likes port 22 is unvailable, how to get this work???

thanks
 
Old 09-11-2003, 09:53 AM   #7
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Is ssh even running?

ps -aux | grep sshd

And when they mean firewall, make sure a firewall on this server is not blocking port 22, not if its behind another firewall, etc.
 
Old 09-11-2003, 09:57 AM   #8
ashley75
Member
 
Registered: Aug 2003
Posts: 231

Original Poster
Rep: Reputation: 30
it's running

root 903 0.0 0.0 2676 1280 ? S Sep10 0:00 /usr/sbin/sshd
oracle 7399 0.0 0.0 1752 616 pts/7 S 09:55 0:00 grep sshd


how can I check to see if the firewall on this server is blocking the port 22?????

what about FTP, could you please show me how to check for FTP as well???

thanks
 
Old 09-11-2003, 10:10 AM   #9
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
I'm never used the Advanced Server but you can try to type: setup at a console to bring up a configuration window to setup different services, etc. Should be able to select from there to allow FTP and SSH and reconfigure your default firewall settings if that was setup during installation.
 
Old 09-11-2003, 10:23 AM   #10
ashley75
Member
 
Registered: Aug 2003
Posts: 231

Original Poster
Rep: Reputation: 30
thanks for your prompt advises.

I did type setup and go to services, I noticed that ftp services is not there so how can I reinstall the ftp package on this server???/
 
Old 09-11-2003, 10:52 AM   #11
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
It depends on what ftp package you want to use. If you have the RedHat cds you can run:

redhat-config-packages

and then choose to install whatever ftp package you want from there. Then you will be prompted to insert the redhat cd.
 
Old 09-11-2003, 10:53 AM   #12
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Quote:
Originally posted by ashley75
thanks for your prompt advises.

I did type setup and go to services, I noticed that ftp services is not there so how can I reinstall the ftp package on this server???/
You can either most likley install the FTP packages provided by Redhat from your CD's you installed with or you can download whatever FTP service you intend to use. If your looking for the most popular with best track record, I'd recommend proftpd at www.proftpd.org or if you want it secure, go with something like sftp.

Regards.
 
Old 09-11-2003, 01:21 PM   #13
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
Quote:
Originally posted by ashley75

how can I check to see if the firewall on this server is blocking the port 22?????
iptables -L
Then search for a line with '22'. But it may be SSHD configuration. Look into /etc/sshd/sshd_config (or a similar file), browse the configuration, maybe it's allowing only certain IPs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing pc with putty (ssh) Wozl Linux - Networking 1 10-10-2005 03:44 PM
PuTTY/OS X SSH confusion stutterbug Linux - General 1 03-12-2005 04:38 PM
esound over ssh / putty? oldweasel Linux - Networking 6 05-27-2004 02:05 PM
putty SSH connection deWin Linux - Newbie 3 03-26-2004 09:47 AM
SSH using putty rkemp Linux - Networking 3 03-06-2004 05:04 PM


All times are GMT -5. The time now is 01:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration