LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 03-20-2013, 02:51 AM   #1
banajit
LQ Newbie
 
Registered: Sep 2012
Posts: 3

Rep: Reputation: Disabled
squid 3.1 gives cache error for Google, Bing, Yahoo etc.


Sir,

I have installed squid-3.1.10 on my centos-6.3. It was working file for the first day. But after that it shows problem while opening the mostly visited sites like Google.com, Bing.com, Yahoo.com etc. But all the rarely visited sites are coming nicely. Again after some hours it works fine for all the sites. The problem arises many 2-3 times in a day.

It gives the following error message:

The following error was encountered while trying to retrieve the URL: http://www.google.co.in/

Connection to 2404:6800:4009:803::1018 failed.

The system returned: (110) Connection timed out

The remote host or network may be down. Please try the request again.
Your cache administrator is root.

Please give me your valuable suggestions.
 
Old 03-20-2013, 11:23 AM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,082

Rep: Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713Reputation: 2713
Quote:
Originally Posted by banajit View Post
Sir,
I have installed squid-3.1.10 on my centos-6.3. It was working file for the first day. But after that it shows problem while opening the mostly visited sites like Google.com, Bing.com, Yahoo.com etc. But all the rarely visited sites are coming nicely. Again after some hours it works fine for all the sites. The problem arises many 2-3 times in a day.

It gives the following error message:

The following error was encountered while trying to retrieve the URL: http://www.google.co.in/
Connection to 2404:6800:4009:803::1018 failed.
The system returned: (110) Connection timed out
The remote host or network may be down. Please try the request again.
Your cache administrator is root.

Please give me your valuable suggestions.
First, there are not just "sirs" on this site. And what you're describing is due to your cache settings. You can either expire them more frequently, or you can use the always_direct directive in your squid configuration. Your choice:
http://www.squid-cache.org/Versions/...ys_direct.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Squid cache error kanjah Ubuntu 4 12-19-2012 02:57 PM
LXer: Microsoft & Yahoo Take Big Gamble on Bing LXer Syndicated Linux News 0 08-01-2009 10:01 PM
Using Active directory Authentication of parent non-squid cache to child squid cache espiya7 Linux - Server 0 05-05-2009 09:04 AM
Force Squid to Cache maps.google.com? esaym Linux - Networking 1 01-11-2007 05:59 PM
squid cache error woods Linux - Networking 3 10-29-2004 03:05 PM


All times are GMT -5. The time now is 06:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration