LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 04-20-2002, 06:59 PM   #1
nabil
Member
 
Registered: Feb 2001
Location: MI, USA
Distribution: Debian Linux 100% GNU
Posts: 210

Rep: Reputation: 31
Splash screen for Grub


Hello,
I have just installed grub-0.91 and everything seems to work except getting the splash screen to show up ??? I don't know what I am doing wrong. Here is my menu.lst
Code:
root@nabil/boot/grub# more menu.lst
#
# Sample boot menu configuration file
#

# Boot automatically after 30 secs.
timeout 30

# By default, boot the first entry.
default 0

# Fallback to the second entry.
fallback 1
color green/black light-green/black
splashimage=(hd0,0)/boot/grub/splash.xpm.gz


# For booting Linux
title  Linux 2.5.0
root (hd0,0)
kernel /boot/vmlinuz-2.5.0 root=/dev/hda1 hdc=ide-scsi vga=ask
Can any one help..
Thanks.
 
Old 04-20-2002, 07:25 PM   #2
pbharris
Member
 
Registered: Apr 2001
Location: chicago, IL
Distribution: debian, redhat
Posts: 280

Rep: Reputation: 30
hello,
i thought that command was supposed to go in the file <grub dir>grub.conf
 
Old 04-20-2002, 08:01 PM   #3
nabil
Member
 
Registered: Feb 2001
Location: MI, USA
Distribution: Debian Linux 100% GNU
Posts: 210

Original Poster
Rep: Reputation: 31
grub.conf is just a sym link to menu.lst. should not make any diffenece.

should it !!!
 
Old 04-21-2002, 12:03 AM   #4
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Try changing the ' ask ' in ' vga=ask ' to the actual number. Mine uses ' vga=274 '.
 
Old 04-21-2002, 11:37 AM   #5
nabil
Member
 
Registered: Feb 2001
Location: MI, USA
Distribution: Debian Linux 100% GNU
Posts: 210

Original Poster
Rep: Reputation: 31
This was happening before I even put the vga=ask ????
 
Old 04-21-2002, 04:20 PM   #6
ngomong
Member
 
Registered: Apr 2002
Posts: 54

Rep: Reputation: 15
All the file calls are relative to /boot... therefore:

splashimage=(hd0,0)/boot/grub/splash.xpm.gz

Should be:

splashimage=(hd0,0)/grub/splash.xpm.gz

It was looking for the image in /boot/boot/grub/splash.xpm.gz

Hope that works!
 
Old 04-22-2002, 04:33 AM   #7
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Did you try changing ' vga=ask ' to the right video mode.

On my system, I have to have the splashscreen line uncommented and the ' vga= ' entry set to the right video mode. To disable the splashscreen, I have to comment out the splashscreen line and change the ' vga=274 ' entry to ' vga=normal '.
 
Old 04-22-2002, 09:00 PM   #8
nabil
Member
 
Registered: Feb 2001
Location: MI, USA
Distribution: Debian Linux 100% GNU
Posts: 210

Original Poster
Rep: Reputation: 31
Unhappy

Sorry, tried both suggestions, but still no picture
 
Old 04-22-2002, 10:59 PM   #9
PimpNasty
LQ Newbie
 
Registered: Apr 2002
Location: Central Wisconsin
Distribution: RedHat 7.2 w/ SGI XFS
Posts: 8

Rep: Reputation: 0
Try changing the splashimage line to "splashimage=(hd0,0)/grub/splash.xpm.gz" and moving that line before the "# Fallback to the second entry." line.
 
Old 04-24-2002, 05:26 AM   #10
nabil
Member
 
Registered: Feb 2001
Location: MI, USA
Distribution: Debian Linux 100% GNU
Posts: 210

Original Poster
Rep: Reputation: 31
Not working yet ..Still no go
 
Old 04-26-2002, 07:46 PM   #11
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Let's try this.

Boot up linux and allow it to boot automatically. Time how long it takes. According to your menu.lst file, it should take 30 seconds. Make sure it does.

Run ls -l /boot/grub and see if the file splash.xpm.gz exists and if has a size greater than zero and it has its permission set to be readable.

Change the timeout 30 line to timeout 45. Then reboot and let it boot automatically and time it to make sure it takes 45 seconds. I'm just checking to make sure that grub is using this config file and not using some other config file. Also, before you reboot, comment out the color green/black light-green/black line and you can remove the vga=ask kernel option.
 
Old 04-27-2002, 09:00 PM   #12
nabil
Member
 
Registered: Feb 2001
Location: MI, USA
Distribution: Debian Linux 100% GNU
Posts: 210

Original Poster
Rep: Reputation: 31
linuxcool,

I tried all your suggestions, and still no picture...

It appears to be using the correct config file.. I don't have other config files..
I am using the picture used in Redhat distribution to test this. SHall I try some other splash.xpm.gz !! if so do you know Were I can get a cool one or make one my self ....
 
Old 04-29-2002, 05:26 AM   #13
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Your version of grub may not be able to handle the command splashimage. Red Hat 7.2 can handle it because I saw a sample menu.lst file on their web site.

My version uses splashscreen and also needs vga=274 to work. I doubt that changing splashimage to splashscreen will work, because I think you'll need a different type of splashscreen file to get it to work.

Try man grub and info grub to see if there is any mention of setting up a splashscreen.
 
Old 05-08-2002, 04:26 AM   #14
kdaru
LQ Newbie
 
Registered: May 2002
Location: Arizona
Distribution: Mandrake7.1, now SuSE 8
Posts: 14

Rep: Reputation: 0
GRUB splashscreen

I haven't had any luck with the splashscreen either, but being a newbie attributed it to my own stupidity. But look at http://mail.gnu.org/pipermail/bug-gr...y/006527.html. Apparently, the splash screen is a non-standard patch to GRUB that only Redhat has. My own grub is 0.92, and grepping through the source files show no mention of the words splashimage or splashscreen, implying that my version does not have the patch. Somewhere in the mailing list they mention that it won't be incorporated as a standard feature of grub until v. 1.0. Let us know if the patch works!
 
Old 05-08-2002, 04:30 AM   #15
kdaru
LQ Newbie
 
Registered: May 2002
Location: Arizona
Distribution: Mandrake7.1, now SuSE 8
Posts: 14

Rep: Reputation: 0
P.S.

Take the period off the end of the link address; I'm still learning the ropes of this forum, sorry...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Creating kde splash screen boot screen JUDOLIZARD Linux - Newbie 6 01-30-2009 01:32 PM
Splash Screen dimension8300 Suse/Novell 5 02-20-2005 04:40 PM
Splash screen - What?? Micro420 Mandriva 5 09-07-2003 04:36 PM
splash screen rh 7.3 klod Linux - Software 0 05-09-2003 05:12 AM
splash screen snocked Linux - Newbie 1 01-12-2003 01:43 PM


All times are GMT -5. The time now is 12:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration