LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 05-21-2005, 04:25 AM   #1
newbie007007
Member
 
Registered: Dec 2004
Location: India
Distribution: Fedora
Posts: 36

Rep: Reputation: 15
sound device not working


Hi,

I am using FC3.
Suddenly my xmms is not working.
It is sound device is used by other program.
Even after rebooting the same thing happening.
When i started mplayer ,a message came saying that "Error initializing Default sound device and null output device is used." and presently mplayer is working.

Plz help me fix this error.
Thank you.
 
Old 05-21-2005, 04:44 AM   #2
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
ALSA is output plugin?
Intel-on-board souncard?
What kernel?
 
Old 05-21-2005, 06:25 AM   #3
newbie007007
Member
 
Registered: Dec 2004
Location: India
Distribution: Fedora
Posts: 36

Original Poster
Rep: Reputation: 15
kernel 2.6.9-1.667.
intel onboard soundcard.
alsa output plugin.


thank you.
 
Old 05-21-2005, 07:03 AM   #4
mkoljack
Member
 
Registered: Jan 2005
Location: Chicago
Distribution: Fedora Core 4, Suse 9.3
Posts: 186

Rep: Reputation: 30
Sound

If you are using various multimedia applications all using the ALSA output device, you will get these error msgs. So, what has worked for me is to set amarok == alsa output, xmms == arts output, etc, etc. And even then the error message sometimes occurs. I either restart ALSA and/ or reset arts/system sound. Only takes a second and I'm back to listening pleasure.

Good Luck.
 
Old 05-21-2005, 08:11 AM   #5
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
1) You should have "~/.asoundrc" with the following content:
Code:
pcm.!default {
    type plug
    slave.pcm "dmixer"
}


pcm.dmixer  {
    type dmix
    ipc_key 1024
    slave {
        pcm "hw:0,0"
        period_time 0
        period_size 1024
        buffer_size 4096
        rate 44100
    }
    bindings {
        0 0
        1 1
    }
}

ctl.dmixer {
    type hw
    card 0
}
2) arts is said to be s**t, so turn it off;
3) in xmms Preferences do the following:
a) in Audio I/O Plugins tab:
set ALSA as Output Plugin;
press Configure;
in Device settings tab set Audio device to "default";
in Advanced settings tab unselect "Mmap mode";
b) in Options tab:
select "Allow multiple instances";
4) Also you may not have an access to audio device as an avarage user. This way you should add yourself to audio group:
Open /etc/group;
find a line with such content:
Code:
audio::17:
and change it to:
Code:
audio::17:kornerr
instead of kornerr place your login name, of course
5) Reboot and ENJOY

~~~EDIT~~~
I've found that arts is not s**t. So turn it on!

Last edited by kornerr; 05-29-2005 at 01:46 PM.
 
Old 05-21-2005, 09:28 AM   #6
mkoljack
Member
 
Registered: Jan 2005
Location: Chicago
Distribution: Fedora Core 4, Suse 9.3
Posts: 186

Rep: Reputation: 30
Thank You Kernerr

Wow Kernerr--

Thanks so much. I also did as you suggested. All the multimedia now works in ALSA with no busy messages. No more arts. I appreciate it.

Mark
 
Old 05-21-2005, 10:29 AM   #7
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
Glad to hear "thanks" from you, mkoljack. But next time I ask you to not mistype my nickname
Just copy/paste the nicknames which you want to use - this way there won't be any mistakes.
Thanks.
 
Old 05-21-2005, 11:53 AM   #8
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
Yes, it looked like a good fix. But when I tried it (with the suggested .asoundrc), my ALSA driver barfed, setting output to /dev/null, as described above.

On the other hand OSS and TOSS both work fine. (Enligtned produces a "fuzzy" test sound, but it did work.)

Bottom line: I don't think ALSA is quite yet ready for prime time. The developers should, IMHO, look at the OSS code. It seems, to me, to be much more robust.

By the way, I believe you are supposed be able to set a system-wide asoundrc in /etc/ which might be useful for a system with multiple users. Igf ALSA actually worked.
 
Old 05-21-2005, 01:34 PM   #9
mkoljack
Member
 
Registered: Jan 2005
Location: Chicago
Distribution: Fedora Core 4, Suse 9.3
Posts: 186

Rep: Reputation: 30
Oops, sorry kornerr. Thanks for taking time to help us. PTrenholme -- ALSA is a fantasic output in Linux and it handles my external USB sound card SB Audigy2 NX. My point is there is a solution for you.

1. Be sure the .asoundrc file is in /your/home/.asoundrc directory
2. You may need the latest ALSA drivers, which was the case with me.

Those can be retrieved from the ATrpms repository for Fedora 3 and they work very well.

I'm posting again because I worked very hard to get sound working and it sounds like you are so close. Keep working at it. Fedora 3 is a fantastic distro. Kornerr had the last piece to my puzzle, God Bless him and thanks again Kornerr -- sorry for mispelling!

Good luck.

Last edited by mkoljack; 05-21-2005 at 01:36 PM.
 
Old 05-22-2005, 02:58 AM   #10
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
mkoljack, don't bless me
I'm not genius at all, I'm just crazy about asking quesions on LQ.org.
The first (and the only) man who helped me with ALSA was keefaz in Slackware thread
Thanks to keefaz!

PTrenholme, read the second post in this thread and give me the answer

And one good advice: visit sometimes Slackware, Gentoo, Debian and other "similar difficult distro's" threads - guys there are much smarter than we are
And, of course, try Slackware, Gentoo, Debian (of wich Slackware is easier for Linux beginners... like me)

Last edited by kornerr; 05-22-2005 at 03:00 AM.
 
Old 05-23-2005, 05:19 PM   #11
newbie007007
Member
 
Registered: Dec 2004
Location: India
Distribution: Fedora
Posts: 36

Original Poster
Rep: Reputation: 15
It has really been great to learn things from you all.
I am a newbie to linux.
My xmms is working fine.
Can anyone of you tell me is there anyway by which i can listen to two audio files simultaneously??

Thank you
 
Old 05-24-2005, 09:03 AM   #12
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
All what is described in post# 5 will help you. But only if you use ALSA as output plugin in all multimedia apps.
E.g., I can listen simultaneously to xmms, mplayer, (g)xine.

Quote:
I am a newbie to linux
We're all
 
Old 05-24-2005, 02:07 PM   #13
mkoljack
Member
 
Registered: Jan 2005
Location: Chicago
Distribution: Fedora Core 4, Suse 9.3
Posts: 186

Rep: Reputation: 30
Follow kornerr's instructions as stated in post 5. You have the abilty to play anything you want then through ALSA. It works perfectly. Be sure to turn off arts.

Good Luck!
 
Old 05-24-2005, 09:25 PM   #14
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
Quote:
Originally posted by kornerr
snip . . .
PTrenholme, read the second post in this thread and give me the answer
snip . . .
Well, just because I'm retired now, with lots of time on my hands, I decided to see how the final test release of FC4 was working. Interestingly, "out of the box" the sound seems to work without a hitch. (And there are lots of real cool improvements over FC3 in FC4.)

Anyhow, my sound needs are quite minimal (since my hearing's damaged from too much gun discharge noise in my youth) so I'm happy with [T]OSS on FC3, and ALSA on FC4. So, thanks for the offer to help, but I'll just let it slide for now.
 
Old 06-03-2005, 10:07 AM   #15
ravee
Member
 
Registered: Jan 2005
Location: India
Distribution: Fedora Core 2
Posts: 83

Rep: Reputation: 15
I had some problem with the sound card too. And I fixed it by installing alsa sound drivers. I have detailed it so that I will remember it at a future date as well as share it with others. You can read about it here:

http://linuxhelp.blogspot.com/2004/1...ipset-isa.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB drive not working properly, read only device? (USB key storage device) Arodef Linux - Hardware 14 01-01-2010 08:32 AM
Sound Device Not Working, Possible conflict between onboard/pci? Christopher Linux - Hardware 5 01-07-2005 04:57 PM
Sound device not working Dragonblade Linux - General 2 07-25-2004 06:05 PM
damn device=:0 not working gunslinger77 Linux - Software 0 06-10-2004 11:20 AM
no sound from cd player, good sound from audio device test fmickel Linux - Hardware 5 06-04-2004 01:46 PM


All times are GMT -5. The time now is 08:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration