LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   snd-hda-intel.ko disables PC speaker (http://www.linuxquestions.org/questions/linux-general-1/snd-hda-intel-ko-disables-pc-speaker-563759/)

rhubarbpie 06-22-2007 12:43 PM

snd-hda-intel.ko disables PC speaker
 
My PC speaker doesn't sound if I load the snd-hda-intel.ko module. I have PC speaker support compiled into the kernel and the speaker flawlessly if the snd-hda-intel.ko module isn't loaded.

Can I use my PC speaker with the snd-hda-intel.ko module loaded?

Simon Bridge 06-23-2007 05:26 AM

Do you have sound in general? (like through regular speakers?)

rhubarbpie 06-30-2007 05:27 PM

Yes, all other sound works well. My only problem is with my PC speaker.

Simon Bridge 07-01-2007 01:52 AM

So, what are you not getting through your system speaker that you expect to?
Looks like alsa is expecting to channel all sounds through your regular speakers.

rhubarbpie 07-01-2007 07:01 PM

Beeps. I want my Perl and bash scripts to beep. I also want my OpenOffice macros to sound beeps.

The problem seems to be the Intel HD Audio option:

Device Drivers --->
Sound --->
Advanced Linux Sound Architecture --->
PCI devices --->
<> Intel HD Audio

If I compile Intel HD Audio into the kernel or build it as a module I receive no PC speaker output. If I recompile the kernel without Intel HD Audio my PC speaker sounds. Unfortunately, I need it as a module for my modem. I do need my modem occassionally.

Simon Bridge 07-02-2007 12:08 AM

Why can your macros and scripts not use the alsa system beep?

http://www.mail-archive.com/alsa-use.../msg19938.html
http://osdir.com/ml/linux.alsa.user/.../msg00019.html
... both have the same problem, but there is no suggested solution.

Some people seem to have the opposite problem... PC speaker beep but no other sound. And there is the usual slew of people with no sound at all.

I am suspecting that the pcspkr driver is being turned off in a configuration file. Or, maybe, the alsa driver is just hogging all audio.

http://www.gentoo.org/doc/en/migration-to-2.6.xml
... points out that the PC speaker is a configurable option.
"CONFIG_INPUT_PCSPKR=m" is, presumably, how you compiled in support. I'm trying to find if this can be enabled/disabled dynamically.

Hmmm... I note that the system beep is disabled when I use beryl... it has a visual bell instead (wobbles the window). Thinking this through backwards and searching for ways to disable the beep shows me the file to look at is /etc/inputrc ... look for a line that says "set bell-style none"...

rhubarbpie 07-03-2007 09:17 PM

How can I use the alsa speaker beep? I see the Speaker bar in alsamixer which I set to maximum.

avalonit 03-06-2013 11:04 AM

Quote:

Originally Posted by rhubarbpie (Post 2809748)
How can I use the alsa speaker beep? I see the Speaker bar in alsamixer which I set to maximum.

What I did to enable pc speaker beeps is:
Code:

$ cat /etc/modprobe.d/00local.conf
options snd-hda-intel beep_mode=1

On my old computer it worked by itself but not on this one. Not sure why. It may have something with that this one has a hardware PC speaker while the other one did not. Anyway try it out. btw another thing that may help you is play with the model option of the same module. See available options with modinfo.


All times are GMT -5. The time now is 08:35 AM.