LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-25-2006, 03:10 PM   #1
bmeckle
Member
 
Registered: Jun 2004
Posts: 60

Rep: Reputation: 15
slow ftpd response


I am trying to script an ftp to run every minute, but when I connect to my ftp server (running ftpd) it takes like a minute for the prompt to come back. I believe this is caused by the server trying to do a DNS reverse lookup. Is there a way to turn off the reverse look up for ftp? Or a way to minimize the time out for this?

Thanks in advance.
 
Old 01-26-2006, 08:21 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Why not setup proper DNS settings instead? It might also be that your trying to use passive FTP, try toggling this setting as well.
 
Old 01-26-2006, 08:31 AM   #3
bmeckle
Member
 
Registered: Jun 2004
Posts: 60

Original Poster
Rep: Reputation: 15
Good point. Something that I also thought of. Unfortunately the reason it is set up this way is for security reasons. Also passive ftp needs to be used because traffic to and from the ftpd server is regulated by a firewall.

Looking at the man pages for nsswitch.conf I see something about a lookup time-out setting. Does anybody know anything about this?

Thanks in advance.

Bob
 
Old 01-26-2006, 03:52 PM   #4
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
You might try setting up the ftpd daemon as a stand alone process rather than having inetd spawn it on demand. I'm thinking that when inetd spawns your ftpd it has to read the binary off of the disk. If it was a running process then it wouldn't need to start a process and read the disk before it responded to your ftp connect request.

If you are using vsftp then instructions for setting this up are in the /etc/vsftp.conf file.
 
Old 01-27-2006, 07:57 AM   #5
bmeckle
Member
 
Registered: Jun 2004
Posts: 60

Original Poster
Rep: Reputation: 15
Thanks for the response. In researching the problem I found that Solaris 9 has an issue with this due to the way in.ftpd does not use nsswitch.conf for name resolution. It uses an older process, there is a patch to fix this, and we are currently in the process of applying this patch. This should allow us to set up an entry in /etc/hosts for this system and cut out the time out of the name resolution. In the mean time I removed the secondary DNS server from resolv.conf which cut the lookup time from over a minute to about 15 seconds.

Thanks, again for your responses.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
squid slow response ilnli Linux - Software 10 10-16-2006 11:56 PM
[SOLVED] Q3: Slow network response mattz40 Debian 9 04-05-2005 09:07 AM
Slow konsole response taarnak Linux - General 2 12-16-2003 05:43 PM
Slow response as ..... umok Linux - Newbie 4 07-11-2003 12:54 PM
Slow response on Mandrake 8.0 Droopy Linux - Networking 0 09-07-2001 09:16 PM


All times are GMT -5. The time now is 02:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration