LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Slow booting of w2k after redhat 8 installation (http://www.linuxquestions.org/questions/linux-general-1/slow-booting-of-w2k-after-redhat-8-installation-34089/)

teddy77 10-29-2002 01:43 AM

Slow booting of w2k after redhat 8 installation
 
i recently installed red hat 8.0 on my pc and have decided on a dual boot config. with w2k

The installation is fine and everything works well, except that the booting up of w2k has become really slow, i mean a noticeable big difference. I tried looking for information on this but have found nothing that works for me.

Heard that the problem is due to the linux partitions and how w2k takes time to figure out what these partitions are.

i have 2 HD (1) with w2k installation (2) linux partitions with 1 fat32 shared partition and 1 ntsf partition for w2k archive

any help will be much appreciated

deadbug 10-29-2002 06:08 PM

You wrote: i have 2 HD (1) with w2k installation (2) linux partitions with 1 fat32 shared partition and 1 ntsf partition for w2k archive

Do you have a Linux partition between two that Windows would understand? If I'm reading this correctly, your second drive has two or more Linux partions, physically followed by a FAT32 partition and an NTFS partition.

If this is the case, you have presented Windows with a problem it has a great deal of difficulty dealing with, because it doesn't understand anything but its formats. See my other dissertaion on a bridge over a river that now has a section missing.

To fix this, reconfigure your partitions. If you are giving Linux the beginning of the second drive, only have non-Windows formats on it.

Option #1 is to put the shared partitions at the end of disk #1 and dedicate disk #2 to Linux. If that isn't feasible, try Option #2.

Reinstall Linux (I'll get hate mail for this!) and change the order you put the second disk's partitions in. Put the Windows-compatible ones up front and the Linux ones at the back. This way our finicky Windows operating system encounters all of its known universe without holes.

This should get Windows back to its normal stodgy pace.

teddy77 10-30-2002 08:07 PM

but i though that the linux partitions have to be in the first 1024 of the hard drive? is this true?

MasterC 10-30-2002 08:55 PM

Nope...

;)

This might have been true of the boot loader back in the day, but now Linux is as versatile as it gets.

Cool

newpenguin 10-30-2002 09:03 PM

the search function is great.
http://www.linuxquestions.org/questi...ght=slow+win2k

and a person suggested there

solution to slow win2k with dual linux without fdisk shennanigins ( post #8)

Hey,

Had the exact same problem, huge delays in win2k boot/startup.
Using win2k/linux (RH7.3) dual boot, with the two OS's on different HDDs. Noticed that the linux drive was listed in the device manager of win2k (control panel->system->hardware tab->device manager) under "disk drives". Right-click the linux drive, select disable, and BAAM! - the system boots like it ain't five years ago.

Hope this helps,
Ryan

teddy77 11-01-2002 12:06 PM

thanks guys, problem fixed :)
Used deadbug's option 2 and everything worked nicely


All times are GMT -5. The time now is 01:29 PM.